#openstack-meeting-alt: rpm_packaging

Meeting started by dirk at 13:00:29 UTC (full logs).

Meeting summary

  1. roll call (dirk, 13:00:59)
    1. https://etherpad.openstack.org/p/openstack-rpm-packaging (dirk, 13:01:20)

  2. Newton schedule update (dirk, 13:06:21)
    1. https://releases.openstack.org/newton/schedule.html (dirk, 13:06:31)

  3. feedback for renderspec improvals (see https://review.openstack.org/#/c/360919/ ) (toabctl) (dirk, 13:16:15)
    1. https://review.openstack.org/#/c/360919/ (dirk, 13:16:22)

  4. python3 renderspec (dirk, 13:22:33)
    1. https://etherpad.openstack.org/p/openstack-rpm-packaging-python3-renderspec (dirk, 13:22:40)

  5. Extend pymod2pkg to include mapping between PyPi module name and OpenStack project name (dirk, 13:25:25)
    1. ACTION: dirk get back to IgorYozhikov on the python3 proposal (dirk, 13:25:34)
    2. ACTION: jpena post review (dirk, 13:30:11)

  6. Including test directories in package (dirk, 13:30:23)
    1. https://github.com/openstack/python-neutronclient/blob/cccc7f7fb0cecb585a8a250c11c22e2135838b47/neutronclient/tests/unit/osc/v2/trunk/test_network_trunk.py#L21 (IgorYozhikov, 13:40:57)
    2. AGREED: keep tests inside main package for now, revisit topic potentially later (dirk, 13:49:29)

  7. Core reviewer additions (dirk) (dirk, 13:49:41)
  8. open floor (dirk, 13:53:21)
    1. ACTION: dirk send mail about new core members to openstack-dev (dirk, 13:53:33)


Meeting ended at 14:00:28 UTC (full logs).

Action items

  1. dirk get back to IgorYozhikov on the python3 proposal
  2. jpena post review
  3. dirk send mail about new core members to openstack-dev


Action items, by person

  1. dirk
    1. dirk get back to IgorYozhikov on the python3 proposal
    2. dirk send mail about new core members to openstack-dev
  2. IgorYozhikov
    1. dirk get back to IgorYozhikov on the python3 proposal
  3. jpena
    1. jpena post review
  4. openstack
    1. dirk send mail about new core members to openstack-dev


People present (lines said)

  1. dirk (92)
  2. IgorYozhikov (48)
  3. jpena (30)
  4. number80 (24)
  5. toabctl (18)
  6. itxaka (7)
  7. openstack (5)


Generated by MeetBot 0.1.4.