13:01:57 <dirk> #startmeeting rpm_packaging
13:01:57 <openstack> Meeting started Thu Sep 29 13:01:57 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:01 <openstack> The meeting name has been set to 'rpm_packaging'
13:02:02 <dirk> #topic roll call
13:02:13 <jpena> o/
13:02:14 <toabctl> hi
13:02:15 <number80> o/
13:03:09 <number80> ping dirk toabctl IgorYozhikov number80 jruzicka jpena aplanas
13:04:21 <number80> IgorYozhikov: ?
13:04:36 <IgorYozhikov> o/
13:05:02 <number80> ok, let's start
13:05:11 <number80> dirk: ?
13:05:48 <dirk> yes, sorry
13:06:16 <dirk> #topic Chair for the next two weeks (hguemar absent on october, 6)
13:06:24 <dirk> I'm also absent very likely
13:06:34 <number80> anyone's up for october, 6 at least?
13:06:35 <dirk> I can probably do the week after
13:06:48 <jpena> I can do Oct 6
13:06:51 <number80> #info dirk chairing october,13 meeting
13:06:57 <IgorYozhikov> I can also
13:06:58 <number80> #info jpena chairing october,6 meeting
13:07:01 <number80> ah right
13:07:10 <IgorYozhikov> ah, ok
13:07:12 <dirk> #topic promote SUSE and MOS CI to voting gates (final decision)
13:07:32 <number80> no opposition on the list, anyone who disagree with promotion?
13:07:44 <jpena> no, +1 for me
13:07:48 <toabctl> +1
13:07:51 <number80> +1
13:08:01 <dirk> +1
13:08:03 <IgorYozhikov> update from MOS side: we will handle stable/newton after branching process done in our downstream
13:08:08 <IgorYozhikov> so for master +1
13:08:18 <IgorYozhikov> let's make them voting
13:08:21 <number80> I checked with infra-root earlier, and we're now able to add gates to rpm-packaging-ci group
13:08:21 <toabctl> dirk, SUSE CI already handles stable/newton, right?
13:08:25 <dirk> toabctl: yes
13:08:30 <dirk> there were a few hickups in the last few days
13:08:36 <astsmtl> Or, we can do it sooner if need arises.
13:08:36 <dirk> also caused by a broken harddrive and other issues
13:08:40 <dirk> but things should be good again
13:08:59 <IgorYozhikov> our branching in progress
13:09:17 <IgorYozhikov> believe that it takes a week
13:09:28 <number80> IgorYozhikov: ping me when you're done and I'll add MOS CI
13:09:28 <IgorYozhikov> so very soon we could handle newton too
13:09:38 <IgorYozhikov> number80, sure
13:09:40 <number80> dirk, toabctl: suse CI is ready?
13:09:45 <dirk> number80: yes
13:09:47 <toabctl> number80, yes
13:09:50 <astsmtl> You can add MOS CI as voting right now for every branch.
13:09:53 <number80> ok, I'll get it added today
13:10:04 <astsmtl> It just won't vote in stable/newton.
13:10:10 <number80> astsmtl: if you say so, I'll add it then :)
13:10:13 <dirk> number80: thanks. youcould do in theory yourself once permissions are changed in gerrit
13:10:19 <dirk> but for now you need an infra root
13:10:26 <number80> dirk: perms were fixed
13:10:31 <dirk> oh, great
13:10:52 <dirk> astsmtl: you need to change config then to remove the non-voting flag fyi
13:11:12 <dirk> #action number80  change gate checks to allow voting for SUSE ci + mos ci
13:11:20 <dirk> #action dirk change suse ci to propagate voting
13:11:24 <astsmtl> I thought we'll make one CR for both CI systems
13:11:44 <astsmtl> If not, we can modify config for MOS CI separately.
13:11:48 <dirk> astsmtl: I think it is a dual change. once "allowing voting" and one "do vote"
13:12:01 <dirk> the "do-vote" thing is a option in your local zuul
13:12:10 <number80> ok, added
13:12:22 <IgorYozhikov> :)
13:12:29 <dirk> #topic package reviews
13:12:41 <dirk> #link https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open
13:12:51 <dirk> anything somebody wants to bring up
13:12:56 <dirk> in general things seem to be progressing
13:13:18 <dirk> there are two reviews that are stalled
13:13:26 <dirk> https://review.openstack.org/#/c/357361/
13:13:31 <dirk> this one depends on python-mistral
13:13:39 <dirk> does anyone want to create a mistral package in rpm-packaging?
13:13:52 <dirk> it doesn#t have to be perfect, just good enough to satisfy the dependency :)
13:13:56 <astsmtl> JFYI, I'm working on ceilometer.
13:14:07 <number80> I wouldn't start with mistral for service personally
13:14:19 <jpena> I think IgorYozhikov wanted to prepare a mistral package
13:14:22 <dirk> well, it blocks the whole tripleo related packages from going in
13:14:23 <astsmtl> And btw, maybe we want some tool to sync on who does what?
13:14:24 <IgorYozhikov> I believe - we can
13:14:25 <dirk> so it is important
13:14:31 <astsmtl> Maybe etherpad?
13:14:49 <dirk> gerrit?
13:14:56 <dirk> feel free to post a unfinished review
13:15:05 <dirk> at least I'm somewhat good at checking for duplicates..
13:15:07 <astsmtl> In Mirantis we use Google Spreadsheet for that.
13:15:08 <toabctl> +1 for gerrit.
13:15:14 <astsmtl> Ok.
13:15:15 <number80> Yep
13:16:03 <dirk> so can we at least have a mistral package that fulfills the tripleoclient deps?
13:16:11 <dirk> just not package services and all the other stuff?
13:16:24 <dirk> we can add that later, but I hate to see other things blocked on it right now
13:16:40 <number80> well, tripleoclient should be renamed as triplemessclient
13:16:46 <toabctl> lol
13:16:51 <number80> not the easiest one to work on
13:16:56 <dirk> alternatively we can remove the test dep
13:17:03 <dirk> it is only for testing iirc, maybe we can get rid of it
13:17:09 <number80> it requires quite a lot of things like heat-templates etc ...
13:17:27 <number80> so mistral packaging alone won't unblock that review
13:17:33 <dirk> jpena: wanna try to reduce %check so that we can live without mistral?
13:17:36 <IgorYozhikov> so mistral & heat?
13:17:44 <jpena> dirk: I'll give it a try
13:18:20 <dirk> #action jpena  try removing mistral from *triplo* review s for now
13:18:23 <dirk> jpena: thanks!
13:18:33 <IgorYozhikov> Am I right that we are going to cut mistral from test depends to unlock 3-O*?
13:19:00 <dirk> yes
13:19:09 <dirk> at least give that a try
13:19:18 <IgorYozhikov> ok
13:19:29 <dirk> alternatively if somebody has a mistral package, post a review :)
13:19:39 <number80> *nods*
13:19:43 <dirk> but we are running out of clients right now, we need to start with services
13:20:02 <IgorYozhikov> dirk, I will try to do that
13:20:16 <dirk> thanks
13:20:25 <dirk> anything else on rpm-packaging?
13:20:58 <IgorYozhikov> dirk, colleagues did you have a chance to contact out newcomers?
13:21:31 <IgorYozhikov> I'm about Chinese folks?
13:21:50 <dirk> I think number80  wanted to send an email
13:21:52 <dirk> I haven't
13:21:54 <IgorYozhikov> s/out/our/
13:21:59 <dirk> but they seem to be active right now
13:22:06 <dirk> maybe we could invite them here..
13:22:32 <IgorYozhikov> I posted in one of reviews invitation to irc
13:22:38 <number80> Yeah, I haven't yet
13:23:12 <number80> if nobody does, I will do today or tomorrow
13:23:35 <toabctl> I pinged tony in #rpm-packaging
13:24:00 <number80> I'd like to channel their efforts, as some of the clients they submitted needs proper checking (e.g requirements etc...)
13:24:27 <number80> so more focused reviews, to have a faster throughput
13:24:38 <IgorYozhikov> yep, I saw them
13:24:54 <IgorYozhikov> will spend some time today & tomorrow on that
13:24:57 <dirk> number80: yeah, it would also be good to explain tha tyou can fix more than one character per git commit  :)
13:25:06 <dirk> e.g. all the url changes could have been done in one review
13:26:05 * number80 notes to add that point
13:26:17 <number80> Yes, these do not affect builds so it can be done in one go
13:26:30 <dirk> anyway, no harm done, I'm fine either way
13:26:43 <dirk> I took the liberty to fastapprove those trivial changes to reduce workload for others
13:26:49 <number80> wfm
13:27:18 <IgorYozhikov> dirk, https://review.openstack.org/#/c/378444/ - didn't pass SUSE CI
13:27:39 <IgorYozhikov> in that PR url changed
13:27:40 <dirk> IgorYozhikov: thats a flakey test
13:27:46 <dirk> oslo.messaging fails like 50% of the cases right now
13:27:46 <IgorYozhikov> i c
13:27:53 <dirk> I don't know exactly why, but it is fairly annoying
13:28:08 <dirk> it is not visible in the mos ci because it only rebuilds one package, while we always rebuild everything against everything
13:28:40 <dirk> I was already searching in oslo.messaging git whether there is a fix somewhere but couldn't pinpoint one
13:28:43 <IgorYozhikov> yes, mos ci rebuilds only changed
13:29:11 <dirk> I would love to get that one nailed though
13:29:36 <dirk> next?
13:29:52 <dirk> #topic pymod2pkg reviews
13:30:04 <dirk> #link https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open
13:30:22 <IgorYozhikov> https://review.openstack.org/#/c/379419/1/pymod2pkg/__init__.py
13:30:48 <IgorYozhikov> look like only 1 PR awaiting
13:31:11 <number80> no controversies here
13:31:25 <dirk> #topic renderspec reviews
13:31:33 <dirk> #link https://review.openstack.org/#/q/project:openstack/renderspec+status:open
13:31:54 <dirk> anything there?
13:32:09 <number80> same here, if some can +W the g-r one
13:32:13 <jruzicka> I'd drom https://review.openstack.org/#/c/336151/
13:32:16 <jruzicka> *drop
13:32:36 <IgorYozhikov> omg, dirk, number80 is it normal that I have verified option enabled?
13:32:38 <toabctl> me too
13:32:40 <dirk> ah, thats a good one
13:32:52 <dirk> to be honest I can't make up my mind on this one
13:32:56 <dirk> I see good in either approach
13:32:57 <number80> IgorYozhikov: let's see in the other chan
13:33:27 <jruzicka> yeah but it's in a bad -1 state
13:33:30 <number80> ok, how about discussing it in the mailing list?
13:33:42 <number80> astsmtl: do you feel like driving that discussion?
13:33:44 <jruzicka> you mean postponing even further
13:33:50 <astsmtl> I want to update this CR.
13:34:06 <jruzicka> astsmtl, OK, please do.
13:34:07 <toabctl> it's changing the current default behavior.
13:34:09 <toabctl> ok
13:34:15 <astsmtl> Let return do discussion after that.
13:34:20 <jruzicka> great
13:34:20 <number80> jruzicka: no, just want to avoid eternal postponing, because nobody can take a final decision on the design
13:34:50 <jruzicka> we got our next step there, so I'm happy
13:34:55 <dirk> ok
13:35:06 <dirk> can someone summarize the next step in an agreed statement for the bot ?
13:35:20 <jruzicka> toabctl, how's the {{ requires going }} ?
13:35:28 * jruzicka summarizing
13:35:38 <toabctl> jruzicka, no progress. I was on vacation (and will be on vacation again)
13:36:06 <jruzicka> #action astsmtl to upload next version of https://review.openstack.org/#/c/336151/ before continuing discussion
13:36:14 <dirk> jruzicka: thx
13:36:18 <dirk> #topic open discussion
13:36:54 <jpena> can I haz new releases for renderspec and pymod2pkg? They'll be useful to complete DLRN support for the 3rd party CI
13:37:15 <number80> jpena: sure
13:37:21 <jruzicka> oh, right, how do one make a relese btw?
13:37:25 <jpena> thx :)
13:37:27 <jruzicka> is just pushing verison tag enough?
13:37:32 <number80> jruzicka: sending a review to releases repo
13:37:38 <jruzicka> ah yes
13:37:44 * number80 will take care of that
13:38:02 <jruzicka> #action number80 to release new versions of pymod2pkg and renderspec with latest fixes
13:38:15 <jruzicka> wait I'm not chair :D
13:38:17 <number80> I'd like to finalize summit fishbowl agenda, there was no new changes for a while, are we good?
13:38:20 <number80> yes
13:38:44 <dirk> jruzicka: sorry
13:38:51 <jruzicka> my bad, I came late
13:38:53 <dirk> #chair jruzicka  number80  IgorYozhikov  toabctl jpena astsmtl
13:38:54 <openstack> Current chairs: IgorYozhikov astsmtl dirk jpena jruzicka number80 toabctl
13:39:05 <jruzicka> #action astsmtl to upload next version of https://review.openstack.org/#/c/336151/ before continuing discussion
13:39:08 <jruzicka> #action number80 to release new versions of pymod2pkg and renderspec with latest fixes
13:39:17 <astsmtl> Oh, sorry guys, seems like I was wrong, and I will no do another version of this request
13:39:33 <astsmtl> s/no/not
13:39:41 <jruzicka> even better!
13:39:43 <number80> astsmtl: you mean the renderspec change or something else?
13:39:50 <jruzicka> astsmtl, please abandon it in that case
13:39:51 <astsmtl> So we can discuss it here or in ML.
13:39:54 <number80> yes
13:40:22 <astsmtl> I won't abandon it, because I believe that this beahviour is much better than what we have now.
13:40:33 <jruzicka> so I didn't understand your sentence, then
13:41:57 <astsmtl> :D
13:42:21 <astsmtl> I mean - I can't improve it more. :P
13:42:50 <jruzicka> oh I see
13:43:11 <number80> then, let's discuss about design, and make choices
13:43:32 <number80> Until we do so, nobody will agree on what to do with this review
13:43:47 <dirk> so I think what astsmtl  wants to do is
13:43:54 <dirk> "if a file was given as argument, and it doesn't exist, fail"
13:44:07 <jruzicka> yes, reasonable
13:44:09 <dirk> "if a file was not given explicitely but is the default, then *fail* as well"
13:44:14 <dirk> right?
13:44:36 <dirk> and the latter part is what jruzicka objects to, right?
13:44:43 <astsmtl> No, if file was not specified we don't want to fail.
13:44:58 <dirk> ah, ok
13:45:21 <dirk> so if it was not specified explictly on command line but the implict one does not exist, silently ignore that
13:45:29 * number80 will revisit review again
13:46:14 <jruzicka> yeah but then I found out the default isn't used
13:46:15 <astsmtl> Oh.. again no.
13:46:31 <jruzicka> and it's also outside of current dir which is maddness
13:46:45 <astsmtl> There cannot be default values for these files.
13:46:48 <jruzicka> I'll revisit it too.
13:46:57 <jruzicka> astsmtl, oh there can as well as requirements.txt is
13:47:12 <astsmtl> So if you want them to affect render process - you specify them explicitly.
13:47:41 <number80> astsmtl: I'll add it to next week meeting agenda, so it doesn't drag further
13:48:13 <jruzicka> astsmtl, templates that are part of renderspec also affect render process yet you don't need to pass them
13:48:28 <astsmtl> Because they are part of renderspec.
13:48:50 <astsmtl> If we make global-requirements.txt and epochs part of renderspec, they can be used by default.
13:48:52 <jruzicka> yes and we can have a convention for arbitrary files that affect the rendering process
13:49:14 <astsmtl> That was my idey, that I reconsidered.
13:49:18 <jruzicka> if sane and well documented, I'm always for tools that work without parameters for the default use case
13:49:22 <astsmtl> s/idey/idea/
13:49:48 <astsmtl> Well, propose good default value then.
13:49:50 <jruzicka> I'm not aware about such convention now, so we can remove this unused magic
13:49:56 <jruzicka> and reintroduce it when needed
13:50:07 <toabctl> hi TonyXu
13:50:16 <jruzicka> astsmtl, yes, alternative to your change would be a good default :)
13:50:34 <astsmtl> Not alternative but addition I think.
13:50:50 <jruzicka> removing the removal :D
13:51:02 <jruzicka> sure. I'll revisit the review until next meeting
13:51:33 <astsmtl> My change has an important point that specified non-existing files should lead to failure.
13:51:39 <jruzicka> explicit is good unless you don't need to be explicit about obvious things that are same 90 % of time :)
13:51:56 <dirk> astsmtl: hmm, so one thing we could do is require a single "--context" parameter that refrences all files that should be used for rendering a spec
13:52:07 <dirk> if its not given, we abort
13:52:19 <dirk> if it is given, we have pointers to everything that will be considered that way
13:52:54 <jruzicka> but do we use epoch.yaml in the render process?
13:52:59 <dirk> then jruzicka  is still happy because he could alias "renderspec" to "renderspec --context fedora-with-all-my-epochs-and-deps" and be good
13:53:06 <astsmtl> It's the same as current request.
13:53:24 <dirk> astsmtl: ok, I guess I didn't read that out of the existing git commit message
13:53:26 <jruzicka> well I'm OK with current concept (the second revision)
13:53:37 <dirk> I might have had a bad understanding
13:53:38 <jruzicka> just need to test it again
13:53:53 <jruzicka> let's stop this
13:54:00 <dirk> ok
13:54:08 <dirk> #action jruzicka revisit https://review.openstack.org/#/c/336151/2
13:54:09 <jruzicka> all information required has been transfered
13:54:13 <jruzicka> yes
13:54:19 <dirk> great, thanks astsmtl  and jruzicka
13:54:23 <astsmtl> :)
13:54:23 <dirk> anything else before we end?
13:55:16 <IgorYozhikov> nope
13:55:24 <dirk> ok, cya, and toabctl, don't make too much vacation ;)
13:55:26 <dirk> #endmeeting