13:00:19 <jpena> #startmeeting rpm_packaging
13:00:20 <openstack> Meeting started Thu Oct  6 13:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:23 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:26 <jpena> #topic roll call
13:00:33 <toabctl> hi
13:00:42 <jpena> #chair toabctl IgorYozhikov
13:00:43 <openstack> Current chairs: IgorYozhikov jpena toabctl
13:00:59 <dirk> o/
13:01:05 <jpena> #chair dirk
13:01:05 <openstack> Current chairs: IgorYozhikov dirk jpena toabctl
13:01:14 <dirk> thanks
13:02:35 <jpena> number80 can't attend today, not sure about jruzicka
13:03:06 <number80> I'll be around but do not block on me (conference wifi being the reason)
13:03:29 * dirk too, but probably different conference :)
13:03:31 <jpena> shall we start with the agenda, then?
13:03:38 <toabctl> yes
13:03:41 <IgorYozhikov> ok
13:03:51 <jpena> #topic Project Team Gathering
13:04:22 <number80> yep, who thinks he could manage to get there?
13:04:45 <number80> I'm not sure we can send out someone from RDO side (but I'll try asking to get few of us there)
13:04:55 <number80> Mirantis, Suse?
13:05:02 <number80> anyone else?
13:05:14 <IgorYozhikov> number80, what kind of meeting? could you please clarify :)
13:05:21 <dirk> IgorYozhikov: see email
13:05:29 <number80> IgorYozhikov: PTG are replacement of design summit/mid-cycles
13:05:39 <number80> it'll be in Atlanta in Feb.
13:05:52 <IgorYozhikov> ah, I saw that one
13:06:03 <toabctl> not sure from my side. need to ask
13:06:08 <IgorYozhikov> do not have clear answer now
13:06:12 <IgorYozhikov> :(
13:06:23 <IgorYozhikov> require to talk to mgmt 1st
13:06:30 <number80> let me know, when you have definitive or semi-definitive answers
13:06:40 <IgorYozhikov> sure
13:06:44 <jruzicka> o/
13:06:51 <jpena> according to the e-mail, we can provide an answer until Oct 16, so we could ask during the week and gather the output during next week's meeting
13:06:56 <dirk> I guess the major topic we need to decide on is whether we want to have a room allocated
13:06:57 <jpena> #chair jruzicka
13:06:59 <openstack> Current chairs: IgorYozhikov dirk jpena jruzicka toabctl
13:07:10 <IgorYozhikov> got it
13:07:24 <dirk> for me personally I would prefer if it would be in europ in that week but that is not the case :)
13:07:33 <dirk> I will be there, at least partially
13:08:05 <dirk> we could also decide to schedule a pure-virtual meeting I guess at the same time
13:08:13 <dirk> but that misses all the fun of being in atlanta
13:08:34 <IgorYozhikov> dirk - it is a good idea
13:08:44 <IgorYozhikov> i mean every1 could join
13:10:33 <IgorYozhikov> anyway - will clarify this question with mgmt and provide answers
13:10:53 <number80> ack
13:11:24 <jpena> so we'll discuss it again next week?
13:12:41 <IgorYozhikov> why not - 1 week should be enough i think to ask and get back with preliminary results :)
13:13:26 <jpena> #action Discuss it again next week, after we have gathered mgmt input
13:13:49 <jpena> let's move on to the next topic, then
13:13:58 <jpena> #topic packages reviews
13:14:41 <jruzicka> astsmtl`'s epoch patch has been merged
13:15:31 <jpena> I need to look at the mistral patch, I'd love to get that in to unblock the tripleo stuff
13:15:35 <IgorYozhikov> I'm trying to build mistral as promised, not very successfully
13:16:05 <IgorYozhikov> at 1st I want to reach green builds
13:16:16 <IgorYozhikov> after that will fix linter errors
13:16:26 <astsmtl`> \o/
13:17:22 <jpena> is there any review that needs special attention?
13:17:42 <IgorYozhikov> toabctl, https://review.openstack.org/#/c/382196/
13:17:48 <IgorYozhikov> https://build.opensuse.org/project/monitor/home:suse-cloud-ci:rpm-packaging-sles12-Master-439b366e7579c415857de0735eaa599d9cc265c0?blocked=0&building=0&dispatching=0&finished=0&scheduled=0&signing=0&succeeded=0
13:17:55 <toabctl> there is the question about systemd service files and config handling
13:18:17 <toabctl> IgorYozhikov, I'll have a look later
13:18:20 <dirk> IgorYozhikov: looks like there are a few issues in teh suse ci, will take a look at that
13:18:25 <IgorYozhikov> I see a lot of packages in unresolvable
13:18:26 <dirk> for mistral
13:18:54 <IgorYozhikov> toabctl, yes, what questions?
13:19:01 <toabctl> IgorYozhikov, see comments in https://review.openstack.org/#/c/379784/
13:19:36 <toabctl> IgorYozhikov, would be nice if somebody from mirantis could comment there, too
13:20:05 <toabctl> but we don't have to discuss it here now I guess
13:20:20 <IgorYozhikov> o i c, will take a look, thanx
13:20:32 <dirk> IgorYozhikov: main issue with mistral is probably the missing zaqarclient
13:21:37 <IgorYozhikov> dirk, thanks, so it means that we need to package it 1st in rpm-packaging
13:21:41 <dirk> number80: do you plan to fix the zaqarclient review any time soon? :)
13:21:44 <IgorYozhikov> right?
13:21:56 <dirk> it is open since ~ 3 months
13:22:06 <dirk> or can anyone else help out
13:22:29 <number80> dirk: I'll look after GA release
13:22:40 <number80> (litterally after finishing the builds)
13:23:47 <number80> (FYI, GA releases have been merged in gerrit)
13:24:06 <jpena> btw, I've proposed a renderspec release including the latest patch: https://review.openstack.org/382549
13:27:09 <IgorYozhikov> toabctl, I read comments related to multi configuration service setup in unit files
13:27:26 <toabctl> IgorYozhikov, yes
13:27:49 <IgorYozhikov> looks fine, i just want to test such kind of setup 1st
13:28:41 <IgorYozhikov> and all these conf dirs should be created from spec files
13:28:44 <toabctl> IgorYozhikov, the only thing you need to take care about is that the files/dirs need to exists
13:28:47 <toabctl> yes
13:29:38 <toabctl> IgorYozhikov, I've already written a sample program where you can play with some options and see which parameters win if you use multiple config-file/config-dir parameters : https://gist.github.com/toabctl/58504087cd0c6adf63f1d6eb1573c279
13:30:03 <IgorYozhikov> fine, 1 concern here - does matter order of conf files?
13:30:17 <toabctl> IgorYozhikov, it does. that's the whole point for the change
13:30:18 <IgorYozhikov> ah, ok - that is exactly what I'm asking
13:30:41 <toabctl> last mentioned file wins. for config-dir, last file in order wins
13:31:11 <IgorYozhikov> got it
13:32:38 <IgorYozhikov> moving next? anything more interesting 4 review?
13:33:08 <jpena> nothing for me, so let's move on
13:33:14 <jruzicka> yup, let's move on
13:33:24 <jpena> there's no open pymod2pkg review
13:33:50 <jpena> same for renderspec, just a WIP review by toabctl
13:33:56 <jpena> anything to mention there? ^^
13:34:02 <toabctl> no news there. still WIP
13:34:33 <jpena> ok then
13:34:35 <jpena> #topic open floor
13:34:47 <jpena> we still have 25 minutes
13:35:27 <jruzicka> 25 minutes saved ;)
13:35:33 <toabctl> I guess we are fast today :-)
13:35:40 <jpena> ok, if nobody has anything to add, we can close the meeting
13:35:49 <jpena> #endmeeting