13:01:46 <dirk> #startmeeting rpm_packaging
13:01:47 <openstack> Meeting started Thu Oct 13 13:01:46 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:51 <openstack> The meeting name has been set to 'rpm_packaging'
13:01:59 <toabctl> hi
13:02:02 <dirk> ping dirk toabctl IgorYozhikov number80 jruzicka jpena aplanas
13:02:04 <jpena> o/
13:02:14 <dirk> #chair toabctl jpena
13:02:15 <openstack> Current chairs: dirk jpena toabctl
13:02:16 <number80> pong
13:02:17 <dirk> #topic roll call
13:02:21 <number80> o/
13:02:23 <dirk> #chair number80
13:02:24 <openstack> Current chairs: dirk jpena number80 toabctl
13:02:44 <dirk> everyone, please update the meeting agenda here
13:02:48 <dirk> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
13:04:51 <dirk> should we start?
13:04:54 <toabctl> yes
13:04:56 <number80> yes
13:04:59 <dirk> #topic  Project Team Gathering
13:05:10 <dirk> should RPM packaging consider having meetings ?
13:05:16 <dirk> so I think we have to fill in the form until end of this week
13:05:29 <dirk> not sure, toabctl number80  have you finalized travel plans?
13:05:32 <number80> From RH, we'll have a representative (best-effort)
13:05:37 <toabctl> so who's going to atlanta? I don't have an approval yet..
13:05:45 <jruzicka> barcelona?
13:05:53 <toabctl> jruzicka, atlanta in feb2017
13:06:00 <jruzicka> oh
13:06:08 <number80> jruzicka: Atlanta PTG, we have to tell the foundation if they have to save us some space or not
13:06:35 <dirk> number80: so do we have to say 'yes' or can we say 'maybe' ?
13:07:36 <number80> dirk: if there's at least 2 other people, I'd say yes, otherwise, no
13:09:46 <dirk> IgorYozhikov: any opinion?
13:10:35 <dirk> number80: so for me I can not commit to anything. I would like to go but the particular week I have a very hard time going far away
13:11:04 <number80> dirk: is it possible to know if suse can send at least one person?
13:13:27 <dirk> number80: do you mean a person related to rpm-packaging or in general?
13:13:44 <number80> dirk: in general is good enough
13:13:57 <dirk> for general, we will definitely send a number of people
13:14:11 <number80> ok, let's settle to maybe
13:14:40 <number80> worst-case will be trying to have something common with debian packaging folks
13:14:57 <dirk> works for me
13:15:01 <number80> #action hguemar answer foundation to save some space for PTG (maybe)
13:15:12 <dirk> #agreed  settle to maybe do something common with debian fols
13:15:17 <toabctl> sounds good
13:15:54 <dirk> #topic pre-release version handling: https://review.openstack.org/#/c/384622
13:16:36 <toabctl> ah. so while starting to package services there was a discussion in the ceilometer review about version handling
13:16:58 <toabctl> fedora is using a combination of the version/release tag while suse uses only the version + '~'
13:17:25 <toabctl> so I created a renderspec patch to handle both cases. Not sure if I did it correct for fedora so reviews welcome.
13:17:36 <toabctl> that's it basically if you have no comments/questions
13:18:04 <number80> I'll look at it but yes, it's not easy
13:18:54 <dirk> anything else on this?
13:18:57 <toabctl> ok. then next topic
13:18:59 <toabctl> nope
13:19:08 <dirk> #topic packages reviews
13:19:17 <dirk> #link https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open
13:19:39 <toabctl> there are a couple of things waiting for the MOS CI but I think IgorYozhikov is working on that
13:19:51 <dirk> right
13:20:34 <jpena> I have a question about https://review.openstack.org/385049
13:21:13 <jpena> based on the review feedback, it looks like a macro is preferred in openstack-macros. I can prepare a patch, just wanted to know if we all agree on that
13:22:11 <toabctl> sounds better to me, yes
13:24:00 <dirk> jpena: I'm fine with teh macro
13:24:24 <number80> ack for rpm macros
13:24:42 <dirk> #agreed rework https://review.openstack.org/385049 to use a macro
13:25:44 <jpena> ack, thanks
13:26:33 <dirk> anything else? I have not had time to review the current patch queue before meeting
13:26:50 <dirk> #topic https://review.openstack.org/#/q/project:openstack/renderspec+status:open
13:27:04 <dirk> we have only one review there for the version handling
13:27:06 <dirk> which we already talked about
13:27:08 <dirk> so ..
13:27:10 <dirk> #topic open floor
13:27:51 <dirk> anything that we have to discuss before barcelona ?
13:27:56 <dirk> I might not be able to join next week's meeting
13:28:08 <dirk> ah, one more thing.. timezone
13:28:32 <dirk> I think the meeting just moves an hour earlier when we switch DST off, right?
13:28:47 <dirk> is that an issue for anyone?
13:30:49 * dirk checks whether he has still internet
13:31:15 <jpena> not an issue for me
13:33:41 <toabctl> are we done?
13:33:53 <dirk> looks like
13:34:00 <dirk> last words..? 3..2..1.. ?
13:34:09 <dirk> number80 can you do the chair next time?
13:34:10 <toabctl> ciao
13:34:43 <dirk> #endmeeting