13:02:04 <IgorYozhikov> #startmeeting rpm_packaging
13:02:05 <openstack> Meeting started Thu Nov 17 13:02:04 2016 UTC and is due to finish in 60 minutes.  The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:09 <openstack> The meeting name has been set to 'rpm_packaging'
13:02:21 <jpena> o/
13:02:30 <IgorYozhikov> Hi, let's spend sometime on agenda https://etherpad.openstack.org/p/openstack-rpm-packaging
13:03:14 <dirk> o/
13:03:22 <IgorYozhikov> #chair IgorYozhikov dirk
13:03:23 <openstack> Current chairs: IgorYozhikov dirk
13:05:24 <toabctl> hi
13:05:36 <IgorYozhikov> nice 2 c u toabctl
13:05:43 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
13:06:03 <IgorYozhikov> ok, if we are done with agenda - let's start
13:06:57 <IgorYozhikov> #topic - keystone https://review.openstack.org/396262 + naming of some of python projects like memcached & ldap (python-python-foo?) (IgorYozhikov)
13:07:35 <IgorYozhikov> I see that most of ppl are here and want to discuss keystone
13:07:47 <IgorYozhikov> and here I have 2 questions
13:08:02 <IgorYozhikov> let me start from the tail of topic
13:08:53 <IgorYozhikov> question is mostly for SUSE side - is it normal from perspective of naming policy that some of packages has python-python-*?
13:09:05 <dirk> it can happen, yes
13:09:12 <dirk> policy is python-$pypi_name
13:09:23 <dirk> so if pypi_name includes python- , then it will be python-python-foo
13:09:42 <dirk> in the case of python-ldap, the pypi name is ldap, so it would be python-ldap
13:10:00 <dirk> (and we use pyldap anyway, so the question is mood, proper name is python-pyldap in the suse sense)
13:10:14 <IgorYozhikov> ah, so I'll will update my PR and uncomment strings like # Requires:       {{ py2pkg('python-ldap') }}
13:10:29 <dirk> well, thats wrong anyway
13:10:36 <dirk> it should be py2pkg("pyldap") :-)
13:11:01 <IgorYozhikov> got it and what about python-memcached?
13:12:03 <dirk> the pypi name is python-memcached, our suse package name is python-python-memcached
13:12:56 <IgorYozhikov> dirk, I can't find ldap on pypi, only https://pypi.org/simple/python-ldap/
13:13:08 <IgorYozhikov> might be I'm doing something wrong?
13:13:54 <dirk> IgorYozhikov: anyway, keystone uses pyldap..
13:14:08 <IgorYozhikov> I got it, will build this dependency
13:14:51 <IgorYozhikov> so, it's become clear about naming
13:15:14 <IgorYozhikov> so let's discuss keystone
13:15:22 <IgorYozhikov> I need a feedback
13:16:06 <IgorYozhikov> I found that testrepository is using all available vcpu and fails ^(
13:16:21 <dirk> IgorYozhikov: can you remove the -2 then? I'll give it a review round..
13:16:25 <IgorYozhikov> so I set export TEST_RUN_CONCURRENCY=1 flag to run tests in 1 by 1
13:16:32 <IgorYozhikov> sure
13:16:46 <IgorYozhikov> done
13:17:37 <IgorYozhikov> also, is it necessary to add apache as run-time dependency?
13:18:08 <IgorYozhikov> or it should be done from perspective of cms side(puppet|chef|ansible|...)?
13:18:26 <dirk> coincidentally we're just debating that wsgi stuff as well
13:18:38 <dirk> some of our packages have it some don't
13:18:43 <dirk> its not necessary from cms side
13:19:06 <dirk> I guess we should take a decision and do it that way for all openstack services..
13:19:18 <IgorYozhikov> toabctl suggested to do not include a sub-package like keystone-apache
13:19:33 <IgorYozhikov> which is going to install httpd config in right place
13:19:35 <jpena> we don't add apache as a dependency either
13:19:58 <dirk> yeah, hardcoding apache is definitely "wrong" in the sense that any wsgi server will do
13:20:13 <IgorYozhikov> ok, will remove it
13:20:28 <toabctl> we should just provide the wsgi app
13:20:38 <toabctl> then the deployer can decide what to use
13:21:07 <IgorYozhikov> got it, and the last question from my side - config folder
13:21:12 <number80> o/
13:21:25 <IgorYozhikov> I created /etc/keystone/conf.d
13:21:25 <IgorYozhikov> hey number80
13:21:39 <toabctl> config folder does not work with wsgi afaik until now
13:21:39 <IgorYozhikov> and put there all conf files
13:21:41 <toabctl> hey number80
13:21:58 <IgorYozhikov> yes, I asked our keystone developer
13:22:36 <IgorYozhikov> he told me that it is better to store config files in expected folder like /etc/keystone
13:22:38 <toabctl> IgorYozhikov, keystone.conf should still be at /etc/keystone/keystone.conf
13:23:06 <IgorYozhikov> but I can also create a conf.d sub folder
13:23:46 <toabctl> well - if it doesnt work we dont need it. it needs to be handled somehow by the wsgi app
13:24:03 <toabctl> I try to find a solution for that.
13:24:04 <IgorYozhikov> anything else about keystone? just want to collect all suggestions and implement them :)
13:24:43 <IgorYozhikov> and finish with keystone to unblock the rest of dev core
13:24:53 <dirk> not from me, will send a detailed review when I have time
13:26:10 <IgorYozhikov> dirk, according to your comments libxmlsec1-openssl1 - is required for unit tests
13:26:23 <IgorYozhikov> freezgun also required for unit tests
13:27:11 <IgorYozhikov> I have got it from test logs
13:28:51 <IgorYozhikov> I saw a couple of unmet dependencies in SUSE CI job
13:30:27 <IgorYozhikov> could some1 from SUSE side fix it?
13:31:41 <IgorYozhikov> number80, jpena do you have something to add according to current topic?
13:31:51 <jpena> nope, nothing from my side
13:32:30 <IgorYozhikov> let's move further?
13:32:47 <number80> *nods*
13:32:58 <IgorYozhikov> #topic - packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:33:31 <IgorYozhikov> dirk, do you have a chance to look into tests for mistral?
13:33:58 <dirk> no, forgot about it
13:34:02 <IgorYozhikov> https://review.openstack.org/382196 - or I can add condition with_tests?
13:34:05 <dirk> #action dirk look into test issues with mistral
13:34:06 <IgorYozhikov> o i c
13:34:11 <IgorYozhikov> thanx
13:34:14 <dirk> I'll chekc it out
13:34:39 <IgorYozhikov> https://review.openstack.org/#/c/397618/
13:35:44 <IgorYozhikov> if every1 fine with ^^^ I can merge it:)
13:37:51 <IgorYozhikov> https://review.openstack.org/#/c/380834/ - last week we discussed that epoch folder should be back-ported into mitaka branch
13:38:09 <dirk> IgorYozhikov: too late :)
13:38:26 <dirk> IgorYozhikov: ah, thats a precondition?
13:38:29 <dirk> I can do that
13:38:41 <IgorYozhikov> yey
13:38:46 <dirk> or can you? I don' tknow what the proper mitaka level epochs are
13:38:49 <IgorYozhikov> I can
13:39:00 <IgorYozhikov> going to chery-pick from newton
13:39:20 <IgorYozhikov> or just add a new commit in case of troubles
13:39:50 <IgorYozhikov> #action IgorYozhikov back-port of epoch folder into mitaka branch
13:40:51 <IgorYozhikov> anything else in PRs we need to pay attention now ?
13:42:08 <IgorYozhikov> I see that we have a number of PRs from September
13:44:27 <IgorYozhikov> #topic  - pymod2pkg reviews (https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open )
13:44:42 <IgorYozhikov> there is 1 PR here https://review.openstack.org/#/c/398912/2
13:45:49 <IgorYozhikov> this change is related to SUSE
13:47:03 <kaslcrof> this patch related to naming problem with python-ldap in keystone
13:47:50 <IgorYozhikov> kaslcrof, think so
13:48:38 <IgorYozhikov> #topic - renderspec reviews (https://review.openstack.org/#/q/project:openstack/renderspec+status:open )
13:49:40 <IgorYozhikov> I guess that toabctl didn't have a chance to do something related to renderspec, right?
13:51:31 <IgorYozhikov> #topic open floor
13:52:14 <IgorYozhikov> we have 9 mins to discuss any other topics which are out of scope of agenda
13:53:15 * dirk is good
13:53:31 <dirk> ah, well, maybe.. is there any update on the rdo gating?
13:53:40 <dirk> 3rd party ci I mean
13:53:50 <number80> I'm working on fixing networkx
13:54:00 <jpena> number80 was faster than me :)
13:54:34 <number80> well, I'm progressing on that side, I'll have Gdal 2.x built soon
13:56:53 <IgorYozhikov> ok, anything else?
13:57:18 <toabctl> one thing
13:57:42 <IgorYozhikov> please proceed
13:57:51 <toabctl> is anybody using apache for wsgi (keystone, adoh, ceilometer,...)
13:58:00 <IgorYozhikov> me
13:58:08 <IgorYozhikov> keystone, aodh
13:58:11 <toabctl> eh, everybody, not anybody
13:58:19 <toabctl> number80, ^^
13:58:26 <jpena> yes, we are using it
13:58:36 <toabctl> and are you still shipping systemd files?
13:58:43 <IgorYozhikov> nope
13:58:49 <IgorYozhikov> useless
13:58:50 <jpena> not for keystone
13:58:53 <toabctl> maybe we discussed that already and I missed it
13:59:02 <jpena> but for ceilometer and aodh I think we still keep both options
13:59:09 <toabctl> we could still ship a systemd file with uswgi
13:59:11 <IgorYozhikov> no, we didn't
13:59:22 <toabctl> jpena, but its for developers only
13:59:38 <IgorYozhikov> toabctl, afraid it should be in different packages
13:59:54 <IgorYozhikov> or do not enable systemd unit after install
14:00:00 <IgorYozhikov> by default
14:00:04 <toabctl> IgorYozhikov, sure
14:00:21 <toabctl> I just want to know how others handle this wsgi switch
14:00:25 <IgorYozhikov> we are on time
14:00:26 <IgorYozhikov> #endmeeting