13:00:49 <number80> #startmeeting rpm_packaging
13:00:50 <openstack> Meeting started Thu Nov 24 13:00:49 2016 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:55 <openstack> The meeting name has been set to 'rpm_packaging'
13:01:00 <IgorYozhikov> glad 2 c u
13:01:00 <number80> #topic roll call
13:01:06 <toabctl> o/
13:01:07 <number80> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
13:01:12 <number80> #chair jpena IgorYozhikov toabctl
13:01:13 <openstack> Current chairs: IgorYozhikov jpena number80 toabctl
13:02:42 <dirk> o/
13:03:24 <number80> hi
13:03:27 <number80> #chair dirk
13:03:28 <openstack> Current chairs: IgorYozhikov dirk jpena number80 toabctl
13:03:32 <number80> let's start then
13:03:44 <number80> #topic keystone and mistral PRs
13:03:53 <number80> https://review.openstack.org/#/c/382196/
13:04:00 <number80> https://review.openstack.org/#/c/396262/
13:04:52 <IgorYozhikov> yes, just want to understand what should be done next to unblock dev core services
13:05:02 <number80> keystone fails in Suse because of deps that needs to be updated
13:05:07 <number80> *CI
13:05:14 <IgorYozhikov> I know
13:05:49 <IgorYozhikov> and about mistral dirk was promised to look into tests failures
13:06:01 <number80> okie
13:06:04 <IgorYozhikov> is there any progress?
13:06:19 <IgorYozhikov> or I can disable tests with bcond?
13:06:24 <IgorYozhikov> with_tests?
13:06:58 <IgorYozhikov> here we need feedback from SUSE side
13:07:18 <dirk> IgorYozhikov: still wip
13:07:28 <dirk> let me take a look now while the meeting is progressing
13:07:52 <toabctl> I have a look at the missing build deps  now
13:08:02 * d0ugal wonders if he can help with Mistral test failures
13:08:03 <IgorYozhikov> dirk, that's great and do you have something to say about deps 4 keystone?
13:08:22 <IgorYozhikov> ah, looks like i'm late :)
13:08:43 <dirk> )IgorYozhikov I'll fix that
13:08:47 <dirk> ah, or toabctl
13:09:00 <dirk> IgorYozhikov: we don't have most of the deps that you're referencing there..
13:09:42 <dirk> IgorYozhikov: e.g. python-hacking should not be in there
13:10:13 <IgorYozhikov> I think that we need to decide - build deps on vendors side and rebuild packages || add with_tests -> disable check and move further
13:10:26 <dirk> thats independent
13:10:39 <dirk> python-hacking is not a valid test dep, it shouldn#t be there
13:10:48 <dirk> others like python-future and so on are just omissins in the ci repo
13:10:53 <dirk> toabctl will fix that in a min
13:11:03 <IgorYozhikov> As I mentioned it used in tests
13:11:27 <IgorYozhikov> I tried to remove hacking and tests failed
13:14:38 <IgorYozhikov> so, dirk is watching into CI logs & elaborating next steps. Let's move further now?
13:14:54 <number80> try run_test.sh -P so it won't run flake8
13:15:21 <number80> it should pass
13:16:19 <IgorYozhikov> number80, are you suggesting to change %check section 4 keystone?
13:16:26 <number80> yes
13:17:03 <IgorYozhikov> %{__python2} setup.py testr ->  run_test.sh -P ?
13:17:37 <number80> yes, let's see if it fixes the issue
13:18:36 <IgorYozhikov> number80, could you point me where is this file ?
13:18:49 <dirk> IgorYozhikov: so looked at mistral.. the tests are doing a curl on http://www.example.com/
13:18:56 <dirk> which fails, because there is no network in a SUSE apckage build
13:19:05 <dirk> no network -> tests fail
13:19:09 <dirk> imho the test is broken
13:19:34 <number80> yes, we should have no network available
13:19:53 <IgorYozhikov> may be workaround? like local dummy http server?
13:20:22 <toabctl> fixing the test would be good
13:20:22 <IgorYozhikov> or there is a way of how exclude this test?
13:21:08 <d0ugal> dirk: Would you like me to have a go at updating the test?
13:21:20 <dirk> sure
13:21:29 <dirk> there is one failure, it is mistral.tests.unit.engine.test_with_items.WithItemsEngineTest.test_with_items_and_adhoc_action
13:22:02 <IgorYozhikov> nice
13:22:02 <d0ugal> oh, cool. I know that file.
13:22:28 <IgorYozhikov> #action d0ugal is going to fix mistral test mistral.tests.unit.engine.test_with_items.WithItemsEngineTest.test_with_items_and_adhoc_action
13:22:36 <dirk> d0ugal: actually it is just a dns lookup it seems. there is also no dns
13:23:28 <d0ugal> dirk: cool, should be fairly easy to resolve.
13:23:44 <IgorYozhikov> ok, seems like one problem less
13:24:29 <IgorYozhikov> and about runt_test.sh -P - I can't find this file here - https://github.com/openstack/keystone/tree/10.0.0
13:24:57 <IgorYozhikov> number80, could you please tell me where did you find it?
13:26:02 <number80> https://github.com/openstack/mistral/blob/master/run_tests.sh
13:26:15 <IgorYozhikov> it is master :(
13:26:20 <number80> ah yes
13:26:26 <IgorYozhikov> ah it is mistral
13:26:55 <IgorYozhikov> sorry for inconvenience
13:28:00 <IgorYozhikov> anyway it is exists in 3.0.2 https://github.com/openstack/mistral/blob/3.0.2/run_tests.sh
13:29:29 <number80> ah right
13:29:38 <IgorYozhikov> ok, so, should I try to change %check in mistral to use run_test.sh?
13:31:36 <IgorYozhikov> updated
13:31:41 <IgorYozhikov> https://review.openstack.org/#/c/382196/
13:31:57 <number80> ack, for mistral after reading logs, I think we just need to exclude the failing tests
13:32:30 <IgorYozhikov> ok, will examine build logs
13:32:48 <IgorYozhikov> and about keystone
13:33:00 <IgorYozhikov> so here there are unmet deps right?
13:34:28 <dirk> toabctl: is going to fix that momuntarily
13:34:33 <dirk> lets move on
13:34:36 <dirk> IgorYozhikov: ^^
13:34:45 <toabctl> it is fixed. but not sure about that secxml lib thing
13:34:45 <IgorYozhikov> dirk, thanx :)
13:34:53 <toabctl> see coments in the review
13:34:55 <IgorYozhikov> it is also required
13:35:07 <IgorYozhikov> because it used in tests
13:35:19 <toabctl> IgorYozhikov, bindep has libxml2 mentioned
13:35:20 <IgorYozhikov> I add it according to tests logs
13:35:21 <toabctl> oh.
13:36:46 <IgorYozhikov> number80, https://packaging-ci.fuel-infra.org/job/master-rpm-packaging-build-centos7/1630/console
13:37:00 <IgorYozhikov> run_tests wants venv
13:37:47 <dirk> IgorYozhikov: add -N
13:38:33 <number80> yep
13:38:39 <IgorYozhikov> done
13:38:47 <number80> I suggest that we look to the next topics?
13:38:54 <IgorYozhikov> toabctl, I will remove http || apache2
13:38:58 <IgorYozhikov> yes
13:39:09 <IgorYozhikov> let's move further
13:40:31 <number80> #topic XStatic
13:40:50 <IgorYozhikov> Here I want to clarify 2 things
13:41:26 <IgorYozhikov> 1) should we package all xstatics or just required by horizon
13:42:14 <IgorYozhikov> 2) should we build them as is - ie with embedded js,css,etc
13:43:28 <IgorYozhikov> As I remember Alan mentioned about 1 part a couple days ago
13:43:30 <dirk> 1) all required by horizon and that are on git.openstack.org/
13:43:35 <dirk> imho
13:43:39 <jpena> actually, shouldn't they be treated like other dependencies? I'm not sure why we should build them
13:43:52 <dirk> jpena: they're hosted on git.openstack.org
13:44:27 <dirk> jpena: so its imho similar to other deps, like castellan, cliff..
13:44:34 <jpena> dirk: ack
13:45:52 <IgorYozhikov> ok, I already asked Andrii to start upload xstatics to master
13:46:02 <number80> ok
13:46:13 <IgorYozhikov> not sure if he is here now
13:46:34 <IgorYozhikov> I'll ask him to participate our meetings
13:46:45 <IgorYozhikov> in our meetings
13:46:47 <IgorYozhikov> :)
13:47:35 <IgorYozhikov> moving further?
13:48:59 <dirk> +1
13:49:08 <dirk> number80: can you ping apevec about the -1 ?
13:49:14 <dirk> he was not so happy about xstatic
13:49:48 <IgorYozhikov> dirk, may be we set #agreed for xstatics just for history
13:50:38 <IgorYozhikov> it will be easier to track decisions
13:50:46 <number80> dirk: ack, I'm myself mixed about it, but it's logical to package whatever we have in git.openstack.org
13:51:00 <number80> #agreed package XStatic in rpm-packaging
13:52:17 <IgorYozhikov> next topic?
13:53:38 <IgorYozhikov> we have 7 mins to go
13:54:41 <jpena> yes, go ahead
13:55:08 <IgorYozhikov> #topic - packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:55:27 <number80> yes
13:55:39 <number80> any controversies?
13:56:01 <dirk> covered already
13:56:08 <number80> ok
13:56:11 <number80> next topic
13:56:28 <IgorYozhikov> #topic pymod2pkg reviews (https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open )
13:56:54 <IgorYozhikov> https://review.openstack.org/#/c/401214/4/pymod2pkg/__init__.py
13:57:03 <jpena> I fixed the XStatic review, it should cover all cases now I think
13:57:15 <number80> both opened reviews are ready for merge
13:57:55 <IgorYozhikov> should we publish new version after merge of these 2 prs?
13:58:07 <d0ugal> dirk: This may solve the Mistral test for you: https://review.openstack.org/#/c/402057/
13:59:19 <dirk> d0ugal: nice, that was quick
13:59:19 <IgorYozhikov> dirk, toabctl if you are fine with these 2 PRs, please merge https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open
13:59:53 <jpena> IgorYozhikov, having a new version of pymod2pkg should help, currently all XStatic builds will fail because of that
14:00:18 <IgorYozhikov> yes, and that is why I'm asking about releasing of new version after merge
14:00:30 <IgorYozhikov> we r out of time :(
14:00:31 <dirk> IgorYozhikov: done
14:00:36 <dirk> jpena: any update on the rdo gate?
14:01:15 <jpena> dirk: most reviews are getting CI results, only waiting for the networkx.drawing packages to make it report
14:01:49 <dirk> jpena: ok, good. thanks
14:01:56 <dirk> lets free the channel
14:01:58 <dirk> #endmeeting