13:04:28 <IgorYozhikov> #startmeeting rpm_packaging
13:04:29 <openstack> Meeting started Thu Dec  1 13:04:28 2016 UTC and is due to finish in 60 minutes.  The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:32 <openstack> The meeting name has been set to 'rpm_packaging'
13:04:43 <IgorYozhikov> #chair IgorYozhikov jpena
13:04:44 <openstack> Current chairs: IgorYozhikov jpena
13:05:26 <openstack> number80: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
13:05:33 <number80> arf
13:05:34 <IgorYozhikov> Let's start with filling up additional questions in agenda - https://etherpad.openstack.org/p/openstack-rpm-packaging
13:05:42 <IgorYozhikov> number80, already started
13:06:05 <toabctl> hi
13:09:28 <IgorYozhikov> Let's start?
13:10:50 <IgorYozhikov> #topic Finish with keystone and mistral, what should be done for it? (We need to gather all required for initial services setup and move further with dev core)
13:11:46 <toabctl> for keystone I commented on the changeset
13:12:01 <toabctl> also the commit msg is still wrong imo.
13:12:43 <toabctl> so should we start packaging already the beta;s available?
13:12:55 <IgorYozhikov> toabctl, i c I can switch to 11.0.0.0b1 then
13:13:26 <IgorYozhikov> and what about mistral
13:13:34 <toabctl> IgorYozhikov, cool. then could you directly use the new version variables introduced to renderspec recently? then we see how that works
13:13:53 <toabctl> IgorYozhikov, not sure if dirk looked into that. he is out today
13:14:01 <IgorYozhikov> toabctl, if you are about release - yes, will see
13:14:41 <toabctl> IgorYozhikov, I'm talking about http://docs.openstack.org/developer/renderspec/usage.html#handling-the-package-version
13:14:44 <IgorYozhikov> toabctl, last recommendation from dirk was BuildRequires:  openstack-macros
13:14:44 <IgorYozhikov> %if 0%{?suse_version}
13:14:44 <IgorYozhikov> BuildRequires:  systemd-rpm-macros
13:14:44 <IgorYozhikov> %endif
13:15:10 <toabctl> for mistral?
13:15:14 <IgorYozhikov> yes
13:15:49 <toabctl> yeah. for suse we need theses macros: https://en.opensuse.org/openSUSE:Systemd_packaging_guidelines
13:15:53 <IgorYozhikov> because there are no such calls like %systemd_preun ...
13:16:01 <toabctl> number80, jpena is there a similar thing for fedora?
13:17:04 <IgorYozhikov> I think that openstack-macros should handle this
13:17:13 <IgorYozhikov> because of different syntax
13:17:18 <jpena> yes, it makes sense to create compatible macros
13:17:18 <toabctl> hm. yes.
13:18:02 <jpena> for fedora we have https://fedoraproject.org/wiki/Packaging:Scriptlets#Scriptlets
13:18:52 <IgorYozhikov> jpena, could you add such macro -> openstack-macros?
13:19:09 <jpena> IgorYozhikov, ack, I'll give it a try
13:19:40 <IgorYozhikov> #action jpena is going to work on common systemd/service macro
13:20:02 <IgorYozhikov> thanx :) that is really needed  in further work on dev core
13:20:40 <IgorYozhikov> #action IgorYozhikov will update keystone to 10.0.0.0b1
13:21:37 <IgorYozhikov> anything else related to topic?
13:22:36 <IgorYozhikov> #topic Last clarification on Xstatics, jpena has concerns about what should be handled (projects only from openstack namespace or all of horizon deps)
13:23:26 <IgorYozhikov> during last meeting we agreed on xstatics - I mean that we are going to build them
13:24:47 <IgorYozhikov> During this week I raise this question, but, I might be missed something, there was no answer
13:25:49 <IgorYozhikov> jpena, could you please tell some words about xstatics and openstack namespace
13:26:08 <jpena> what I understood was that we'd build every XStatic project that is hosted at github.com/openstack
13:26:35 <jpena> which means base XStatic (hosted somewhere @ bitbucket) was out
13:26:45 <toabctl> jpena, that is also my understanding
13:27:41 <IgorYozhikov> does it mean that Xstatic should be packaged on per vendor basis and we are not going to built it, right?
13:28:05 <jpena> imo yes
13:28:27 <IgorYozhikov> collecting votes :)
13:29:01 <IgorYozhikov> I guess that toabctl has the same opinion, no?
13:29:07 <IgorYozhikov> number80, ^^
13:29:38 <toabctl> yes
13:30:45 <IgorYozhikov> ok
13:30:53 <IgorYozhikov> now it's clear
13:31:37 <IgorYozhikov> #topic  packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:33:31 <IgorYozhikov> https://review.openstack.org/#/c/374277/
13:34:56 <IgorYozhikov> do we have something for collective review?
13:35:46 <IgorYozhikov> if no - looks like we are done with agenda
13:35:53 <IgorYozhikov> #topic open floor
13:37:57 <IgorYozhikov> I have a question about pymod2pkg
13:38:32 <IgorYozhikov> toabctl, do you plan to make a new release with latest code?
13:39:00 <toabctl> IgorYozhikov, I did not checked what changed. do we need a new release?
13:39:07 <IgorYozhikov> pypi has pymod2pkg 0.6.1
13:39:49 <jpena> we need a new release, yes. At least for the XStatic mapping in RDO
13:40:06 <toabctl> ok. I can trigger on
13:40:13 <IgorYozhikov> great, thanx
13:40:24 <toabctl> #action toabctl triggers a new pymod2pkg release
13:42:14 <IgorYozhikov> we have about 19min to the end, anything else to discuss ?
13:42:38 <jpena> nothing for me
13:44:03 <toabctl> number80, can you approve https://review.openstack.org/405384 please?
13:44:10 <toabctl> nothing from my side
13:44:32 <IgorYozhikov> toabctl, did you have a chance to try pocket metal glass?
13:44:44 <toabctl> ?
13:44:58 <toabctl> is that related to our meeting?
13:45:05 <IgorYozhikov> nope :)
13:45:16 <IgorYozhikov> I'm out of topics
13:45:26 <toabctl> let's end the meeting then
13:45:38 <toabctl> IgorYozhikov, and yes. it works:) thanks again for that!
13:45:39 <IgorYozhikov> #endmeeting