13:02:45 <IgorYozhikov> #startmeeting rpm_packaging
13:02:46 <openstack> Meeting started Thu Jan 12 13:02:45 2017 UTC and is due to finish in 60 minutes. The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:49 <openstack> The meeting name has been set to 'rpm_packaging'
13:03:07 <IgorYozhikov> #chair jpena dirk IgorYozhikov
13:03:08 <openstack> Current chairs: IgorYozhikov dirk jpena
13:03:29 <jruzicka> o/
13:03:41 <jpena> o/
13:03:46 <IgorYozhikov> let's spend some time on agenda https://etherpad.openstack.org/p/openstack-rpm-packaging
13:03:56 <number80> o/
13:04:16 <IgorYozhikov> #chair jpena dirk IgorYozhikov number80
13:04:17 <openstack> Current chairs: IgorYozhikov dirk jpena number80
13:04:36 <dirk> o/
13:06:32 <number80> let's start
13:06:39 <IgorYozhikov> yep
13:07:04 <IgorYozhikov> #topic keystone https://review.openstack.org/#/c/396262/, let's merge it?
13:07:22 <number80> if the pymysql change is done, I'm good
13:07:29 <IgorYozhikov> I tried to address all comments from all sides in my last PR
13:07:57 <IgorYozhikov> number80, I just updated PR with pymysql
13:08:30 <IgorYozhikov> but now it failed on SUSE ci side
13:09:10 <number80> I think the eventlet package in suse CI is missing a deps if I stand correctly
13:09:51 <IgorYozhikov> dirk, could you take a look please ^^^^^
13:12:00 <IgorYozhikov> so, does it means that in common everything else is fine with keystone PR?
13:13:04 <IgorYozhikov> and it is only required to fix possible issues related to SUSE ci passing
13:13:09 <IgorYozhikov> and we can merge
13:13:14 <IgorYozhikov> right?
13:15:20 <IgorYozhikov> number80, dirk, jpena your opinion? ^^
13:15:43 <jpena> yes, I'm fine with that (I'd like to fix the ldap/pyldap issue, but that's the next topic)
13:15:51 <dirk> IgorYozhikov: I need to review it and fix the suse ci issue
13:16:01 <IgorYozhikov> great, thanx!
13:16:14 <IgorYozhikov> #topic pyldap or python-ldap, change mappings in pymod2pkg or just use exact component from project requirements
13:16:54 <IgorYozhikov> I'm not sure that we need to create one mapping for 2 different projects
13:17:22 <IgorYozhikov> let's discuss this topic, question raised by apevec
13:17:23 <number80> we can handle that with provides
13:18:43 <IgorYozhikov> as dirk mentioned in the keystone code there is pyldap
13:19:11 <IgorYozhikov> number80, do you suggest to add provides pyldap into python-ldap, am I right?
13:19:17 <dirk> number80: the point is that keystone explictely requests pyldap
13:19:26 <dirk> so pyldap needs ot be the eggname
13:19:29 <dirk> ldap is not the same thing
13:19:38 <IgorYozhikov> agree
13:21:45 <IgorYozhikov> just trying to understand why not to use pyldap. Is there any blockers on the RH side for that?
13:22:14 * number80 trying to remember why
13:23:22 <number80> I need to recheck with Alan, but we can provide pyldap somewhere
13:23:45 <jpena> in the fedora packages, we have python-ldap and python3-pyldap (pyldap supports python3, but only that subpackage is created)
13:23:47 <number80> it could be a bug or something
13:24:28 <number80> jpena: python2 variant can be reenabled
13:25:04 <number80> but it means phasing out legacy ldap python modue
13:25:37 <number80> (ok, just remembered that was the problem)
13:27:19 <IgorYozhikov> ok, so number80 is going to clarify usage of pyldap with apevec, right?
13:27:29 <number80> ack
13:27:39 <number80> #action number80 check with apevec pyldap status
13:27:45 <IgorYozhikov> cool
13:28:15 <number80> but I lean toward switching to pyldap either for ocata or pike at last
13:29:50 <IgorYozhikov> #topic Open Floor
13:30:43 <IgorYozhikov> I want to say welcome to new contributors - Dobroslaw, kornicameister
13:30:54 <IgorYozhikov> sorry if missed someone
13:31:01 <Dobroslaw> and jakub :)
13:31:10 <IgorYozhikov> sure, thanx
13:31:33 <jakub> hi all
13:31:54 <IgorYozhikov> I think that you may have questions || topics to discuss
13:32:17 <number80> Welcome Droboslaw and kornicameister
13:34:09 <jakub> I guess there are some questions from Dobroslaw and kornicameister on the openstack-rpm-packaging channel
13:34:48 <jakub> [07:36] <Dobroslaw> I'm working now on monasca-api in https://review.openstack.org/#/c/418376/
13:34:54 <jakub> [07:36] <Dobroslaw> And I have in some way similar problem with dependencies like kornicameister
13:35:04 <jakub> [07:37] <Dobroslaw> in monasca-api requirements file we have 3 potential db drivers, but two of them are commented: https://github.com/openstack/monasca-api/blob/master/requirements.txt#L20
13:35:09 <jakub> [07:38] <Dobroslaw> and because of that tests fail (not seeing casandra driver)
13:35:14 <jakub> [07:38] <Dobroslaw> should I add all this drivers as dependencies in spec file?
13:35:23 <jakub> [07:39] <Dobroslaw> user will most likely need only one specific - for him - driver
13:35:27 <jakub> [07:39] <Dobroslaw> but tests needs all
13:36:04 <jakub> (sorry for putting it like that, but Dobroslaw had to leave)
13:36:54 <dirk> jakub: I thought I answered to that
13:37:04 <Dobroslaw> ok I have some more time
13:37:17 <dirk> dirk> kornicameister: generally sqlalchemy
13:37:17 <dirk>
07:12 <dirk> So just depend on that .. the actual orm is an installer issue
13:37:17 <dirk>
07:12 <dirk> Usually OpenStack uses oslo.db though
13:37:34 <Dobroslaw> yes, but for relational dbs
13:38:11 <Dobroslaw> I'm looking for Casandra, InfluxDB and Vertica
13:38:43 <dirk> ah, so you're talking about the test failures?
13:38:45 <dirk> just add it as buildrequires
13:38:47 <Dobroslaw> yes
13:38:52 <dirk> buildrequires are not runtime requires, so it doesn't affect users
13:39:05 <Dobroslaw> and about drivers for end users
13:39:23 <Dobroslaw> they will use one driver
13:39:36 <dirk> do you want to opinionate to influxdb?
13:39:38 <Dobroslaw> but how to pack it?
13:40:00 <Dobroslaw> make this all drivers dependency of one package?
13:40:01 <IgorYozhikov> are you speaking about https://github.com/openstack/monasca-api/blob/1.5.0/tox.ini#L14-L18
13:40:52 <Dobroslaw> or create 3 packages, every one depending on one driver?
13:41:16 <Dobroslaw> IgorYozhikov, well partially, tests check all drivers
13:41:31 <jpena> in these cases, we usually leave the installation of the driver as a task for the deployer
13:41:39 <jpena> as runtime req I mean
13:42:14 <dirk> Dobroslaw: well, either opinionate one or none
13:42:19 <dirk> Dobroslaw: IMHO I would not require any
13:43:00 <dirk> Dobroslaw: its the task of the installer (manualler or automatic) to setup the database
13:43:02 <Dobroslaw> so running installation of influxdb from e.g. chef based on user config?
13:43:13 <dirk> sure, I mean the database could be on a completely different node
13:43:21 <dirk> so requiring any database doesn't make sense
13:43:24 <IgorYozhikov> if these packages are required only during build time you can add them to build-requires or exclude such tests from testr
13:43:31 <Dobroslaw> sorry, I mean influx python driver
13:44:40 <IgorYozhikov> Dobroslaw, does it means that obly drivers will be required for tests, not DBs, right?
13:44:47 <Dobroslaw> yes
13:45:00 <dirk> same thing, if you don#t want to opinionate the pacakging to always use influxdb, just depend runtime wise on nothing
13:45:54 <Dobroslaw> oh, ok
13:45:58 <Dobroslaw> will do
13:46:00 <Dobroslaw> thank you
13:46:04 <number80> yep
13:47:28 <IgorYozhikov> anything else to discuss - topics, questions, concerns?
13:47:36 <dirk> yes
13:47:53 <dirk> #link https://releases.openstack.org/ocata/schedule.html
13:48:37 <dirk> schedule reminder
13:48:46 <IgorYozhikov> R-5?
13:48:59 <dirk> feature freeze is upcoming, and PTL self nomination next week
13:49:08 <dirk> In case you want to think about becoming PTL :)
13:49:24 <IgorYozhikov> o i c :)
13:49:27 <dirk> sorry, week after next week
13:49:30 <dirk> I'm off by one
13:50:22 <number80> yep, resigning from this cycle, so feel free to candidate :)
13:51:48 <IgorYozhikov> number80, this cycle looks to be shorter compare to newton
13:52:24 <IgorYozhikov> anyway, thank you for info & reminding
13:52:40 <number80> well, it's nice to change from time to time
13:53:34 <IgorYozhikov> number80, what is about ptg? any updates?
13:54:40 <IgorYozhikov> as I remember that we planed to create remote sessions if it possible
13:55:28 <number80> Well, we have 2 days scheduled of meeting, and yes, we'll plan remote sessions (likely during the US mornings/European afternoons)
13:55:48 <IgorYozhikov> yey :D
13:55:59 <number80> I haven't received exact schedule to make suggestions yet
13:57:03 <IgorYozhikov> good, anything else?
13:58:18 * dirk is good
13:58:36 * jpena to
13:58:38 <jpena> too
14:00:03 <IgorYozhikov> #endmeeting