13:00:03 <IgorYozhikov> #startmeeting rpm_packaging
13:00:04 <openstack> Meeting started Thu Jan 19 13:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:07 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:10 <number80> thanks IgorYozhikov
13:00:20 <number80> agenda: #startmeeting rpm_packaging
13:00:22 <number80> arf
13:00:25 <IgorYozhikov> #chair number80 IgorYozhikov jpena
13:00:26 <openstack> Current chairs: IgorYozhikov jpena number80
13:00:31 <jpena> o/
13:00:33 <number80> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
13:00:43 <jruzicka> o/
13:00:56 <number80> my man Jakub :)
13:02:23 <dirk> moin moin
13:02:30 <dirk> toabctl is still ooo
13:03:20 <number80> ok
13:03:25 <number80> let's start then
13:03:33 <number80> #topic nova, glance, cinder, neutron how, who, when?
13:03:38 <IgorYozhikov> yes
13:03:48 <IgorYozhikov> want to clarify our future plans
13:04:00 <number80> ok, I volunteer for glance/cinder
13:04:01 <IgorYozhikov> and your opinion about it
13:04:27 <IgorYozhikov> because of one of goals been set in Barcelona - dev-core in Ocata
13:04:56 <number80> Yep, since the cycle was short, we couldn't move as fast but we landed keystone
13:05:07 <number80> so let's keep trying min cloud
13:05:14 <IgorYozhikov> horizon is on the way and that is good, very soon hope all required deps will be built
13:05:23 <number80> Yes
13:06:05 <IgorYozhikov> I can take nova
13:06:23 <number80> ack
13:06:30 <IgorYozhikov> and who want to take neutron?
13:06:36 <number80> #action number80 to package glance, cinder
13:06:48 <number80> #action IgorYozhikov to package nova
13:07:02 <IgorYozhikov> I know that neutron looks a painful
13:07:32 <IgorYozhikov> volunteers?
13:07:37 <jpena> I'll go for neutron, looks like fun
13:08:02 <number80> #action jpena to package neutron
13:08:11 <IgorYozhikov> yey!
13:08:17 <number80> thanks, well, network sounds to me like no fun but that's a personal bias :D
13:09:29 <IgorYozhikov> so, very soon we will have nova,cinder,glance,neutron & horizon. That's good
13:09:51 <IgorYozhikov> Any thoughts how to check all them together?
13:10:00 <IgorYozhikov> puppet, ansible,etc?
13:10:16 <IgorYozhikov> I'm about basic functionality
13:10:41 <IgorYozhikov> without swift,ceph, neutron-*aas
13:10:41 <dirk> IgorYozhikov: can you remove the -2 btw and work on the dashboard review?
13:10:57 <IgorYozhikov> dirk - yes, will do
13:11:20 <number80> Yes
13:11:23 <dirk> IgorYozhikov: well, at suse we have a small quickstart script (its like devstack but using packages)
13:11:27 <dirk> we could add it to the suse ci
13:11:53 <dirk> to be honest the current packaging isn't far enough yet to worry about that
13:12:00 <dirk> for now building packages would be nice
13:12:09 <number80> We'll look into reusing puppet manifests (low-level stuff) and maybe packstack (I need to check with jpena and amoralej feasibility)
13:12:16 <number80> *about
13:12:49 <IgorYozhikov> packstack also looks good, just AIO with small config
13:12:51 <jpena> number80: puppet modules/packstack are an option, if there are not many changes with package names or locations
13:13:03 <IgorYozhikov> could be run as periodic job
13:13:18 <jpena> I can have a look at it once we've created the basic services
13:13:27 <number80> jpena: thank you :)
13:14:41 <IgorYozhikov> looks like we covered 2 things at ones.
13:14:43 <dirk> so any service left?
13:14:53 <IgorYozhikov> heat
13:15:02 <dirk> looks like all is covered by number80 / jpena
13:15:04 <dirk> heat is basic? :)
13:15:09 <IgorYozhikov> not sure
13:15:21 <jpena> it's 2nd batch for me :)
13:15:29 * number80 do not know anything about that heat thing
13:15:42 <IgorYozhikov> dirk, may be swift then
13:15:52 <number80> swift is basic indeed
13:16:57 <dirk> number80: good excuse ;)
13:17:05 <number80> :)
13:17:17 <dirk> ok, I'll see about swift.
13:17:57 <number80> ack
13:18:28 <dirk> did we ever decide about the package splitting?
13:19:32 <IgorYozhikov> dirk, are you about tests || about something else?
13:20:04 <dirk> well, let me explain the standard openstack packaging with suse
13:20:17 <dirk> we have a python-$modulename  subpackage
13:20:25 <dirk> then we have a openstack-$modulename package
13:20:42 <dirk> and a openstack-$modulename-$servicename subpackage that only contains the stuff for launching that service (systemd files for example)
13:21:26 <dirk> it looks like we tried to do something similar to that with the keystone packaging
13:21:36 <dirk> although mistral deviates from that again
13:21:54 <dirk> also do you call horizon dashboard or horizon? :)
13:22:39 <IgorYozhikov> dirk, in http path?
13:23:09 <IgorYozhikov> afaik horizon = debina/ubuntu & dashboard - RH/CentOS
13:23:31 <dirk> from the package naming
13:23:33 <IgorYozhikov> don't know how in SUSE
13:24:02 <dirk> as I said, we call it openstack-dashboard
13:24:23 <dirk> mostly because for historical reasons wthough, because in folsom timeframe or so someone said horizon will be renamed to dashboard soon
13:24:40 <dirk> so we wanted to be correct from the beginning :) looks like this never happened though
13:26:11 <number80> Yeah
13:26:14 <IgorYozhikov> openstack-dashboard looks fine
13:27:05 <IgorYozhikov> according to https://review.rdoproject.org/r/#/c/3923/3/python-django-horizon.spec RDO is using same name
13:29:07 <IgorYozhikov> in MOS we use openstack-dashboard too
13:30:53 <dirk> ok
13:30:59 <IgorYozhikov> dirk, if any1 agree about package structure, should we take keystone as a reference for further packages?
13:31:11 <dirk> #agreed horizon is called openstack-dashboard
13:31:25 <dirk> IgorYozhikov: well, keystone is a bad example as it doesn't follow that structure :)
13:31:32 <dirk> e.g. the wsgi app is not installed in a -app subpackage
13:31:52 <IgorYozhikov> got it
13:32:44 <IgorYozhikov> moving forward?
13:33:14 <dirk> +1
13:34:18 <IgorYozhikov> number80, jpena ? ^^
13:34:24 <jpena> yep
13:34:46 <IgorYozhikov> #topic packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:35:03 <number80> +1
13:37:03 <IgorYozhikov> MOS will update today python-django-compressor - https://review.fuel-infra.org/#/c/29876/3
13:38:02 <IgorYozhikov> any urgent PRs for review?
13:38:16 <dirk> well, the whole ocata series
13:38:24 <number80> Yep
13:38:27 <dirk> Ideally I'd like us to cut a stable/ocata branch somewhen soon
13:38:35 <dirk> we started packaging Ocata, and I don#t want to fork from upstream
13:38:48 <number80> when's the branching for the other projects?
13:39:12 <dirk> "it depends"
13:39:22 <IgorYozhikov> libs & clients in a week or 2 before services
13:39:26 <IgorYozhikov> i think
13:39:40 <dirk> non-client lib freeze is today
13:39:46 <dirk> so they have stable branches
13:39:49 <dirk> the rest is coming next week
13:40:12 <dirk> thats why I'm frantically trying to get stuff into master
13:40:14 <dirk> :)
13:40:15 <number80> ok, I'll schedule branching early next week
13:40:24 <number80> and push for reviews now
13:41:39 <IgorYozhikov> I reviewed a lot of PRs today
13:43:40 <number80> ack
13:45:04 <number80> anything else?
13:45:13 <IgorYozhikov> nope
13:45:43 <number80> #topic https://review.openstack.org/#/q/project:openstack/renderspec+status:open
13:45:59 <number80> (no pymod2pkg review, I merged the pystache one)
13:46:39 <number80> I don't see any urgent review there, but someone may have a different opinion
13:46:44 <dirk> looks good
13:47:16 <number80> ok, then open floor
13:47:20 <number80> #topic open floor
13:47:34 <number80> any specific topic you want to bring before we close the meeting?
13:48:24 <IgorYozhikov> any updates on ptg?
13:49:33 <number80> I haven't received any email yet, though TC is gathering opinion of some openstack goals
13:50:20 <number80> schedule is not yet published
13:50:54 <IgorYozhikov> thnx
13:51:22 <dirk> number80: see governance/goals/pike
13:51:44 <dirk> there is one (?) review pending still
13:53:38 <number80> Yep
13:55:27 <dirk> the accepted goal was python 3.5 voting everywhere and working for "base" set of services
13:57:05 <IgorYozhikov> yes, I asked how to solve exe name issues, via update-alternatives for example
13:57:09 <number80> Yes
13:57:39 <dirk> one thing I was wondering - do we want to remove the global-requirements copy in rpm-packaging?
13:58:03 <dirk> I never got around fixing the bot, and mos ci doesn't use it (and rdo and mos just ignore it anyway since they don#t do global rebuilds)
13:58:26 <dirk> so its only there for suse ci, and I can probably hack that locally
13:58:36 <IgorYozhikov> mos ci uses g-r from rpm-packaging
13:58:42 <IgorYozhikov> during builds
13:58:51 <dirk> I thought it uses the one from g-r?
13:59:15 <IgorYozhikov> dirk, I'll check it & let you know
13:59:45 <number80> dirk: we can remove it and allow local overrides if needed (and agreed by CI masters)
14:00:20 <IgorYozhikov> we have fall-back
14:00:21 <IgorYozhikov> 13:53:50 + '[' NEW = MERGED ']'
14:00:21 <IgorYozhikov> 13:53:50 + mkdir artifacts
14:00:21 <IgorYozhikov> 13:53:50 + '[' -f global-requirements.txt ']'
14:00:21 <IgorYozhikov> 13:53:50 + cp global-requirements.txt artifacts/
14:01:20 <IgorYozhikov> time colleagues :(
14:02:03 <IgorYozhikov> #endmeeting