13:02:37 <IgorYozhikov> #startmeeting rpm_packaging
13:02:38 <openstack> Meeting started Thu Feb  2 13:02:37 2017 UTC and is due to finish in 60 minutes.  The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:44 <openstack> The meeting name has been set to 'rpm_packaging'
13:02:53 <jpena> o/
13:03:03 <IgorYozhikov> #chair toabctl IgorYozhikov jpena dirk number80
13:03:04 <openstack> Current chairs: IgorYozhikov dirk jpena number80 toabctl
13:03:05 <toabctl> hi
13:03:27 <IgorYozhikov> let's spend a couple of minutes on agenda update - https://etherpad.openstack.org/p/openstack-rpm-packaging
13:03:54 <dirk> o/
13:06:01 <jruzicka> o/
13:07:53 <IgorYozhikov> let's start
13:08:10 <IgorYozhikov> #topic nova - https://review.openstack.org/#/c/425673/ - cross distro diffs & how to resolve such cases(policykit, sudoers.d, etc; package folder ownership)
13:10:21 <IgorYozhikov> I saw comments left by toabctl but @ at 1st I want to talk about differences between RH & SUSE
13:10:21 <toabctl> who added that topic?
13:10:26 <IgorYozhikov> I'm
13:10:29 <toabctl> ok :)
13:11:00 <IgorYozhikov> and after that discuss comments
13:12:23 <IgorYozhikov> a couple of days ago dirk wrote about diffs for policykit
13:13:23 <IgorYozhikov> because of errors raised in SUSE CI while nova packages were building
13:13:58 <IgorYozhikov> I'm speaking about such errors
13:13:59 <IgorYozhikov> [ 2726s] openstack-nova-cert-15.0.0.0~xbeta2-1.1.noarch.rpm: directories not owned by a package:
13:13:59 <IgorYozhikov> [ 2726s]  - /usr/com
13:13:59 <IgorYozhikov> [ 2726s] openstack-nova-common-15.0.0.0~xbeta2-1.1.noarch.rpm: directories not owned by a package:
13:13:59 <IgorYozhikov> [ 2726s]  - /etc/polkit-1
13:14:01 <IgorYozhikov> [ 2726s]  - /etc/polkit-1/localauthority
13:14:03 <IgorYozhikov> [ 2726s]  - /etc/polkit-1/localauthority/50-local.d
13:14:05 <IgorYozhikov> [ 2726s]  - /etc/polkit-1/rules.d
13:14:07 <IgorYozhikov> [ 2726s]  - /etc/sudoers.d
13:14:09 <IgorYozhikov> [ 2726s]  - /usr/com
13:14:46 <IgorYozhikov> toabctl, dirk could you please point me - how to solve this?
13:15:18 * toabctl needs to look into the changeset...
13:16:32 <jpena> IgorYozhikov: I had some similar issues in the neutron review, and fixed it by adding the packages that own those directories as BuildRequires
13:19:13 <IgorYozhikov> jpena, could you point me on which line in PR is this?
13:20:12 <jpena> IgorYozhikov, for example line 46 in https://review.openstack.org/#/c/424085/8/openstack/neutron/neutron.spec.j2 . The SUSE CI was complaining that I had no owner for /etc/sudoers.d, so I added sudo as BR
13:20:51 <IgorYozhikov> o i c
13:22:10 <IgorYozhikov> just want to understand - is it a hack || workaround. I mean, is this a valid way for resolving such cases in future?
13:22:57 <jpena> good question, I think it's due to the way the SUSE CI checks for directories, but I'd let dirk or toabctl comment on that
13:23:44 <IgorYozhikov> jpena, agree here. Explanation of how-to do it in the right way will be awesome :)
13:25:27 <IgorYozhikov> jpena, do you have any comments on https://review.openstack.org/#/c/425673/ while toabctl is looking into CI ?
13:25:49 <jpena> IgorYozhikov: nothing yet, I have to give it a good look
13:27:23 <IgorYozhikov> I'm not sure that systemd.service needs to do something with DB as a pre-start stage. toabctl suggested to add db sync there
13:27:49 <toabctl> and it is allowed to fail. see the minus
13:28:24 <jpena> we don't add the db syncs in the service start, that's a task we leave for the deployment tool
13:33:24 <IgorYozhikov> so, what decision we are going to make here, I'm about db syncs?
13:34:14 <IgorYozhikov> leave all configuration machinery to CM tools || add it with allowance of failure?
13:36:15 <IgorYozhikov> As for me, if suggested by toabctl approach wouldn't produce any harm - I'm fine with it
13:37:17 <jpena> we can give it a try. The only downside is a longer service startup time
13:38:19 <IgorYozhikov> ok
13:39:53 <IgorYozhikov> #agreed to use db syncs as pre-start stage in service unit files,  starting with '-' before command, example:  ExecStartPre=-/usr/bin/nova-manage db sync
13:40:24 <IgorYozhikov> toabctl, any updates related to CI and folders ownership?
13:40:34 <toabctl> IgorYozhikov, no
13:41:20 <dirk> IgorYozhikov: what do you mean
13:41:21 <dirk> ?
13:41:24 * dirk is back from real life
13:42:06 <IgorYozhikov> dirk, we are discussing folder ownership and diffs between distros
13:42:43 <IgorYozhikov> <<jpena>> IgorYozhikov, for example line 46 in https://review.openstack.org/#/c/424085/8/openstack/neutron/neutron.spec.j2 . The SUSE CI was complaining that I had no owner for /etc/sudoers.d, so I added sudo as BR
13:43:14 <IgorYozhikov> And we want to understand how to solve such cases in the right way
13:43:38 <dirk> IgorYozhikov: there are two ways, a) add buildrequires to packages that would normally "own" the directory
13:43:43 <dirk> or b) own the directories
13:44:09 <IgorYozhikov> dirk, so suggested by jpena approach is valid, right?
13:44:09 <dirk> basically the idea is by policy we want each directory that exists on an installed customer end user system to be owned by at least one rpm, ideally exactly one
13:44:22 <dirk> yeah, sudo buildrequires might work
13:44:31 <IgorYozhikov> yey :)
13:44:38 <dirk> yep, it owns the dir
13:44:41 <dirk> so yes, thats the proper fix then
13:44:53 <IgorYozhikov> ok, let's move to the next topic then.
13:45:06 <IgorYozhikov> I'll propose updates to nova soon
13:45:14 <dirk> thanks!
13:45:15 <IgorYozhikov> #topic neutron https://review.openstack.org/#/c/424085/ - finally pass CIs, review requried
13:45:24 <dirk> I know I took the action item of swift, its still on my todo somewhere
13:45:30 * dirk is just dead under the water right now
13:46:20 <IgorYozhikov> jpena, MOS CI finally built missed deps and neutron passed all CIs
13:47:05 <jpena> nice!
13:47:16 <jpena> so please go ahead and review it now if you can
13:47:24 <IgorYozhikov> will do
13:48:15 <IgorYozhikov> also I want to ask other colleagues to do the same :)
13:48:20 <IgorYozhikov> good
13:49:25 <IgorYozhikov> #topic - PTG planning
13:49:56 <IgorYozhikov> author of ^^ topic, please proceed
13:52:26 <IgorYozhikov> jpena, toabctl do you know who suggested last topic?
13:52:41 <dirk> do we have a room?
13:52:50 <jpena> dunno
13:53:03 <dirk> does anyone know?
13:53:07 <toabctl> who will be there? dirk, number80  and me?
13:53:17 <dirk> yes
13:53:23 <toabctl> maybe number80 knows?
13:55:06 <IgorYozhikov> yes, he said a couple of words during previous meeting, but nothing special
13:55:27 <IgorYozhikov> so I think that we need to ping him about PTG
13:56:25 <IgorYozhikov> I'll be able to join PTG session remotely it this will be possible
13:56:39 <IgorYozhikov> s/it/if/
13:58:10 <dirk> plase do
13:58:14 <dirk> it would be good to have a room and so on
13:58:19 <dirk> and I have not seen any updates on this so far
13:59:14 <IgorYozhikov> I'll try to talk to number80
14:00:36 <IgorYozhikov> ok, thanx every1 4 attending
14:00:39 <IgorYozhikov> #endmeeting