12:21:09 <toabctl> #startmeeting rpm_packaging
12:21:10 <openstack> Meeting started Thu May 11 12:21:09 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:21:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:21:13 <openstack> The meeting name has been set to 'rpm_packaging'
12:21:31 <toabctl> #chair dirk IgorYozhikov jpena|lunch aplanas
12:21:32 <openstack> Current chairs: IgorYozhikov aplanas dirk jpena|lunch toabctl
12:21:37 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:21:53 <toabctl> as usual, please add your topics to https://etherpad.openstack.org/p/openstack-rpm-packaging
12:21:56 <IgorYozhikov> o/
12:22:02 <aplanas> hi
12:22:33 <toabctl> ok. let's start and append topics to the list if needed
12:22:45 <toabctl> #topic Queens ptg attendance
12:23:13 <IgorYozhikov> yes
12:23:38 <IgorYozhikov> Do we have plans to go to Queens?
12:23:45 <toabctl> according to https://www.openstack.org/software/roadmap/ , the PTG will be in september
12:24:02 <toabctl> I'll no attend due to personal reasons
12:24:03 <IgorYozhikov> I've got letter
12:24:33 <jpena> o/ (sorry, had to pick up kid from school)
12:24:44 <toabctl> hey jpena
12:24:46 <IgorYozhikov> with clarification request from tc
12:25:21 <IgorYozhikov> and we need to figure out, are we going on not
12:26:00 <toabctl> IgorYozhikov, what is the mail about? reserving a room? a timeslot? anything else?
12:26:45 <IgorYozhikov> toabctl, : Poking one more time :) I know its a busy week for us all, but if you can take a few minutes to talk to your project teams about PTG attendance in September and fill out the survey that would be wonderful! If I don't hear from you by the EOD Sunday, I will assume your project IS NOT planning on attending the PTG.
12:27:34 <toabctl> ok. so I'm not going. what about others?
12:27:46 <dirk> I'll be going
12:27:46 * IgorYozhikov not sure too
12:27:46 <aplanas> me neither, I guess
12:28:07 <dirk> but attendance last time was somewhat limited
12:28:20 <dirk> so I'm fine with skipping it and saying we'll not attend
12:28:26 <IgorYozhikov> I'm going to switch company this summer and can't promise now anything
12:28:28 <jpena> I might go, but I can't say for sure now.
12:28:31 <toabctl> yeah. basically dirk and me with some random folks from other projects
12:28:51 <toabctl> IgorYozhikov, but still anything openstack related?
12:29:03 <IgorYozhikov> toabctl, yes
12:29:07 <IgorYozhikov> but in China
12:29:26 <toabctl> ok. cool
12:29:56 <IgorYozhikov> so, I'm declining invite right?
12:31:45 <IgorYozhikov> colleagues? ^^^
12:31:57 <aplanas> IgorYozhikov: I think that is the reasonable answer here, yes
12:32:21 <IgorYozhikov> good
12:32:30 <jpena> +1
12:32:35 <toabctl> ok
12:32:42 <toabctl> #topic MOS CI shutdown early in June
12:33:12 <IgorYozhikov> yep
12:33:27 <toabctl> bad to hear that...
12:33:30 <IgorYozhikov> I clarified it finally.
12:33:44 <toabctl> IgorYozhikov, so mirantis is no longer using packages?
12:33:58 <IgorYozhikov> It use
12:34:43 <IgorYozhikov> But unfortunately "everything" is switching to Ubuntu / deb
12:35:37 <IgorYozhikov> I'll provide exact date when MOS will stop rpm-packaging CI
12:36:18 <IgorYozhikov> I'm apologizing for that and it is also hard to me
12:37:01 <toabctl> IgorYozhikov, ok. sad to hear that but thanks for sharing the info
12:37:12 <toabctl> #topic packages reviews
12:37:25 <toabctl> #link https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open
12:37:31 <toabctl> anything controveral in the queue?
12:38:13 <toabctl> I wonder why https://review.openstack.org/#/c/461888/ passes in other CIs? do you guys have network access in the CI?
12:38:23 <IgorYozhikov> I'll check all failed with MOS CI
12:38:42 <toabctl> need todo the same for the SUSE CI.
12:39:43 <IgorYozhikov> https://review.openstack.org/#/c/456679/
12:39:52 <IgorYozhikov> looks like low hanging ^
12:40:03 <jpena> toabctl: yes, we have internet access in our CI
12:40:31 <toabctl> jpena, ah. that's why it passes. SUSE CI does not allow any extra content from the net
12:40:46 <toabctl> IgorYozhikov, I'll update it.
12:40:57 <IgorYozhikov> ah, jpena MOS & SUSE building in sanboxes
12:41:11 <IgorYozhikov> without Internet
12:41:23 <IgorYozhikov> just to ensure that all dependencies are in place
12:41:52 <IgorYozhikov> sometimes we applying patches for tests which are required external network access
12:44:48 <IgorYozhikov> toabctl, https://review.openstack.org/#/c/459616/
12:44:54 <IgorYozhikov> what is missed here
12:45:02 <IgorYozhikov> because CI complains on : DEBUG util.py:417:  Installing mistral script to /builddir/build/BUILDROOT/python-mistralclient-3.1.0-0.x86_64/usr/bin
12:45:02 <IgorYozhikov> DEBUG util.py:417:  + install -p -D -m 644 doc/build/man/mistral_client.1 /builddir/build/BUILDROOT/python-mistralclient-3.1.0-0.x86_64/usr/share/man/man1/mistral_client.1
12:45:03 <IgorYozhikov> DEBUG util.py:417:  install: cannot stat 'doc/build/man/mistral_client.1': No such file or directory
12:45:38 <toabctl> IgorYozhikov, iirc this is due to a pbr update. we have already commits in the history which fixes similar problems afair
12:46:08 <toabctl> IgorYozhikov, ah. sorry. only mos failed. maybe you need to update your pbr package?
12:46:11 <IgorYozhikov> python-pbr-2.0.0
12:46:23 <IgorYozhikov> do we need newer?
12:46:50 <toabctl> hm. looks like suse ci has also 2.0.9
12:46:56 <toabctl> eh, 2.0.0
12:47:12 <dirk> we might need to update to the newer pbr
12:47:16 <dirk> there have been again man page changes
12:47:24 <dirk> e.g. man pages are no longer built
12:47:36 <dirk> I bailed out of that upgrade mess last time I tried because it broke the existing specs
12:47:42 <dirk> but we need to fix it..
12:48:05 <dirk> toabctl: ok if we take the action item to update the dependencies for SUSE CI? it's been pretty out of date..
12:48:18 <IgorYozhikov> dirk, so does it means that we need to update pbr to last versions according to U-C?
12:50:19 <dirk> IgorYozhikov: yes. currently global requirements specify >=2.0,1=2.1, which is effectively >=3.0
12:50:27 <dirk> so our env with pbr 2.0 is wrong
12:50:41 <dirk> this could also explain some of the other SUSE CI failures
12:50:54 <dirk> I would really like to habe pbr being maintained in rpm-packaging itself btw
12:51:10 <dirk> that would solve all of that custom-3rd-party-waiting-for-deps-to-be-updated
12:51:16 <IgorYozhikov> let's vote for that
12:51:45 <IgorYozhikov> but should we create a separate folder for such cases
12:52:01 <IgorYozhikov> 4 example ./dependencies/pbr
12:52:59 <dirk> pbr really is no different than anything else that we pacakge
12:53:09 <dirk> it is an openstack hosted python project
12:53:20 <dirk> so there is no point in putting it anywhere else than openstack/pbr
12:53:28 <dirk> just someone needs to submit a review and get it in
12:53:43 <dirk> any volunteers
12:53:44 <dirk> ?
12:53:49 <IgorYozhikov> I'm fine with that
12:54:08 <IgorYozhikov> latest published version?
12:55:03 <IgorYozhikov> dirk, ^^^
12:56:02 <toabctl> yes
12:56:18 <toabctl> I have another meeting in 3 min and need a short break.
12:57:17 <IgorYozhikov> ok
12:57:46 <IgorYozhikov> #action IgorYozhikov will provide PR fro openstack/pbr
12:57:56 <toabctl> IgorYozhikov, thanks
12:57:56 <IgorYozhikov> s/fro/for/
12:58:05 <toabctl> if there is anything else, let's discuss it in #openstack-rpm-packaging
12:58:09 <toabctl> thanks everybody!
12:58:14 <toabctl> #endmeeting