12:12:35 <dirk> #startmeeting rpm_packaging
12:12:36 <openstack> Meeting started Thu Jun 15 12:12:35 2017 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:12:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:12:39 <openstack> The meeting name has been set to 'rpm_packaging'
12:12:44 <dirk> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:12:54 <dirk> #topic roll call
12:12:56 <number80> hello
12:13:00 <dirk> #chair number80
12:13:00 <openstack> Current chairs: dirk number80
12:13:14 <dirk> everyone please update agenda on https://etherpad.openstack.org/p/openstack-rpm-packaging
12:13:22 <dirk> today might be a light meeting, its a public holiday
12:16:19 <dirk> #topic python 3.x
12:16:45 <dirk> #link https://review.openstack.org/#/c/469187/1/openstack/oslosphinx/oslosphinx.spec.j2
12:17:05 <dirk> SUSE is strongly switching to Python 3.x, so the current approach of building only python 2.x no longer works
12:17:28 <dirk> number80: has there been an evaluation of the singlespec macros? is this an approach to adopt by RDO?
12:18:06 <number80> dirk: well, we're interested in, but I haven't had yet the time to look at it
12:18:09 <dirk> there are ways to make it work for SUSE with renderspec without porting the RDO port
12:18:25 <dirk> we could implement a --flavor singlespec in renderspec and make py2pkg generate the appropriate macros
12:18:36 <dirk> but the work would be wasted if we could adopt a common solution
12:18:48 <dirk> number80: how can we help with the time constraint? :)
12:18:50 <number80> TBH, our problem is that I don't know how we will support python3, which makes it difficult for me to envision how
12:19:30 <number80> But it would be compatible with the current way, how Fedora implements dual-stack python though
12:20:19 <dirk> number80: can you check the above link? it shows what currently would need to be done to build python2-foo and python3-foo from a single spec
12:20:32 <number80> Yes, I added myself as a reviewer
12:20:54 <dirk> number80: we could take baby steps into that direction, e.g. by agreeing on the %python_subpackages macro
12:21:09 <dirk> or by adding a python_build -> %py2_build wrapper for the rdo case
12:21:45 <number80> Well, this one won't be too problematic
12:22:35 <number80> But yeah, we can start uniformizing %python_build, %python_install semantics
12:23:50 <dirk> number80: so are you good with switching from %py2_build to %python_build ?
12:24:02 <dirk> should we discuss that in a RDO meeting?
12:24:28 <number80> I'll start a discussion on our mailing-list
12:24:47 <number80> #action number80 to discuss macros with downstream RDO community
12:26:44 <dirk> number80: thanks a lot
12:26:56 <number80> np
12:26:57 <dirk> #agreed look at standardizing macro names to be more compatible with singlespec
12:27:05 <dirk> related
12:27:06 <dirk> #link https://review.openstack.org/#/c/472632/
12:27:21 <dirk> Javier did an experiment with the python2 provides, this didn't build well yet
12:27:27 <dirk> I'll take a look at that, probably early next week
12:27:33 <dirk> #action dirk look at the python2 compat macro
12:27:46 <dirk> #topic open floor
12:27:49 <dirk> any topics?
12:28:03 <dirk> I assume we'll have to look for a new meeting time for IgorYozhikov
12:28:05 <dirk> somewhen soon
12:31:21 <number80> nnot currently
12:31:35 <number80> but yes, we can look for another time slot for meetings
12:31:45 * number80 got meeting inflations
12:31:54 <dirk> yeah, tell me about it
12:32:06 <dirk> anyway, next week toabctl  and aplanas should be back
12:32:15 <dirk> so let's keep it short for today
12:32:19 <number80> excellent
12:32:40 <dirk> #endmeeting