12:03:26 <toabctl> #startmeeting rpm_packaging
12:03:27 <openstack> Meeting started Thu Jul  6 12:03:26 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:03:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:03:31 <openstack> The meeting name has been set to 'rpm_packaging'
12:03:32 <openstack> dirk: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
12:03:33 <IgorYozhikov> o/
12:03:35 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:03:40 <jpena> o/
12:03:45 <dirk> o/
12:03:47 <toabctl> #chair dirk jpena IgorYozhikov
12:03:48 <openstack> Current chairs: IgorYozhikov dirk jpena toabctl
12:03:49 <dirk> toabctl: continue :)
12:04:01 <toabctl> hey everybody
12:04:12 <toabctl> as usual, let's collect topics on the etherpad
12:04:18 <toabctl> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
12:09:10 <toabctl> let's start
12:09:44 <toabctl> dirk, did we discuss the openSUSE python3 default already?
12:10:01 <toabctl> #topic package reviews
12:10:03 <dirk> not sure, I missed last week's meeting
12:10:06 <toabctl> me too
12:10:30 <toabctl> or not? I don't remember. anyway - anything special in the current queue?
12:11:02 <IgorYozhikov> toabctl, we discussed py3 as default provides
12:11:25 <IgorYozhikov> but not sure we agreed on something
12:12:32 <toabctl> ok. let's first go through the review topic and handle that (if there is something) at the end
12:14:47 <dirk> I don't have a particular review to bring up
12:14:52 <dirk> but it brings me to a new topic
12:15:26 <dirk> does anyone want to bring up a particular review?
12:15:27 <number80> o/
12:15:38 <toabctl> #topic EOL of Mitaka branch
12:15:59 <IgorYozhikov> dirk,  may be this one - https://review.openstack.org/#/c/465971/
12:16:36 <dirk> so officially mitaka is EOL. although some projects still have a mitaka branch
12:16:42 <dirk> do we want to close down the stable/mitaka branch?
12:17:05 <dirk> or keep it open but not care about it anymore (unless we have to)
12:17:15 <dirk> from the SUSE side mitaka didn't end up on any product so we're not going to maintain the branch
12:17:27 <IgorYozhikov> dirk, close or stop do commits?
12:17:47 <dirk> close in the sense of deleting branch and replacing it with a -eol tag
12:18:05 <number80> RDO has EOLed Mitaka (product is a different matter) so +1 unless someone needs it
12:18:16 <toabctl> +1 for closing it
12:18:55 <number80> (basically, if you need it, you have to raise your hand!)
12:22:07 <IgorYozhikov> +1
12:22:49 <IgorYozhikov> let's close it
12:23:18 <toabctl> dirk, can you take that action?
12:23:32 * toabctl does not know yet how to close branches ...
12:25:10 <number80> toabctl: as dirk said delete branch through git and tag head mitaka-eol
12:25:35 <dirk> toabctl: ok, will do
12:25:45 <dirk> #action dirk replace stable/mitaka branch with a mitaka-eol tag
12:26:04 <toabctl> #topic Clarify
12:26:18 <toabctl> who added that topic? and what does it mean?:)
12:27:42 <dirk> sorry, me
12:27:50 <dirk> I was seeing the MOS ci reporting stuff again
12:27:57 <dirk> in some places. does anyone know more?
12:28:07 <toabctl> IgorYozhikov, ?
12:28:18 <IgorYozhikov> OMG, where, can you point me?
12:29:19 <dirk> maybe I've been halluzinating
12:29:21 <IgorYozhikov> afaik it should not
12:29:22 * dirk checks
12:29:32 <toabctl> dirk, I saw the same today..
12:29:46 <dirk> IgorYozhikov: here: https://review.openstack.org/#/c/475582/
12:30:45 <IgorYozhikov> #action IgorYozhikov will check MOS CI status
12:30:53 <dirk> IgorYozhikov: thanks!
12:31:18 <IgorYozhikov> strange, because there were plans to shutdown it in June/July
12:32:22 <jpena> it's been silent for a few weeks, then it started reporting again
12:33:39 <toabctl> next topic? or anything else on MOS CI?
12:33:59 <dirk> next
12:34:05 <toabctl> #topic Open Floor
12:34:37 <cousin_luigi> Just a question: will there be another meeting next Thursday?
12:34:38 <dirk> so we have half an hour for our favorite python3 topic ? :)
12:34:50 <toabctl> I wanted to ask that :)
12:34:59 <dirk> is there a special thursday?
12:35:31 <cousin_luigi> I had asked the SUSE singlespec honcho to come here today, but it was a bank holiday, so hopefully he'll be here next week.
12:35:56 <dirk> cousin_luigi: jan matejek?
12:35:58 <cousin_luigi> Just so I know, is it every Thursday?
12:36:01 <cousin_luigi> dirk: Precisely.
12:36:07 <toabctl> cousin_luigi, yes.
12:36:10 <dirk> cousin_luigi: yes, every thursday at 12:00 PM UTC
12:36:12 <cousin_luigi> Good.
12:36:25 <toabctl> number80, any update on the python3 fedora side?
12:36:31 <toabctl> maybe in regards to singlespec?
12:36:38 <dirk> cousin_luigi: both toabctl and I are pretty active on singlespec
12:36:50 <cousin_luigi> dirk: Sorry for having misrepresented things:)
12:36:53 <dirk> it is clear that we need to come up iwth a strategy
12:36:57 <cousin_luigi> Perhaps I just don't know.
12:37:05 <number80> nope, I was in PTO last week (it's like I'm getting more and more PTO, I just got 7 additional days recently)
12:37:24 <dirk> cousin_luigi: no, sorry. it's good that you keep it in our minds, the problem definitely doesn't go away
12:37:45 <dirk> openSUSE would like to switch to python3 default now and the openstack pile of packages (which come from rpm_packaging) are definitely a limiting factor here
12:38:07 <dirk> maybe we can do it one step a  time
12:38:23 <dirk> question: are we good with letting the current python 2.x builds be named python2-xxx going forward?
12:38:46 <dirk> if so, then we could add the python_provides macro and have at least a singlespec-compatible way to build python2.x only packages
12:39:21 <number80> dirk: renaming into python2-xxx is fine
12:39:45 <dirk> so when you say renaming, we need a provide/obsoletes, right?
12:39:55 <number80> as for python3, I have yet no answers myself until RHEL8 is out (and that's the one million dollar question even for myself)
12:40:19 <toabctl> we could just add the Provides: python2-
12:40:20 <number80> dirk: yes but we have a macro for that
12:40:23 <toabctl> without renaming it
12:40:30 <number80> toabctl: won't work for upgrades
12:40:54 <number80> we had similar issues when Fedora renamed stuff from python to python2
12:40:56 <dirk> toabctl: sure, but thats even less compatible with singlespec I'd say
12:41:14 <dirk> toabctl: lets do it the same way like singlespec as long as we can't swithc to singlespec yet
12:41:47 <dirk> number80: not sure how RHEL8 is related.. the singlespec approach offes the ability to build both 2.7 and 3.x, only one of them, and select the default one that is providing the python-XX provides
12:42:10 <dirk> number80: so we could use singlespec but have a flavor that says "only build python2" or "only build python3" or "build both python2.x and 3x"
12:42:12 <IgorYozhikov> during last meeting was made suggestion about using flavor for singlespec
12:42:24 <number80> dirk: for us, it will define how we will ship python3 and may even impact packaging if we use technologies like SCL
12:42:29 <dirk> the goal I think for the next major SLE release is that it will be python 3.x only I think
12:42:32 <cousin_luigi> dirk: doesn't singlespec already have that?
12:42:47 <cousin_luigi> skip_pythonX macro
12:44:13 <toabctl> number80, what is SCL?
12:45:16 <dirk> cousin_luigi: isn't that what I tried to say? :)
12:45:33 <toabctl> I guess software collections?
12:46:01 <number80> toabctl: yes, if you want my opinion, it should be renamed as PITA
12:46:38 <number80> Well, when life gives SCL, you drink rum
12:46:52 <dirk> lol
12:46:55 <cousin_luigi> dirk: I thought it was something about the convoluted way openstack produces .spec files, but don't mind me, I fear I'm drunk.
12:47:26 <dirk> number80: can you elaborate a bit (not on the rum part) ?
12:47:44 <dirk> number80: so the scenario is that SCL might contain all of python 3.x? or SCL might contain the 2.x versions?
12:48:16 <number80> dirk: we'd need to add some macro magic in spec file to build them against SCL, and it requires a specific buildroot
12:48:51 <number80> and we'd need to rebuild a lot of deps
12:49:26 <toabctl> I guess something like https://access.redhat.com/documentation/en-US/Red_Hat_Developer_Toolset/1/html-single/Software_Collections_Guide/#sect-Converting_a_Conventional_Spec_File
12:50:48 <number80> Well, that's quite a complex migration (it would also affect systemd units and all)
12:51:15 <toabctl> hm.ok
12:52:06 <number80> but again, I don't know what we will be using. We postponed python3 until RHEL8 release, as worst case would be doing migrations twice
12:53:09 <dirk> number80: so can that be done via a renderspec flavor?
12:53:43 <dirk> ah, systemd services
12:53:43 <dirk> hmm
12:53:50 <dirk> ok, we're loosing time a bit
12:53:57 <dirk> so , let me restart the question
12:54:15 <dirk> are we aligned to rename everything to python2-* and add a python-* provides for now?
12:54:54 <cousin_luigi> dirk: Isn't that going to mess with python3 in tumbleweed?
12:54:56 <toabctl> hm. that's a lot of work without getting py3 support. I would prefer todo that in one run tbh
12:54:58 <dirk> toabctl: number80 : jpena : IgorYozhikov : ?
12:55:07 <dirk> toabctl: just one patch to renderspec?
12:55:28 <number80> Yes
12:55:32 <toabctl> oh. true.
12:56:23 <IgorYozhikov> +!
12:56:26 <IgorYozhikov> +1
12:56:54 <jpena> +1
12:57:45 <toabctl> not sure about the "one patch" thing. but not getting py3 isn't nice imo. but +1
12:57:59 <number80> +1
12:58:57 <dirk> ok, any volunteers?
12:59:01 <toabctl> #agreed rename everything to python2-* and add a python-* provides for now
12:59:17 <toabctl> 1 min left...
13:00:12 <toabctl> I can have a look
13:00:25 <dirk> thanks
13:00:28 <dirk> lets end the meeting
13:00:29 <toabctl> #action toabctl look into python2 provides/obsoletes
13:00:33 <toabctl> #endmeeting