12:04:27 <toabctl> #startmeeting rpm_packaging
12:04:28 <openstack> Meeting started Thu Aug  3 12:04:27 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:04:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:04:31 <openstack> The meeting name has been set to 'rpm_packaging'
12:04:34 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:04:45 <jpena> o/
12:04:50 <toabctl> #chair dirk jpena number80
12:04:51 <openstack> Current chairs: dirk jpena number80 toabctl
12:05:44 <toabctl> hey jpena
12:05:57 <toabctl> as usual, put your agenda topics to https://etherpad.openstack.org/p/openstack-rpm-packaging
12:07:29 <toabctl> #topic PTL
12:08:24 <toabctl> jpena, we had that topic already the last 2 weeks. I could candidate for PTL but I'll be on parental leave for some weeks during the Queens cycle. so if you would like to step up as PTL, that would also be fine
12:08:32 <toabctl> if not, I'll just do it :)
12:08:58 <jpena> toabctl: I'd rather not be the PTL for this cycle, so all for you :)
12:09:03 <toabctl> or maybe there are other hidden candidates but I guess ther aren't
12:09:13 <toabctl> ok
12:09:16 <jpena> I wouldn't mind being a substitute PTL during your leave
12:09:30 <toabctl> jpena, oh.ok. sounds good to me.
12:10:20 <toabctl> #topic packaging reviews
12:10:29 <toabctl> anything special in the queue?
12:10:50 <jpena> nothing for me, I just came back after holidays and still catching up
12:11:33 <toabctl> ok
12:11:40 <toabctl> #open floor
12:11:51 <toabctl> #topic open floor
12:12:32 <toabctl> jpena, you might have missed that - I try to find a way to abstract the dependencies more to be able to implement the singlespec approach for the suse side.
12:13:00 <toabctl> openSUSE might no longer accept py2 only packages soon so this is something we need todo
12:13:18 <toabctl> the idea is to create a yaml structure which could then be rendered into a spec for suse/fedora
12:13:36 <toabctl> https://review.openstack.org/#/c/490352/ is a preparation step for that.
12:14:02 <jpena> yep, I saw that review
12:14:11 <toabctl> not sure how good that will work out but I think adding a lot of %if's to the spec.j2 templates will just lead to complicated specs
12:14:35 <toabctl> jpena, if you have any better idea how we could support py2/py3 for opensuse and fedora, tell me :)
12:14:39 <jpena> ok, so the plan is a template within the template
12:15:08 <toabctl> jpena, yes. something like http://paste.openstack.org/show/617415/
12:15:27 <toabctl> which then (via distro-specific templates) can be rendered into a .spec
12:15:54 <toabctl> so now we do spec.j2->spec rendering. the new renderer would be yaml.j2->yaml->spec
12:16:17 <toabctl> the example is not complete. there are lots of thing missing. I'm working on that currently
12:17:19 <jpena> mmm... it looks nice
12:18:55 <toabctl> ah. one more topic - when do we want to branch stable/pike ?
12:19:53 <toabctl> there are stable branches for the libs and clients already. given that we do not have to many services it might be good to branch soon..
12:20:55 <jpena> Let's do it soon, then. We should just check services to make sure we're packaging some recent versions
12:21:05 <toabctl> yes
12:21:32 <toabctl> anything else? otherwise this was a short meeting :)
12:21:53 <jpena> nothing for me :)
12:21:54 <dirk> toabctl: imho we should create a pike branch
12:22:09 <toabctl> dirk, yeah. we discussed that 2 min ago...
12:22:32 <toabctl> well - we missed the action item. I can do it.
12:22:46 <toabctl> #action toabctl creates a stable/pike branch
12:23:14 <dirk> done
12:23:19 <dirk> toabctl: we need to setup ci though
12:23:46 <toabctl> sure
12:24:18 <toabctl> #action toabctl create suse ci for pike
12:24:22 <toabctl> anything else?
12:24:29 <jpena> #action jpena to setup rdo ci for pike
12:26:54 <toabctl> ok. thanks everybody for attending.
12:26:59 <toabctl> #endmeeting