12:01:09 <toabctl> #startmeeting rpm_packaging
12:01:10 <openstack> Meeting started Thu Aug 24 12:01:09 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:13 <openstack> The meeting name has been set to 'rpm_packaging'
12:01:17 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:01:57 <toabctl> anybody arround?
12:02:15 <jpena> o/
12:02:22 <toabctl> hey jpena
12:02:48 <toabctl> let's wait some minutes of somebody else is arroung
12:03:01 <jpena> ok
12:03:05 <toabctl> feel free to add agenda points to https://etherpad.openstack.org/p/openstack-rpm-packaging
12:06:24 <toabctl> let's start
12:06:30 <toabctl> #topic pymod2pkg - handling singlespec
12:06:41 <number80> o/
12:07:01 <toabctl> for https://review.openstack.org/#/c/492931/ I removed the pymod2pkg handling
12:07:54 <toabctl> which does not work (obviously) . but the %python_module macro expands to python-%{**} python3-%{**} so it expects the name without the leading python-
12:08:04 <toabctl> not sure how to handle that with pymod2pkg. any suggestions?
12:08:08 <toabctl> hey number80
12:08:56 <toabctl> I wonder if pymod2pkg should return 2 names instead of one.
12:09:33 <jpena> let me check the macros
12:09:44 <toabctl> jpena, it is the first line in the changeset
12:09:51 <toabctl> %{?!python_module:%define python_module() python-%{**} python3-%{**}}
12:09:59 <jpena> ah ok
12:10:29 <toabctl> just removing the python- prefix would not work in all cases I think (eg. for python-cinderclient)
12:13:04 <toabctl> so pymod2pkg could return 2 names
12:14:29 <jpena> what if we have a new call in pymod2pkg where we return 2 names (for backwards compat)? Then we could have a second macro to get them, like py3pkg (or a better name)
12:14:58 <toabctl> hm. yeah
12:15:27 <toabctl> jpena, so we would need a second mapping for python3 ?
12:15:56 <jpena> toabctl: yes. We have several instances where the python2 and python3 packages have different names in CentOS
12:16:00 <toabctl> we don't not have to use the python_module macro. we could also expand this ourselfs
12:16:16 <toabctl> jpena, oh. interessting. do you have an example?
12:16:32 <jpena> yes: PyYAML vs python3-PyYAML
12:16:35 <toabctl> jpena, that would mean that we need to handle that anyway in pymod2pkg, righ?
12:16:39 <jpena> right
12:16:58 <jpena> same for pyOpenSSL
12:17:06 <toabctl> you are doing crazy things in CentOS :)
12:17:14 * jpena shrugs
12:17:45 <toabctl> ok. so somebody needs to work on pymod2pkg
12:18:04 <toabctl> any volunteer?
12:18:25 <jpena> it's just you and me, with number80 hiding :)
12:18:31 <toabctl> heh
12:18:38 <jpena> I can give it a look
12:18:49 <toabctl> jpena, ok. cool. thx
12:19:01 <toabctl> #action jpena looks into a py3 mapping for pymod2pkg
12:19:22 <toabctl> next topic?
12:19:29 <jpena> yes
12:19:31 <toabctl> #topic packaging reviews
12:19:58 <toabctl> anything special?
12:20:20 <jpena> nothing for me
12:20:32 <toabctl> ok. then next
12:20:37 <toabctl> #topic backports merging policy
12:21:14 <toabctl> I was merging backports with just a single +2 (pardon) and wonder if we could change our policy to allow that
12:21:22 <toabctl> jpena, number80 any opinion on that?
12:21:47 <jpena> did we have a policy?
12:21:52 <toabctl> we do not have many reviewers and from time to time things are slow
12:22:03 <toabctl> jpena, heh. I thought we need 2 +2 :)
12:22:36 <toabctl> jpena, but tbh I think for smaller updates where CI is green we could just merge with a single +2 in general
12:23:41 <jpena> I'm ok with that for cherry-picks. To make it official and reach the other cores, could you open a thread in openstack-dev?
12:24:19 <toabctl> sur
12:24:20 <toabctl> e
12:24:45 <toabctl> #action toabctl mail to openstack-dev about single +2 for merging things
12:25:03 <toabctl> #topic open floor
12:25:06 <toabctl> anything else?
12:26:07 <jpena> not for me
12:26:52 <toabctl> ok. then thanks and goodbye
12:26:54 <toabctl> #endmeeting