12:02:18 <toabctl> #startmeeting rpm_packaging
12:02:19 <openstack> Meeting started Thu Sep 21 12:02:18 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:02:23 <openstack> The meeting name has been set to 'rpm_packaging'
12:02:25 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:02:40 <toabctl> #chair jpena|lunch dirk
12:02:41 <openstack> Current chairs: dirk jpena|lunch toabctl
12:02:55 <toabctl> #topic roll call
12:03:46 <toabctl> anybody arround?
12:04:01 * dirk is here :)
12:04:21 <toabctl> as usual, please fill the agenda with topics
12:04:34 <toabctl> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
12:06:27 <toabctl> dirk, seems we are the only 2
12:06:29 <toabctl> let's start
12:06:36 <toabctl> #topic  packaging reviews
12:06:41 <toabctl> anything special in the queue?
12:07:05 <dirk> the pbr/singlespec stuff
12:07:10 <dirk> but I haven't managed to find time for that yet
12:07:34 <toabctl> I had a bit of time. this is the start: https://review.openstack.org/#/c/492931/
12:07:54 <toabctl> but this needs more work on renderspec to support py2 only builds (needed for the RDO CI)
12:08:11 <dirk> yeah
12:08:21 <jpena> o/
12:08:29 <toabctl> hey jpena
12:10:38 <toabctl> dirk, so what do you want to discuss about singlespec?
12:11:20 <dirk> toabctl: maybe we simply declare py3 unsupported for the fedora case for now?
12:11:42 <dirk> but I'm not convinced the current hardcoding of the py2/py3 version in the renderspec template like we do now is nice
12:11:52 <dirk> toabctl: then on fedora it would not expand to the python3- package
12:12:10 <dirk> jpena: unless you say it will be swift and easy to get the python3 deps available.. ;)
12:12:36 <jpena> dirk: unfortunately, it won't. We'll have to work with the assumption that centos 7 won't get python3 soon
12:13:40 <toabctl> dirk, yes. no py3 for fedora - but still the question how to describe that best and how that works with singlespec
12:13:53 * toabctl needs to play with it a bit to see how that could work..
12:16:32 <dirk> toabctl: imho it should be a cmdline option
12:16:45 <dirk> this way we could build the spec file in a py2 only mode, py2+py3 and py3 mode
12:16:50 <dirk> (for maximizing the amount of pain)
12:17:21 <toabctl> dirk, feel free to propose something. I don't see how you would handle a buildrequire for python-enum34 then
12:17:49 <dirk> toabctl: yeah, thats either context sensitive parsing (bad) or a different macro
12:18:04 <dirk> #action dirk try to propose a solution
12:18:25 <toabctl> dirk, it's also on my todo list. I might also have a look
12:18:33 <toabctl> next?
12:20:04 <toabctl> #topic Gnocchi removal
12:20:12 <toabctl> jpena, is that your topic I guess?
12:20:14 <jpena> yes
12:20:44 <jpena> Since gnocchi has moved away from openstack and into its own namespace, I think we should remove it from rpm-packaging
12:20:50 <jpena> and treat it like any other dependency
12:21:07 <toabctl> yeah. agreed
12:22:41 <dirk> jpena: client as well?
12:22:49 <jpena> yes, same
12:24:13 <toabctl> dirk, are you ok with that?
12:24:32 <dirk> I have no isse with that, that was what the agreed policy is
12:24:42 <dirk> (only package stuff that comes primarily from git.o.o
12:24:59 <toabctl> #agreed remove gnocchiclient
12:25:22 <jpena> ok, I'll propose the removal in master
12:25:23 <dirk> I guess the action item is to fix the CI so that it has the dependencies available
12:25:30 <dirk> otherwise everything will break (openstackclient depends on it)
12:25:44 <toabctl> it does not. only mistral
12:26:05 <jpena> it's ok for the RDO CI
12:26:06 <dirk> ah
12:26:23 <dirk> will mistral drop gnocchiclient as dependency going forward?
12:27:08 <toabctl> not sure. but they can also just use it as any other non-openstack dep
12:27:24 <toabctl> I think gnocchiclient already removed most/all of the oslo* deps
12:27:49 <toabctl> keystoneauth1 is left inside of gnocchiclient
12:27:51 * d0ugal takes note to bring this up at a Mistral meeting
12:28:18 <toabctl> d0ugal, thx
12:28:53 <toabctl> #action jpena remove gnocchiclient
12:29:09 <toabctl> #action toabctl add gnocchiclient in SUSE CI
12:29:22 <toabctl> #topic open floor
12:29:26 <toabctl> anything else?
12:29:31 <sanjayu> Hi all, was wondering if I can ask for openvswitch package with DPDK to be available on centos
12:30:08 <toabctl> hi sanjayu
12:30:16 <sanjayu> hi toabctl
12:30:41 <sanjayu> I was trying to setup ovs-dpdk on tripleo - http://tripleo.org/advanced_deployment/ovs_dpdk_config.html
12:30:52 <toabctl> sanjayu, this is about rpm-packaging for openstack services. I think openvswitch should be provided directly from your distro. maybe jpena knows more about RDO specifics
12:31:10 <sanjayu> and saw the openvswitch package from the cloud repo does not have dpdk built in
12:31:28 <sanjayu> this renders the docs to be wrong
12:32:02 <sanjayu> sorry if this is not the right forum, I am searching the right folks to address this
12:32:37 <jpena> sanjayu: I'm not entirely familiar with DPDK, but this is something that is being worked on. Maybe you can ask in #rdo, there are people more familiar with openvswitch+dpdk integration with TripleO there
12:32:56 <sanjayu> jpena, ok will do
12:33:00 <sanjayu> thanks
12:34:55 <dirk> jpena: quick question, has the software collection discussion progressed? should we take a  a look at how to tackle that with renderspec?
12:35:25 <jpena> dirk: little progress has been made so far, let's wait until there is a decision
12:36:43 <dirk> jpena: when is that expected roughly?
12:37:02 <dirk> as explained at the PTG (to jon and others) sUSE is a bit under pressure to deliver a python3 port
12:37:11 <jpena> dirk: I'd love to know :)
12:38:12 <jpena> if SUSE needs to deliver a python3 port, let's work on the assumption that, for now, python3 support will be exclusive for SUSE
12:42:31 <dirk> jpena: wfm
12:42:43 <dirk> #agreed work under the assumption that python3 support will be exclusive for SUSE
12:42:47 <dirk> anything else?
12:43:55 <jpena> nothing for me
12:49:46 <dirk> toabctl: end it :)
12:49:52 <toabctl> #endmeeting