13:02:00 <jpena> #startmeeting rpm_packaging
13:02:01 <openstack> Meeting started Wed May 16 13:02:00 2018 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:04 <openstack> The meeting name has been set to 'rpm_packaging'
13:02:05 <jpena> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof, ykarel
13:02:15 <jpena> remember to add your items to the agenda at https://etherpad.openstack.org/p/openstack-rpm-packaging
13:02:24 <ykarel> o/
13:03:37 <jpena> #chair ykarel
13:03:38 <openstack> Current chairs: jpena ykarel
13:10:00 <jpena> ykarel, I think it's just you and me
13:10:24 <ykarel> hmm
13:10:47 <jpena> let's go with the agenda and cover what we can
13:11:19 <ykarel> ack
13:11:47 <jpena> #topic requirements.txt file in rpm-packaging repo
13:11:59 <jpena> There is an email thread in openstack-dev about this
13:12:32 <jpena> #link http://lists.openstack.org/pipermail/openstack-dev/2018-May/130423.html
13:13:24 <jpena> We are listed as one of the projects having pycrypto in our requirements.txt file. I have clarified that we only have it because it is a local copy of the upstream global-requirements.txt file, but looking at that I realized it hasn't been updated for a long time
13:13:49 <jpena> Since then, global-requirements.txt has stopped including minimum versions and moved that to lower-constraints.txt
13:14:11 <jpena> So I will open a test review to refresh that file, and see if it breaks anything in our toolchain (renderspec, probably)
13:14:15 <jpena> if so, we'll have to adjust
13:15:34 <jpena> #action jpena to propose requirements.txt refresh
13:15:43 <jpena> #topic reviews
13:16:31 <jpena> ykarel: I've had a look at http://lists.openstack.org/pipermail/openstack-dev/2018-May/130423.html
13:16:54 <ykarel> wrong link
13:16:58 <jpena> ouch
13:17:03 <jpena> https://review.openstack.org/#/c/568219/, I mean
13:17:03 <ykarel> https://review.openstack.org/#/c/568219/
13:17:37 <jpena> so... we have several different issues
13:18:02 <ykarel> yes, different issues with different jobs
13:18:11 <jpena> 1- The tox-linters job assumes --skip-version=py2 when rendering with renderspec, so it's not meant to work with python3-only packages
13:18:28 <ykarel> correction,  --skip-version=py3
13:18:35 <jpena> ykarel: correct
13:19:00 <jpena> 2- For RDO, we still need to have python3-based job using Fedora, which will take a few weeks
13:19:19 <jpena> 3- For SUSE, some packages are missing (I think this could be fixed by moving some packages to singlespec)
13:19:37 <jpena> so let's focus on 1 for now
13:19:54 <ykarel> ack, and what is blocking 2?
13:20:47 <jpena> right now, available time and resources. Once we have the base RDO repos available, we have to create a new VM to build packages using Fedora 28 and those base repos
13:20:56 <jpena> and test that everything works as expected
13:21:31 <ykarel> if something i can take care of above, let me know
13:22:08 <ykarel> can't puppet-dlrn be used to setup fedora 28 vm
13:22:17 <jpena> ykarel: yes, I think so
13:22:34 <jpena> it's more the time to bootstrap the initial worker, create the CI jobs and such
13:22:40 <jpena> I'll try to book some time next week
13:22:48 <ykarel> okk
13:23:27 <jpena> #action jpena to book time to create VM for Fedora-based rpm-packaging
13:23:56 <ykarel> jpena, and when u say base RDO repo, you mean fedora-stable repo, or something else
13:24:06 <jpena> ykarel: yes
13:25:09 <jpena> so, going back to 1, we need to work on the tox-linters job to make it work fine with python3-only packages
13:25:25 <jpena> ykarel: do you think you'd have time to check that?
13:26:22 <ykarel> jpena, focusing on other parts of py3, but will check the job as well
13:27:14 <ykarel> afaic the workaround is coming from long ago
13:27:27 <ykarel> earlier sed was used and now --skip-pyversion
13:27:52 <jpena> yes, I think it will require some research
13:28:26 <ykarel> hmm
13:29:30 <jpena> let's move on?
13:31:12 <ykarel> yes
13:31:42 <jpena> #topic open floor
13:31:51 <jpena> I don't have anything else to discuss, ykarel?
13:32:06 <ykarel> me too nothing
13:32:30 <jpena> ok, let's end the meeting and get 30 minutes back of our time :)
13:32:34 <jpena> #endmeeting