13:02:27 <ykarel> #startmeeting rpm_packaging
13:02:28 <openstack> Meeting started Wed Jun 13 13:02:27 2018 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:31 <openstack> The meeting name has been set to 'rpm_packaging'
13:03:14 <ykarel> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof, ykarel
13:03:20 <jruzicka> o/
13:03:26 <ykarel> #chair jruzicka
13:03:27 <openstack> Current chairs: jruzicka ykarel
13:03:36 <dirk> o/
13:03:50 <ykarel> you can add your agenda here:- https://etherpad.openstack.org/p/openstack-rpm-packaging
13:03:54 <ykarel> #chair dirk
13:03:55 <openstack> Current chairs: dirk jruzicka ykarel
13:05:06 <dirk> I have no agenda items to add
13:05:18 <dirk> mostly busy with keeping up the work after aplanas and toabctl are out atm
13:06:07 <ykarel> ok so let's start with Open Reviews
13:06:21 <ykarel> i have some reviews to enable python3:- https://review.openstack.org/#/q/status:open+project:openstack/rpm-packaging+branch:master+topic:enable-py3
13:07:24 <ykarel> they have some failures in SUSE CI but those seems unrelated to patches
13:08:32 <dirk> yes
13:08:35 <ykarel> so out of these 4 are libraries to be converted to singlespec, and other glance and keystone to convert to python3 only
13:08:50 <dirk> I'm trying to keep the suse ci in green but things are changing quicker than I can recover it
13:09:08 <dirk> I did merge the os.win and some other change yesterday, the rest can be rebuilt
13:09:54 <ykarel> Thanks dirk, so only few are remaining now, can you look at those
13:10:06 <dirk> yes, I take the action item
13:10:32 <dirk> I do need some prior fixes to have suse ci to pass
13:10:50 <dirk> currently cinder, keystone, monasca-log-api and horizon are all failing against master
13:11:05 <dirk> and those reviews will trigger those packages and hence won't pass until these are fixed first
13:11:18 * dirk remembers why he hates tracking *master.tar.gz in master
13:11:57 <ykarel> #action dirk to look at fixing SUSE CI and review enable-py3 patches
13:13:02 <openstackgerrit> Dirk Mueller proposed openstack/rpm-packaging master: cinder: add cursive dependencies  https://review.openstack.org/575106
13:13:16 <dirk> ykarel: can you review https://review.openstack.org/#/c/574758/ ?
13:13:26 <ykarel> dirk, sure
13:13:34 <dirk> I need to add one more package and then at least this one should no longer be a problem
13:14:09 <ykarel> ack, +1
13:14:41 <ykarel> dirk, so you can self merge this now?
13:15:01 <dirk> yes, I'll merge it once I got the keystone to pass
13:15:09 <ykarel> Okk
13:17:42 <ykarel> so moving to open floor
13:17:46 <ykarel> #topic open floor
13:19:04 <dirk> ykarel: can you review https://review.openstack.org/#/c/571604/ ?
13:19:49 <dirk> ykarel: https://review.openstack.org/#/c/574887/ is another one that would unbreak the SUSE CI
13:20:37 <ykarel> dirk, done 571604
13:20:51 <ykarel> dirk, in other one need to check why rdo dlrn is failing in fedora
13:22:13 <ykarel> okk we don't have those packages in fedora
13:22:30 <ykarel> +1
13:23:21 <jruzicka> I didn't get to renderspec reqs extension, fighting fires... sorry.
13:27:05 <ykarel> jruzicka, no worries
13:28:36 <dirk> anything else?
13:28:52 <ykarel> nothing from me
13:30:41 <ykarel> so we can close now
13:32:23 <ykarel> #endmeeting