14:17:21 <dirk> #startmeeting rpm_packaging
14:17:22 <openstack> Meeting started Wed Nov 28 14:17:21 2018 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:17:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:17:25 <openstack> The meeting name has been set to 'rpm_packaging'
14:17:42 <dirk> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof, ykarel
14:17:52 <toabctl> hey
14:17:57 <number80> o/
14:18:00 <jpena> o/ (multi-booked)
14:18:42 <dirk> me too
14:18:57 <dirk> please add your topics to https://etherpad.openstack.org/p/openstack-rpm-packaging
14:20:43 <openstackgerrit> Dirk Mueller proposed openstack/rpm-packaging master: Add new %__openstack_set_env macro  https://review.openstack.org/619042
14:21:05 <toabctl> nothing from my side
14:21:25 <dirk> #topic  https://review.openstack.org/#/c/619042/
14:23:47 <dirk> thats from you, number80 ?
14:24:23 <dirk> anything you want to discuss? I just +2ed it
14:25:41 <cmurphy> o/
14:26:00 <openstackgerrit> Dirk Mueller proposed openstack/rpm-packaging master: Update castellan to 1.0.0  https://review.openstack.org/619289
14:26:17 <dirk> number80 we'll come back to this when you have time
14:26:24 <dirk> #topic switching renderspec to py3?
14:27:12 <number80> Yep, I'm discussing it with other folks, we may just do that in the next weeks and keep a switch for people who still need py2 versions
14:27:47 <dirk> just to understand this better, are oyu asking about the renderspec spec file to become py3 only or renderspec becoming py3 only?
14:27:58 <dirk> or py3 compatible? it should be already py3 compatible (I use it via python 3.6)
14:29:39 <number80> spec files
14:30:31 <number80> after RHEL8 is released, we can consider just having a python3-only renderspec (code-wise)
14:30:45 <dirk> any opinions?
14:30:54 <dirk> we can either do singlespec or py3 only, both would work for me
14:31:39 <dirk> now that pymod2pkg is signlespec, renderspec would be the next step
14:31:52 <dirk> I think I tried to do that conversion before and was hanging on pymod2pkg which wasn't ready
14:32:17 <number80> works for me
14:33:39 <dirk> #agreed add py3 to renderspec spec file
14:33:41 <dirk> anything else?
14:33:54 <dirk> number80: can you do a review?
14:35:20 <number80> sure
14:35:45 <dirk> thanks!
14:35:48 <dirk> #topic open floor
14:36:07 <dirk> I guess the topic is whether we could adjust the meeting time an hour earlier? I have two meetings at this time :(
14:36:39 <number80> I might be 10 min late but works for me
14:36:46 <openstackgerrit> Dirk Mueller proposed openstack/rpm-packaging master: Update stevedore to 1.30.0  https://review.openstack.org/619298
14:38:53 <toabctl> works for me
14:39:12 <dirk> we can also do 2:30 :)
14:40:10 <toabctl> 2.30-3.00 CET should be enough usually
14:40:18 <number80> Then perfect
14:41:17 <dirk> I'll do a review
14:41:17 <dirk> thanks
14:41:20 <dirk> any other topics?
14:41:59 * number80 is fine
14:44:47 <toabctl> nope
14:49:35 <dirk> #endmeeting