13:38:28 <dirk> #startmeeting rpm_packaging
13:38:29 <openstack> Meeting started Wed Jan  9 13:38:28 2019 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:38:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:38:32 <openstack> The meeting name has been set to 'rpm_packaging'
13:38:34 <dirk> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof, ykarel
13:38:39 <dirk> #topic roll call
13:39:43 <toabctl> hey
13:39:50 <toabctl> but I have to leave in 5 min...
13:40:10 <jpena> o/
13:40:21 <jpena> multi-booked again :-/
13:41:12 <cmurphy> o/
13:41:19 <dirk> #chair toabctl  jpena  cmurphy
13:41:20 <openstack> Current chairs: cmurphy dirk jpena toabctl
13:41:39 <dirk> jpena: ok, so later is better?
13:41:55 <jpena> dirk: no, this is ok, it's just that I have a recurrent meeting once every 3 weeks
13:42:04 <dirk> ah, ok, you told me that 3 weeks ago :)
13:42:08 * dirk remembers
13:42:12 <jpena> and I've been away since :)
13:42:13 <dirk> ok, lets go over the agenda
13:42:20 <dirk> #topic   proposing cmurphy as core
13:42:37 <evrardjp> sounds like a great idea
13:42:47 <toabctl> that's me. I wanted to proposed colleen as a core reviewer
13:43:03 <jpena> +1 for that, she's been consistently providing good reviews for a long time
13:43:09 <dirk> +1 from me
13:43:16 <toabctl> +1 from me (obviously)
13:43:17 <dirk> #agreed cmurphy as rpm-packaging core
13:43:24 <cmurphy> \o/
13:43:40 <dirk> who writes an email to the list? should I simply announce it?
13:43:44 <dirk> or ask for email voting?
13:43:55 <dirk> I think the normal procedure is email voting
13:44:13 <jpena> I think so, email voting is usually the norm
13:44:47 <dirk> ok, I'll check with toabctl if he or me initiates that
13:44:50 <toabctl> ah. forgot about that. I can write a mail with the proposal. or is that usually the PTL doing?
13:44:58 <toabctl> yeah. we can figure it out.
13:45:05 <dirk> #action dirk/tom do email nomination
13:45:13 <dirk> #topic space for denver ptg
13:45:45 <dirk> I recently received an email asking to enter our interest in getting a room/space allocated at the upcoming PTG in denver
13:45:58 <dirk> It is May 2nd-4th, immediately after the summit I think
13:46:12 <dirk> we need to answer by January 20nd
13:46:35 <dirk> is anyone going? should we staff a room or do the more informal grouping in the infra corner or the like?
13:46:52 <toabctl> I guess I'll not go. but not sure yet.
13:46:55 <dirk> for me personally its not clear whether I'll be able to travel, the week is overlapping some other commitment
13:47:25 <jpena> I don't know if I will attend (assuming no, but not sure). I'll ask and try to have a better idea next week
13:47:45 * toabctl has to leave...
13:48:57 <dirk> ok, it looks like tentantively no
13:49:10 <dirk> I'll give a tentative update and we can discuss it next week again
13:49:36 <dirk> #action dirk revisit denver PTG plan in jan 15th meeting
13:49:43 <dirk> #topic open floor
13:49:50 <dirk> any reviews/things to discuss?
13:53:26 <dirk> last 5 mins to speak up
13:53:33 * dirk doesn't want to be the person with 90 % of the log messages
13:53:51 <dirk> evrardjp: do you want to raise the OSA issues?
13:55:42 <dirk> ah, I see one topic
13:55:54 <evrardjp> mm Nothing to raise immediately
13:55:55 <dirk> #topic pyc excludes
13:56:14 <dirk> in e.g. openstack/freezer-web-ui/freezer-web-ui.spec.j2 and others we have this in the filelist
13:56:21 <dirk> %exclude %{http_dashboard_dir}/openstack_dashboard/enabled/*.pyc
13:56:35 <dirk> just found the same in https://review.openstack.org/#/c/629398/4/openstack/heat-dashboard/heat-dashboard.spec.j2
13:57:14 <dirk> I would tend to say this is wrong, as "modified" pyc/pyo files will then remain on the disk on uninstall, causing most likely horizon to crash (because they initialize the django app which however isn't there anymore)
13:57:19 <dirk> any comments, opinions?
13:59:06 <openstackgerrit> Merged openstack/rpm-packaging master: os-traits: Convert to singlespec  https://review.openstack.org/629396
13:59:22 <evrardjp> dirk: sounds reasonable to me dirk
13:59:37 <cmurphy> there must be a reason they were added in the first place?
14:00:36 <evrardjp> I suppose people think it will prevent them from being packaged in the first place?   I don't know -- just speculations from a noob here
14:00:54 <dirk> jpena: do you know?
14:01:39 <jpena> no, I don't know why they are excluded
14:01:55 <jpena> they should be in, as you mentioned
14:01:57 <dirk> cmurphy: I haven't done the gitalytics but I'd be pretty sure they've been there from the start
14:02:39 <dirk> ok, agreement to fix this?
14:02:44 <dirk> any volunteers ?= :)
14:04:29 <dirk> #agreed do not exclude bytecode (pyc/pyo) from openstack horizon dashboard plugin filelists
14:04:41 <dirk> looks like no volunteers today :/
14:04:45 <dirk> #endmeeting