12:30:46 <toabctl> #startmeeting rpm_packaging
12:30:47 <openstack> Meeting started Wed Aug 21 12:30:46 2019 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:30:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:30:50 <openstack> The meeting name has been set to 'rpm_packaging'
12:30:52 <toabctl> ping toabctl, dirk, apevec, jpena, jruzicka, number80, kaslcrof, cmurphy
12:31:44 <toabctl> as usual, please add your agenda topics to https://etherpad.openstack.org/p/openstack-rpm-packaging
12:32:24 <dirk> o/
12:34:13 <toabctl> dirk, while waiting for others, could you look at https://review.opendev.org/#/c/677701/ and https://review.opendev.org/#/c/677702/ please?
12:35:15 <dirk> sure
12:36:05 <toabctl> dirk, also https://review.opendev.org/#/c/677691/
12:39:01 <toabctl> ok. let's start
12:39:03 <toabctl> #topic python3 and new services
12:39:21 <toabctl> just wanted to say that I'm currently working on adding new services (like barbican)
12:39:27 <openstackgerrit> Dirk Mueller proposed openstack/pymod2pkg master: update git.openstack.org to opendev  https://review.opendev.org/656224
12:39:37 <toabctl> also dirk did a lot of py3 work recently
12:39:39 <toabctl> thanks for that
12:40:09 <toabctl> dirk, any comments/questions to that topic?
12:40:40 <dirk> toabctl: working on horizon (which seems large) and placement (not had enough time for it)
12:40:50 <toabctl> dirk, horizon got merged
12:40:54 <toabctl> I fixed it this morning
12:41:29 <dirk> ah, thanks
12:41:48 <dirk> that should certainly unblock a lot of buildfailures because the python 2.x stack did not work on rdo
12:42:58 <dirk> that means https://review.opendev.org/651631 has a chance of being mergeable
12:43:06 <openstackgerrit> Dirk Mueller proposed openstack/rpm-packaging master: Remove redundant defattr  https://review.opendev.org/651631
12:43:58 <dirk> who takes the action item to release a new version for pymod2pkg?
12:44:10 <toabctl> I can
12:44:25 <toabctl> jpena, is there anything else missing in pymod2pkg except the semantic_vesion fix?
12:44:38 <jpena> toabctl: bot that I'm aware of
12:44:40 <jpena> not*
12:44:57 <toabctl> #action toabctl will trigger a new pymod2pkg release
12:45:01 <toabctl> #topic airship packaging
12:45:04 <toabctl> dirk, ^^
12:47:14 <dirk> sorry, got disrupted
12:47:33 <dirk> this is a subquestion of a larger question
12:47:42 <dirk> currently in rpm-packaging we have an openstack/ directory
12:47:58 <dirk> however with the move to opendev, not everything we have under openstack/ is under openstack/ in opendev
12:48:06 <dirk> e.g. xstatic* moved to x/ in opendev
12:48:16 <dirk> similarly I'd like to add airship packages under airship/
12:48:32 <dirk> so a) do we want to clean up openstack/ to match the layout of opendev/openstack etc ?
12:48:46 <dirk> and b) any concerns about adding airship/ as subdirectory for further packaging coming from there?
12:49:42 <toabctl> re a) - I don't care currently and I wouldn't do the cleanup now
12:50:02 <jpena> same about A)
12:50:13 <toabctl> re b) - fine for me. I guess we need to adjust the tooling for tox to also render/check specs in different directories
12:50:34 <toabctl> easiest would be to just add the packages to openstack/ I thinlk
12:51:12 <toabctl> so both would be fine for me - adding airship to openstack/ or creating a new airship/ and fix tooling
12:52:13 <dirk> I guess moving some stuff out of openstack/ into x/ would help fixing the tooling, so that whoever adds something in airship/ doesn't have to learn how to do that
12:52:28 <dirk> okay, so no concerns about additional opendev "tenants" being packaged?
12:52:34 <dirk> I guess thats an agreement then
12:52:36 <toabctl> not from my side
12:52:50 <dirk> #agreed add other opendev tenants like e.g. airship under rpm-packaging/airship subdirectories
12:53:06 <jpena> I'll need to check the DLRN toolset, but not a deal breaker for now
12:53:19 <openstackgerrit> Merged openstack/pymod2pkg master: Add RDO mapping for semantic_version  https://review.opendev.org/677702
12:53:28 <toabctl> #topic open floor
12:53:32 <toabctl> anything else?
12:54:13 <toabctl> ah. there is one thing - we plan to build containers based on the packages we create with rpm-packaging - but some stuff inside (eg. logrotate, systemd, ...) is not needed for containers
12:54:42 <toabctl> should we move logrotate and systemd related things to subpackages?
12:55:11 <toabctl> jpena, how do you handle that with kolla and rdo packages? are you just installing everything?
12:56:07 <jpena> toabctl: everything gets installed, but I'm not sure if we have an explicit logrotate dependency, for example
12:58:22 <toabctl> ok
12:58:43 <toabctl> I guess I might need to think a bit more about this
12:58:51 <toabctl> anything else to discuss? dirk ? jpena ?
12:59:08 <jpena> no, nothing for me
12:59:35 <openstackgerrit> Thomas Bechtold proposed openstack/rpm-packaging master: update openstacksdk 0.32.0  https://review.opendev.org/665306
12:59:49 <dirk> toabctl: yeah, I think optimizing for size of the ocntainers can be done later
13:00:01 <dirk> toabctl: for me thats mostly an exercise of adding layers to the containerisation
13:00:36 <toabctl> dirk, if you install from packages, you need to split the packages correctly
13:00:49 <toabctl> but we can optimize it later, true
13:00:55 <toabctl> thanks for attending!
13:00:56 <dirk> ah, maybe something about the descriptions for the containers?
13:01:10 <dirk> but thats not urgent atm
13:01:21 <toabctl> dirk, you mean adding them to rpm-packaging?
13:02:04 <toabctl> ok. I need to leave
13:02:14 <toabctl> we can continue to discuss outside of the meeting
13:02:16 <toabctl> #endmeeting