12:33:13 <jpena> #startmeeting rpm_packaging
12:33:14 <openstack> Meeting started Wed Sep 18 12:33:13 2019 UTC and is due to finish in 60 minutes. The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:33:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:33:17 <openstack> The meeting name has been set to 'rpm_packaging'
12:33:17 <jpena> ping toabctl, dirk, apevec, jpena, jruzicka, number80, kaslcrof, cmurphy, rha
12:33:27 <jpena> Remember to add any topics to the agenda at https://etherpad.openstack.org/p/openstack-rpm-packaging
12:34:05 <jpena> #topic roll call
12:34:27 <cmurphy> o/
12:35:08 <jpena> #chair cmurphy
12:35:09 <openstack> Current chairs: cmurphy jpena
12:41:09 <rha> hi. Sorry for being late.
12:41:33 <dirk> o/
12:42:02 <jpena> #chair dirk rha
12:42:03 <openstack> Current chairs: cmurphy dirk jpena rha
12:42:20 <jpena> I see no topics in the agenda, let's go straight to the open floor then
12:42:23 <jpena> #topic open floor
12:42:27 <jpena> Any topics to discuss?
12:42:38 <jpena> #undo
12:42:39 <openstack> Removing item from minutes: #topic open floor
12:42:48 <jpena> now I see we're getting them :)
12:43:06 <jpena> #topic cookiecutter templates
12:43:33 <jpena> who proposed this topic?
12:44:34 <dirk> mine
12:44:46 <dirk> sorry, seems to have lost the etherpad cookie
12:45:32 <dirk> the topic is about solving the need that "which spec file is the one that I should copy&paste from for creating a new package"? problem
12:46:12 <dirk> I would suggest that we have some __template__ .spec.j2 for one or two common usecases (like some py3 only package / openstack service/ singlespec'ed one)
12:46:21 <dirk> potentially fewer templates to start from is better
12:46:47 <dirk> any feedback/opinions about that? while I generally know which spec files are "better" as source of inspiration to others, that doesn't well translate to others
12:47:41 <cmurphy> that sounds like a good idea
12:47:42 <jpena> I think it's a good idea. We used to have a similar concept for RDO in https://github.com/rdo-infra/example-distgit
12:48:53 <rha> Yeah, sounds good to me as well.
12:48:53 <dirk> any proposals which spec templates we should create?
12:48:57 <dirk> any volunteers? :)
12:51:22 <dirk> any good examples to rationalize from?
12:51:26 <rha> I think something for openstack services seems to be the most useful one. Those tend to be more complex.
12:51:38 <dirk> I would pick one of the oslo.* spec files as starter to create the cookiecutter from
12:55:52 <jpena> sounds good as a started. I guess oslo, client and service would be good candidates
12:55:59 <jpena> starter*
12:58:49 <jpena> I need to join another meeting, shall we move on?
13:02:12 <cmurphy> sure
13:03:28 <dirk> jpena: yes, sorry, I'll take the action for now
13:03:38 <dirk> #action dirk make initial cookiecutter review
13:03:41 <jpena> great, thanks
13:03:51 <jpena> #topic more periodic tests?
13:03:58 <dirk> lets skip that for today
13:04:21 <dirk> #topic open floor
13:04:27 <dirk> there are a few urgent reviews to look at:
13:04:29 <dirk> https://review.opendev.org/#/c/682860/
13:04:38 <dirk> https://review.opendev.org/#/c/682883/
13:04:50 <dirk> https://review.opendev.org/#/c/682027/
13:05:02 <dirk> https://review.opendev.org/#/c/682320/
13:05:07 <cmurphy> we talked about doing a project update at the summit and then i went on vacation, did a brainstorm happen and did we get a session reserved?
13:05:07 <dirk> would be good to get some reviews.. :-)
13:05:30 <dirk> ugh
13:05:34 <dirk> cmurphy: I don't know..
13:05:55 <dirk> I actually think we have a few things to talk about this time, there was a large spike in activity recently
13:06:20 <jpena> I'll try to find some time later today for the reviews
13:06:21 <cmurphy> these were my slides from last time fwiw https://docs.google.com/presentation/d/1DCuIu6A6mdrMVRGY5HyffT7e3LBkzDCZOa1wj6IJO2s/edit?usp=sharing
13:06:24 <dirk> https://review.opendev.org/#/c/682320/
13:06:27 <dirk> argh
13:06:32 <dirk> https://github.com/openstack/rpm-packaging/graphs/contributors
13:06:50 <dirk> cmurphy: could you do a copy of them and I'll find som etime (likely tomorrow afternoon) for that?
13:07:16 <cmurphy> sure
13:08:06 <cmurphy> https://docs.google.com/presentation/d/1PWB4POjOgseWL8KjEL5ztYjJxMVk9BQBPV-Sv7-kK0w/edit?usp=sharing
13:08:58 <cmurphy> i'll go ahead and sign up with kendall
13:09:40 <dirk> thanks!
13:18:25 <openstackgerrit> Merged openstack/rpm-packaging master: Remove patch that went upstream https://review.opendev.org/682883
13:18:41 <jpena> anything else to discuss?
13:21:02 <cmurphy> seems like not
13:21:48 <jpena> #endmeeting