13:33:22 <jpena> #startmeeting rpm_packaging
13:33:23 <openstack> Meeting started Thu Jan 23 13:33:22 2020 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:33:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:33:26 <openstack> The meeting name has been set to 'rpm_packaging'
13:33:30 <jpena> ping toabctl, dirk, apevec, jpena, jruzicka, number80, kaslcrof, cmurphy, rha
13:33:44 <jpena> remember to add any last-minute topics to the agenda at https://etherpad.openstack.org/p/openstack-rpm-packaging
13:33:47 <jpena> #topic roll call
13:33:54 <dirk> o/
13:33:57 <cmurphy> o/
13:33:58 <dirk> stuck in an offsite today :/
13:34:52 <jpena> #chair dirk cmurphy
13:34:53 <openstack> Current chairs: cmurphy dirk jpena
13:37:38 <rpittau> o/
13:37:44 <jpena> #chair rpittau
13:37:45 <openstack> Current chairs: cmurphy dirk jpena rpittau
13:38:32 <jpena> let's start with the agenda
13:38:40 <jpena> #topic python2 removal
13:38:54 <dirk> jpena++
13:38:59 <dirk> thanks for all the reviews
13:39:09 <dirk> I'm trying to help on the review side (unbreaking the ci parts)
13:39:21 <jpena> We're making progress with the topic, although more reviews are needed for https://review.opendev.org/#/q/status:open+project:openstack/rpm-packaging+branch:master+topic:remove-python2
13:39:51 <jpena> dirk: yes, I saw the horizon part... That's going to take a while, we need django 2.2 (which is not going to happen on Fedora, but I'm make it sure we get it for CentOS 8)
13:40:01 <jpena> I'm making*
13:40:06 <dirk> hmm
13:40:19 <dirk> ok, then I try to add the old django_compressor for now
13:40:22 <dirk> to unblock us
13:40:28 <dirk> as an overlay
13:42:04 <jpena> once the current reviews are merged, I can take care of sending a new batch, and as soon as we get to the end of the tunnel, we'll have centos8 available for master
13:42:24 <toabctl> hey & sorry for being late.
13:42:29 <jpena> #chair toabctl
13:42:30 <openstack> Current chairs: cmurphy dirk jpena rpittau toabctl
13:42:45 <jpena> which brings us to our second topic
13:42:55 <jpena> #topic CentOS8-based Train builder issues
13:43:32 <jpena> I just realized we have an issue for Train: we want to remove the Fedora-based builder, but we won't backport all the python2 removal patches to Train... and we don't have the python2 dependencies for CentOS 8
13:43:47 <dirk> I would prefer python 2.x removal on train
13:44:10 <dirk> not sure if you want to go that direction but it would make my life easier
13:44:28 <jpena> oh, then it's fine for me :). I'm happy to cherry-pick all reviews once we gret it fine on master
13:44:34 <dirk> I agree its breaking the standard stable policy that we have not committed to be following so far
13:45:04 <jpena> if we backport, we will be able to remove Fedora and keep train and later on centos8
13:45:11 <jpena> so +1 for me
13:45:23 <jpena> any other opinions?
13:46:47 <rpittau> totally fine with thtat
13:47:23 <toabctl> I'm fine with that but I won't have much time to do actual work on the backport stuff.
13:47:44 <toabctl> cmurphy, rha ?
13:48:22 <cmurphy> it's okay with me
13:50:05 <jpena> #agreed We will backport the python2 removal patches to stable/train
13:50:33 <jpena> cool, let's move on then
13:50:40 <jpena> #topic open floor
13:50:49 <jpena> Any other topics to discuss?
13:53:00 <rha> Hey, sorry for being late. Just coming from another meeting :/ I guess I missed all the fun.
13:53:28 <dirk> jpena: I guess the other thing that keeps bugging suse ci is the magnum package
13:53:36 <dirk> which fails building and noone seems to be having time to fix it
13:53:40 <dirk> should we just delete it?
13:54:12 <jpena> dirk: is it just the unit tests that are failing?
13:54:23 <jpena> we could disable them temporarily
13:54:31 <jpena> (we did that for RDO a few times)
13:54:35 <dirk> thats also okay for me
13:56:42 <dirk> ok, will do
13:58:14 <jpena> I have to join another meeting in ~5 minutes, anything else?
13:59:21 <dirk> not from me
13:59:41 <toabctl> I have nothing.
14:00:07 <jpena> ok, then let's call it a day
14:00:10 <jpena> #endmeeting