13:35:14 <jpena> #startmeeting rpm_packaging
13:35:15 <openstack> Meeting started Thu Feb  6 13:35:14 2020 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:35:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:35:18 <openstack> The meeting name has been set to 'rpm_packaging'
13:35:19 <jpena> ping toabctl, dirk, apevec, jpena, jruzicka, number80, kaslcrof, cmurphy, rha
13:35:22 <jpena> #topic roll call
13:35:36 <jpena> Remember to add any last-minute topic to the agenda at https://etherpad.openstack.org/p/openstack-rpm-packaging
13:35:50 <cmurphy> o/
13:36:08 <toabctl> hi
13:36:34 <rha> o/
13:36:47 <jpena> #chair cmurphy toabctl rha
13:36:48 <openstack> Current chairs: cmurphy jpena rha toabctl
13:37:09 <openstackgerrit> Thomas Bechtold proposed openstack/rpm-packaging master: yaql: convert to python3  https://review.opendev.org/703088
13:37:17 <rpittau> o/
13:37:33 <jpena> #chair rpittau
13:37:34 <openstack> Current chairs: cmurphy jpena rha rpittau toabctl
13:40:06 <jpena> let's start
13:40:12 <jpena> #topic Vancouver PTG survey
13:41:00 <jpena> I have received an email asking if we want to want to reserve a room in the Vancouver PTG (June 8-11)
13:41:31 <toabctl> I'll not go
13:41:33 <jpena> Personally, I don't know if I will be attending, what about the rest? Is it worth to ask for a room, or can we just meet ad-hoc if we finally go?
13:42:10 <cmurphy> i don't know if i will be there either
13:42:24 <rha> I won't be there.
13:42:33 <rpittau> not sure I'll be there :/
13:43:45 <jpena> ok, then we will not request a meeting room.
13:43:57 <jpena> #agreed We will not request a meeting room in the Vancouver PTG
13:44:10 <jpena> #topic Python2 removal status
13:44:27 <jpena> We keep on making good progress -> https://etherpad.openstack.org/p/rpm-packaging-python2-packages
13:44:47 <jpena> I see toabctl has approved some patches (thanks!!), so once they're merged I'll check what are the next packages we can update
13:45:46 <openstackgerrit> Merged openstack/rpm-packaging master: oslo.privsep: convert to python3  https://review.opendev.org/703971
13:45:46 <openstackgerrit> Merged openstack/rpm-packaging master: pycadf: convert to python3  https://review.opendev.org/703935
13:46:31 <jpena> Once everything is merged, I'll bootstrap the centos8-based repos and get rid of the Fedora job
13:46:44 <jpena> then we'll backport the whole set of patches to stable/train
13:49:13 <openstackgerrit> Merged openstack/rpm-packaging master: oslo.rootwrap: convert to python3  https://review.opendev.org/703061
13:49:14 <openstackgerrit> Merged openstack/rpm-packaging master: python-novaclient: convert to python3  https://review.opendev.org/703359
13:49:42 <cmurphy> sounds great
13:50:30 <jpena> that's all for this topic, let's move on
13:50:34 <jpena> #topic open floor
13:50:43 <jpena> Anything else you'd like to add?
13:51:14 <rpittau> jpena: just wondering what we want to do for https://review.opendev.org/702227
13:51:43 <jpena> oh, the python3-construct review
13:51:47 <rpittau> yeah
13:52:09 <jpena> toabctl: did you have time to check why the SUSE CI has a higher version than in u-c?
13:52:20 <toabctl> nope
13:54:02 <openstackgerrit> Merged openstack/rpm-packaging master: pymod2pkg: convert to python3  https://review.opendev.org/705688
13:54:03 <openstackgerrit> Merged openstack/rpm-packaging master: oslo.middleware: convert to python3  https://review.opendev.org/704162
13:54:04 <openstackgerrit> Merged openstack/rpm-packaging master: os-api-ref: convert to python3  https://review.opendev.org/705687
13:54:05 <openstackgerrit> Merged openstack/rpm-packaging master: os-ken: convert to python3  https://review.opendev.org/705684
13:54:06 <openstackgerrit> Merged openstack/rpm-packaging master: update octavia-lib to 1.5.0  https://review.opendev.org/705929
13:54:22 <rpittau> are we using different repos then standard ? The version I found for that package should be 2.8.12 in suse 15
13:56:47 <openstackgerrit> Javier Peña proposed openstack/rpm-packaging master: python-neutronclient: convert to python3  https://review.opendev.org/703052
13:56:48 <cmurphy> the master branch ci uses this one i think https://build.opensuse.org/package/show/devel:languages:python:backports/python-construct 2.9.45
13:56:58 <rha> Yeah, we might be using the one from the devel:languages:python:backports project.
13:57:23 <cmurphy> fwiw i experimented with bumping the version in requirements but it breaks ironic-inspector
13:58:15 <cmurphy> i can try to look into packaging the right version for the cloud project today
13:58:35 <jpena> that'd be awesome, thanks!
13:58:42 <rpittau> cmurphy: that's great, thanks :)
14:02:26 <jpena> anything else to discuss? If not, we're getting some time back for coffee
14:02:49 <cmurphy> nothing from me
14:03:42 <rha> not from me either
14:04:13 <jpena> alright, let's close then
14:04:16 <jpena> #endmeeting