13:31:31 <jpena> #startmeeting rpm_packaging
13:31:32 <openstack> Meeting started Thu Oct  1 13:31:31 2020 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:31:35 <openstack> The meeting name has been set to 'rpm_packaging'
13:31:36 <jpena> ping toabctl, dirk, apevec, jpena, number80, kaslcrof,  rha, hberaud, sboyron
13:31:40 <jpena> #topic roll call
13:31:52 <jpena> Remember to add any last-minute topic to the agenda at https://etherpad.opendev.org/p/openstack-rpm-packaging
13:32:08 <dirk> o/
13:32:17 <jpena> #chair dirk
13:32:19 <openstack> Current chairs: dirk jpena
13:32:41 <hberaud> o/
13:33:38 <jpena> #chair hberaud
13:33:39 <openstack> Current chairs: dirk hberaud jpena
13:35:11 <jpena> let's start with the agenda
13:35:17 <jpena> #topic branching?
13:35:41 <jpena> next week we will have the final RCs, so it might be a good moment for branching
13:35:49 <hberaud> +1
13:36:33 <hberaud> If I'm right only trailing projects will remains branchless for now
13:37:05 <hberaud> and fully brancless projects too
13:37:56 <dirk> well, we're not really a trailing project anymore? ;)
13:38:20 <dirk> we could be branching right now I think
13:38:28 <jpena> we're a SIG now, although there's still one missing review...
13:38:30 <dirk> alternatively toabctl is currently trying to get testing going
13:38:46 <dirk> jpena: sig for the next cycle I think, current cycle is still old rules?
13:38:52 <jpena> oh, true
13:38:55 <hberaud> yep
13:40:29 <sboyron> o/
13:40:34 <jpena> alright, so shall we branch this week, or early next week?
13:40:39 <jpena> #chair sboyron
13:40:39 <openstack> Current chairs: dirk hberaud jpena sboyron
13:41:00 <jpena> I'd propose to do it on Monday
13:41:13 <hberaud> +1 for the next week
13:41:21 <toabctl> hey
13:41:26 <jpena> #chair toabctl
13:41:27 <openstack> Current chairs: dirk hberaud jpena sboyron toabctl
13:43:31 <dirk> jpena: monday works for me
13:43:49 <dirk> we just need a review I think, any volunteers?
13:44:23 <jpena> we have a recent core, just saying :P
13:44:30 <hberaud> dirk: let's go
13:44:53 <dirk> this is a sample review: https://review.opendev.org/#/c/645896/
13:44:58 <dirk> ok, I'll do it then
13:44:59 <hberaud> ack
13:45:07 <dirk> sorry, hberaud will do it then
13:45:27 <hberaud> #action hberaud branching
13:45:27 <jpena> #action hberaud to send the review for stable/victoria branching on Monday
13:45:32 <dirk> one more question, do we have pending changes for renderspec and pymod2pkg that we'd like to release
13:46:00 <dirk> toabctl: can you help us with newer releases of those? I think with the switch to SIG the openstack release team will no longer do releases for us, so we need to recover access to pypi
13:46:17 <jpena> we have https://review.opendev.org/752272 for renderspec and recent Fedora versions
13:46:58 <toabctl> dirk, so we need to manually create the sdist tarball and push it to pypi?
13:48:01 <dirk> jpena: ah, the famous py 3.8 breakage. reviewed.
13:48:09 <dirk> I guess at some point we need to suck it up and switch to "distro"
13:48:15 <dirk> toabctl: yes, exactly.
13:48:30 <toabctl> urgs :(
13:48:52 <dirk> toabctl: the discussion was a few weeks ago. basically the "offical project status" requires PTL nomination, which we failed to comply to last time, so evrardjp suggested to become a SIG instead, where we don't have to follow that
13:49:00 <dirk> the downside is that the openstack release team no longer cares about us
13:50:25 <toabctl> and we are no longer listed as official project?
13:50:28 <dirk> ideally we'd build a release pipeline elsewhere (github?)
13:50:49 <toabctl> afk for 2 min...
13:51:08 <dirk> toabctl:  my  understanding is that SIGS sare still "official" part of openstack, just not a openstack project anymore
13:51:25 <dirk> as we never "released" with openstack, I think thats kind of fine
13:52:32 <toabctl> as long as we can stay inside the openstack/ namespace I guess it's fine
13:53:04 <toabctl> and yes, I can do the releases on pypi
13:53:16 <toabctl> but also please let me know your pypi user so I can add you to the project, too
13:53:39 <sboyron> what do we releases on pypi ? renderspec only ?
13:53:47 <toabctl> and pymod2pkg
13:53:51 <sboyron> ok thx
13:55:00 <hberaud> can't we host these projects under the independent release model?
13:55:29 <hberaud> I've no much experience with SIGs
13:56:27 <dirk> hberaud: what do you refer to with "independent release model"? I'm not familiar with that
13:56:47 <hberaud> dirk: https://releases.openstack.org/reference/release_models.html#independent
13:56:50 <toabctl> I think it's what we currently have/had
13:57:31 <toabctl> my understanding is, that we can't use *any* release model as a SIG. now we have to do it on our own. right?
13:57:45 <hberaud> toabctl: ack
13:58:05 <dirk> toabctl: yes, thats how I understood it
13:58:20 <hberaud> indeed renderspec is already an independent deliverable https://github.com/openstack/releases/blob/master/deliverables/_independent/renderspec.yaml
13:58:37 <sboyron> And this model imply to have a PTL ?
13:59:43 <evrardjp> it's still official, it's not _released_ with the deliverables
13:59:43 <hberaud> however, it's not a big deal to manage our own pypi releasing
14:00:03 <evrardjp> because most of the deliverables were independent it didn't matter much
14:00:16 <jpena> is there anything preventing us from reusing Zuul jobs for that?
14:00:17 <evrardjp> next to that toabctl already mentioned the willingness for more independence on how to tag
14:00:22 <evrardjp> no you can!
14:00:33 <evrardjp> the pipelines still exist
14:00:45 <toabctl> evrardjp, but I still like all the automation arround it. this now feels more like a step back imo
14:00:53 <evrardjp> (as the release pipeline is an openstack wide thing)
14:00:54 <evrardjp> you can implement your own jobs
14:01:18 <evrardjp> but you said you wanted to tag per commit at some point, right?
14:01:23 <jpena> instead of the release repo, I guess we could just do "git push gerrit tag ..." after tagging locally, and that should be it
14:01:25 <evrardjp> so that was highly inconvenient
14:01:25 <toabctl> yeah.
14:01:33 <evrardjp> now you can do that easier
14:01:34 <jpena> provided we have the right jobs
14:02:03 <evrardjp> jpena: correct you can ask to have the rights to push tags in gerrit. You can also do that immediately in gerrit interface
14:02:11 <dirk> I found the documentation somewhere a few weeks ago. basically we need to create a rpm-packaging-release-team gerrit group
14:02:15 <evrardjp> but I thought that you might want to have your own way, due to the previous requests
14:02:21 <dirk> which will get additional privileges (push branches, and tags iirc)
14:02:28 <evrardjp> correct
14:02:38 <jpena> ok, then I think it's not a big deal
14:03:01 <evrardjp> and yes, you are still in openstack/
14:03:05 <evrardjp> toabctl: ^
14:03:08 <dirk> anyone interested in figuring out how to reuse the release tooling?
14:03:15 <openstackgerrit> Merged openstack/renderspec master: Improve distro detection for recent Fedora releases  https://review.opendev.org/752272
14:03:27 <evrardjp> I remember that was one of things you were looking for, so I tried to find the best solution
14:03:35 <dirk> evrardjp: do you happen to know how to end up on openstack.org/sigs/ ? is that done automagically?
14:03:54 <evrardjp> isn't it already done?
14:04:06 <evrardjp> I think I have a patch for governance-sigs repo
14:04:11 <evrardjp> and one for governance
14:04:14 <dirk> sorry https://governance.openstack.org/sigs/
14:04:30 <dirk> evrardjp: ok, so the page is generated from that review?
14:04:41 <evrardjp> just a sec
14:04:44 <evrardjp> yes
14:05:25 <hberaud> dirk: I already have lot of topics to manage for the next weeks but I can help if needed
14:05:54 <evrardjp> https://review.opendev.org/#/c/752659/
14:05:58 <jpena> I can also give it a look. We have a similar setup to upload to pypi in some projects using gerrit+zuul
14:06:01 <hberaud> someone else is interested too?
14:06:08 <evrardjp> that should be good enough to have the page refreshed
14:07:22 <sboyron> I can have a look on it too
14:07:30 <dirk> thanks hberaud sboyron
14:07:45 <dirk> lets have a checkpoint on this then next week, we'll certainly have some news then one way or another :)
14:08:03 <dirk> I suggest to push a release for renderspec before wallaby though, so that we can figure out the release part without pressure
14:08:10 <sboyron> but I think I'll need some help about understanding the exact need, I'm not yet familiar with all these process here
14:08:11 <jpena> agreed
14:08:30 <toabctl> dirk, imo for a release, we need to be able to tag it in git
14:08:42 <toabctl> what I hear is that we can't do that currently, right?
14:09:07 <evrardjp> FYI I intended to make this merge _after_ the release, so that patch might have been merged too soon, sorry for that
14:09:30 <evrardjp> toabctl: that should be easily solvable
14:10:33 <dirk> toabctl: we're still in victoria cycle, for which we have release team support
14:10:47 <dirk> toabctl: my understanding is that the change to SIG hasn't happened, it will happen in the wallaby cycle
14:11:01 <toabctl> ah. ok
14:11:32 <dirk> of course its a kind of nice good by gift to push a few reviews, but I'd hope they're okay with it
14:11:43 <dirk> its not particularly difficult to review/handle
14:12:03 <evrardjp> but things have been merged, so let's see :p
14:12:48 <evrardjp> (sorry for the delay in answers too, triple booked)
14:13:00 <hberaud> https://review.opendev.org/755521
14:13:12 <hberaud> renderspec 2.1.0 ^^^
14:13:25 <dirk> evrardjp: ah, you're saying the review to remove us from "official" has been merged, but the "create sig" hasn't?
14:13:27 <dirk> nice
14:13:29 <dirk> :-/
14:14:10 <toabctl> https://review.opendev.org/#/c/755522/ for a new renderspec release
14:15:41 <evrardjp> it's not to remove you from "official" it's to move from project to sig
14:15:48 <evrardjp> both are official
14:15:55 <evrardjp> both are in governance
14:16:02 <toabctl> https://review.opendev.org/755524 for a new pymod2pkg release
14:16:02 <evrardjp> but yeah that is a mistake on the TC side
14:16:09 <toabctl> evrardjp, maybe you can review both!? :)
14:16:24 <evrardjp> I will when I am done with my meetings
14:16:34 <toabctl> thanks
14:16:50 <evrardjp> please note that I have abandonned my core duties in releases though ;)
14:17:34 * dirk unabandons evrardjp
14:17:49 * toabctl approves that
14:18:16 * evrardjp don't see why dirk and toabctl do that, at all.
14:19:20 <dirk> evrardjp: you're saying now that you have a goverment you don't obey our orders anymore? ;)
14:19:35 <dirk> anyway, away the joking, thanks for all the help evrardjp
14:19:54 <hberaud> dirk, sboyron: please prefer to use toabctl's renderspec patch
14:20:37 <hberaud> I missed the drop of py2.7
14:20:38 <evrardjp> dirk: hahaha
14:20:50 <evrardjp> dirk: trying my best!
14:23:10 <jpena> ok, I guess we already moved into open floor some time ago, but just in case
14:23:13 <jpena> #topic open floor
14:23:20 <hberaud> lol
14:23:22 <jpena> is there anything else you'd like to discuss?
14:23:37 <dirk> just a quick update on the suse ci instabilities
14:23:40 <hberaud> nothing on my end
14:23:57 <dirk> it turns out we have some weird network/dns lookup issue, it is being looked at atm
14:24:18 <dirk> so in case jobs fail with all builds as "excluded" that means you hit the problem, and a recheck hopefully fixes it
14:24:28 <sboyron> There is several old review still opent on rpm-packaging, shouldn't we abandon these ?
14:24:35 <dirk> there is a caching squid, and more often than not it stops to do dns resolutions :(
14:25:21 <sboyron> ack dirk, thx for these explanations
14:25:59 * hberaud eject (school run)
14:26:57 <dirk> sboyron: which one in particular?
14:27:09 <dirk> dragonflow we could abandon
14:27:36 <dirk> the singlespec one needs rebase, and the vmware-nsx* ones could theoretically be reviewed
14:28:04 <sboyron> openstack-macros: Drop singlespec file
14:28:15 <sboyron> Populate x/ subdir
14:28:25 <sboyron> Add the networking-l2gw-tempest-plugin package
14:28:26 <dirk> well, the populate x/ dir is still valid
14:29:09 <dirk> there were a few projects that we package moved around as part of the opendev project, so now rpm-packaging has stuff in openstack/ subdir that is not in openstack/ subdir on review.opendev.org
14:29:23 <dirk> so we do have to create the x/ subdir imho and run ci over it as well
14:29:33 <dirk> I just failed to fix the downstream ci for it
14:32:23 <sboyron> ok thx for these status I'll try to find some time to review/patch them.
14:33:35 <jpena> hey, we're running out of time. Let's close and continue discussion if needed
14:33:38 <jpena> #endmeeting