13:38:29 <jpena> #startmeeting rpm_packaging
13:38:30 <jpena> ping toabctl, dirk, apevec, jpena, number80, kaslcrof,  rha, hberaud, sboyron
13:38:31 <openstack> Meeting started Thu Dec  3 13:38:29 2020 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:38:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:38:34 <openstack> The meeting name has been set to 'rpm_packaging'
13:38:38 <jpena> #topic roll call
13:38:50 <jpena> If there's any topic, please add it to the agenda at https://etherpad.opendev.org/p/openstack-rpm-packaging
13:51:09 <dirk> o/
13:51:12 <dirk> sorry I was afk
13:52:34 <jpena> #chair dirk
13:52:35 <openstack> Current chairs: dirk jpena
13:52:42 <jpena> #topic open floor
13:52:46 <jpena> so anything to discuss?
13:53:33 <dirk> the only topic I haven't already shared here is that I plan to move away from 3rd party suse ci
13:53:41 <dirk> the setup is too fragile and breaks too often
13:53:59 <jpena> dirk: so what would be the plan?
13:54:04 <dirk> so eventually I'll replace it with a job on the zuul.o.org instance
13:54:21 <dirk> given that it "just" drives build.opensuse.org, it can really be done from anywhere
13:54:40 <jpena> aha, makes sense
13:54:47 <dirk> and 99% of the issues are in the complex zuul->external zuul setup (ssh, network issues, jenkins issues etc)
13:55:16 <dirk> so we can then decomission the setup (its still a zuulv2 which requires continuous patching to keep up with the changes on zuul.o.org)
13:55:36 <jpena> #info SUSE CI will be migrated away from current setup
13:56:59 <dirk> if we keep it the way it is I would add it as non-voting then
13:57:17 <dirk> which means it would run, but no longer turn the verified to -1 (and also not run during gate run)
13:57:36 <dirk> the alternative is to deviate from the openstack policy of running it voting in check pipeline but leave it out of of gate pipeline
13:57:40 <dirk> any opinion on that?
14:00:18 <jpena> the RDO CI is not running on the gate pipeline, I never knew that was against policy
14:03:40 <dirk> well, its 3rd party
14:03:48 <dirk> so it is aligned iwth policy
14:04:07 <dirk> policy simply says voting jobs have to run on the main zuul and be in the gate pipeline
14:04:16 <jpena> ah ok, now I understand. You mean if you use zuul.o.o to drive the job
14:04:28 <dirk> yes
14:04:39 <dirk> when run on main, the typical thing would be to set it to nonvoting
14:04:43 <openstackgerrit> Merged openstack/rpm-packaging master: update python-tackerclient to 1.4.0  https://review.opendev.org/c/openstack/rpm-packaging/+/764923
14:04:59 <jpena> we can make it non-voting but keep it into account anyway, we're a small enough team to let everyone know
14:05:00 <dirk> which means contrary to now patches would no longer get a "-1" on the verified label when suse ci fails
14:05:30 <dirk> yep, that works for me. I'm anyway always checking the rdo fails as well
14:07:08 <dirk> #action dirk create nonvoting job to eventually replace suse 3rd party ci with a suse test
14:07:14 <dirk> tahts it from my side
14:07:20 <jpena> nice
14:07:31 <jpena> I don't have anything else for today, so let's close the meeting
14:07:36 <dirk> next week(s) will likely be more quiet as holidays are upcoming and there is a lot of covid vacation to take
14:08:02 <jpena> ok, understood. I'll take holidays starting Dec 23
14:09:57 <jpena> #endmeeting