18:00:47 <SergeyLukjanov> #startmeeting sahara
18:00:48 <openstack> Meeting started Thu Apr 30 18:00:47 2015 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:52 <openstack> The meeting name has been set to 'sahara'
18:00:58 <SergeyLukjanov> folks, I need to go a bit earlier today
18:01:10 <SergeyLukjanov> #chair tmckay
18:01:12 <openstack> Current chairs: SergeyLukjanov tmckay
18:01:28 <SergeyLukjanov> tmckay, could you please end the meeting if I'll need to go before it?
18:01:33 <tmckay> sure
18:01:41 <SergeyLukjanov> tmckay, thx!
18:01:44 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Meetings/SaharaAgenda
18:01:56 <SergeyLukjanov> #topic Design summit sessions
18:02:11 <SergeyLukjanov> folks, it's the main topic for today in addition to the common news/update
18:02:29 <SergeyLukjanov> #link https://etherpad.openstack.org/p/sahara-liberty-proposed-sessions
18:02:42 <SergeyLukjanov> I've added summit layout proposal to the top of the doc
18:03:00 <SergeyLukjanov> >> Fish bowl sessions
18:03:00 <SergeyLukjanov> The obligatory Sahara UI improvement session (crobertsrh)
18:03:00 <SergeyLukjanov> Secure Sahara, where we have been, where we are, where we are going (elmiko)
18:03:00 <SergeyLukjanov> >> Working sessions
18:03:00 <SergeyLukjanov> The great API v2 debate (elmiko, SergeyLukjanov?)
18:03:02 <SergeyLukjanov> Sahara HA (alazarev)
18:03:04 <SergeyLukjanov> EDP future improvements - scheduling, extended Oozie support (tmckay, weiting)
18:03:04 <SergeyLukjanov> Sahara resources editability, dependencies, visibility, versioning? (SergeyLukjanov, ?)
18:03:05 <SergeyLukjanov> Future of plugin mechanism (SergeyLukjanov)
18:03:41 <SergeyLukjanov> please, take a look and comment
18:04:01 <elmiko> the proposed layout looks pretty good to me
18:04:04 <SergeyLukjanov> I'd like to push the schedule to https://libertydesignsummit.sched.org/?s=sahara this week
18:04:26 <SergeyLukjanov> so, IMO it covers all proposed stuff + traditionally important stuff for sahara
18:04:41 <SergeyLukjanov> except versioned objects and bring your big data framework
18:04:44 <tmckay> lgtm there is more than can possibly be discussed in any one summit, sane choices
18:05:09 <SergeyLukjanov> first one if good for friday and second one is hopefully will be covered during summit
18:05:10 <elmiko> would be nice to talk about those as well SergeyLukjanov
18:05:34 <SergeyLukjanov> we have the full day at Friday
18:05:41 <elmiko> cool
18:05:50 <SergeyLukjanov> so, I presume there will be enough time to chat about everything :)
18:06:06 <elmiko> probably not, but we'll give it our best ;)
18:06:17 <tmckay> especially interested in weiting's customer use case
18:06:21 <elmiko> +1
18:06:30 <SergeyLukjanov> we probably will need to skip Canadian beer discussion
18:06:36 <SergeyLukjanov> tmckay, +1
18:06:36 <elmiko> what!?!
18:06:48 <Nikolay_St> :D
18:06:51 <elmiko> SergeyLukjanov: -1 to that... ;)
18:06:53 <tmckay> SergeyLukjanov, plenty of parties for that
18:06:57 <SergeyLukjanov> folks, what do you think - should we vote for this layout or just let's name it approved?
18:07:06 <tmckay> approved
18:07:09 <huichun> tmckay: Trevor hi I have reply your email about edp just now
18:07:10 <SergeyLukjanov> tmckay, elmiko yeah, parties will help to discuss it earlier :)
18:07:23 <elmiko> maybe send it to ML to make sure folks who aren't here see it, then approve tomorrow?
18:07:24 <huichun> and will update the spec later
18:07:46 <SergeyLukjanov> elmiko, it could be changed anytime
18:07:53 <tmckay> huichun, oh, I saw it.
18:08:03 <SergeyLukjanov> we're not freezing it till the summit itself
18:08:06 <mattf> SergeyLukjanov, when is the design summit schedule posted?
18:08:15 <elmiko> ok, cool. then i'm fine the way it is. i just want to make sure all the intel folks get a chance to comment.
18:08:15 <SergeyLukjanov> we just need to name slots on summit
18:08:27 <SergeyLukjanov> mattf, https://libertydesignsummit.sched.org/?s=sahara
18:08:40 <tmckay> huichun, I think I follow.  We already have an abstract interface for run, cancel, status.  I am wondering if we can extend that interface to include scheduling and dependencies.  Is that your understanding?
18:08:49 <SergeyLukjanov> elmiko, I'll fill the sched.org this week and send an email to ML
18:08:56 <elmiko> SergeyLukjanov: awesome, +1
18:08:57 <tmckay> so, each EDP engine implements (or not.  Could be optional)
18:09:00 <SergeyLukjanov> elmiko, to make them able to review and mark as well
18:09:07 <mattf> heh, url format changed - http://kilodesignsummit.sched.org/overview/type/sahara s/kilo/liberty/ -> #fail
18:09:18 <SergeyLukjanov> mattf, :)
18:09:19 <SergeyLukjanov> #link https://libertydesignsummit.sched.org/?s=sahara
18:09:27 <huichun> yes I mean add abstract function like scheduler running jobs
18:09:49 <tmckay> huichun, +1.  Will you be at Summit? I forget
18:10:17 <SergeyLukjanov> any more comments / questions re design summit?
18:10:34 <elmiko> looking forward to it =)
18:10:44 <SergeyLukjanov> elmiko, yup :)
18:10:45 <huichun> i will not,weiting will say hello to you for me ^_^
18:10:47 <mattf> looking forward to it, until fri morning!
18:10:53 <tmckay> huichun, okay :)
18:10:58 <elmiko> mattf: lol!
18:11:16 <mattf> elmiko, i necessarily have to fly back fri am
18:11:18 <SergeyLukjanov> #agreed on the proposed design summit layout
18:11:31 <SergeyLukjanov> #agree on the proposed design summit layout
18:11:39 <SergeyLukjanov> #topic sahara@horizon status (crobertsrh, NikitaKonovalov)
18:11:48 <SergeyLukjanov> #link https://etherpad.openstack.org/p/sahara-reviews-in-horizon
18:12:04 <NikitaKonovalov> not much updates on that from me
18:12:24 <NikitaKonovalov> some changes got merged so I moved them to the merged section
18:12:53 <tmckay> crobertsrh is coming ...
18:12:56 <tmckay> there he is
18:13:14 <tmckay> crobertsrh, horizon review status
18:13:20 <huichun_> https://review.openstack.org/#/c/162273/
18:13:29 <huichun> merged
18:13:41 <crobertsrh> Not much in for reviews there lately.  I had a change to use the job types endpoint get merged.
18:14:06 <tmckay> awesome.  I hope it works :)
18:14:21 <huichun> SergeyLukjanov:  so I should add merged in that ether pad?
18:14:50 <NikitaKonovalov> huichun: I'll update that as well
18:14:51 <SergeyLukjanov> huichun, it'll be helpful
18:15:13 <SergeyLukjanov> we're trying to monitor the horizon changes to keep understanding of progress
18:15:15 <huichun> ok thanks NikitaKonovalov
18:15:20 <SergeyLukjanov> anything else re horizon stuff?
18:15:34 <crobertsrh> I'm working on a bug fix that might be backport worthy (to kilo)
18:15:44 <crobertsrh> https://bugs.launchpad.net/horizon/+bug/1450535
18:15:44 <openstack> Launchpad bug 1450535 in OpenStack Dashboard (Horizon) "[data processing] Create node group and cluster templates can fail" [Undecided,In progress] - Assigned to Chad Roberts (croberts)
18:16:02 <crobertsrh> Discovered today for hosts that are not using / as root
18:16:16 <crobertsrh> my first attempt at fixing it ran into django 1.4 compat issues
18:16:27 <SergeyLukjanov> crobertsrh, oh
18:16:33 <crobertsrh> I am about to submit another fix for it that should be django 1.4 compat
18:16:38 <NikitaKonovalov> crobertsrh: I dont thing anyone is using 1.4 now
18:16:46 <SergeyLukjanov> crobertsrh, it sounds like an important issues
18:16:49 <crobertsrh> The gate uses it :)
18:16:56 <NikitaKonovalov> oh
18:17:03 <SergeyLukjanov> :)
18:17:12 <tmckay> crobertsrh, if it's true for ng and cl templates, is it true for other objects too?
18:17:14 <crobertsrh> So, I have a [much worse] fix coming in soon
18:17:20 <crobertsrh> ng, cl and jobs
18:18:35 <SergeyLukjanov> #topic News / updates
18:18:46 <SergeyLukjanov> #info Kilo release!
18:19:01 <SergeyLukjanov> so, we have a Kilo release for Sahara, yay!
18:19:09 <elmiko> \o/
18:19:22 <SergeyLukjanov> btw, Liberty release schedule
18:19:25 <SergeyLukjanov> #link News / updates
18:19:28 <SergeyLukjanov> shit
18:19:33 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
18:19:41 <tmckay> SergeyLukjanov, we added high-level RH stuff to https://etherpad.openstack.org/p/sahara-teams-plans
18:19:51 <SergeyLukjanov> tmckay, great, thx!
18:20:04 <SergeyLukjanov> tmckay, no collisions? :)
18:20:15 <tmckay> SergeyLukjanov, not so far!
18:20:22 <elmiko> no collisions, only collaborations!
18:20:28 <crobertsrh> Not until we try to rebuild the direct engine :)
18:20:35 <elmiko> haha!
18:20:38 <SergeyLukjanov> :)
18:20:51 <tmckay> I should clear purple, it's hard to read
18:21:04 <SergeyLukjanov> re Ironic integration - we could chat a lot about it on summit - we already have this integration working
18:21:05 <Nikolay_St> https://review.openstack.org/#/c/175363/ healthchecks spec is ready, but we have some stuff to discuss
18:21:06 <SergeyLukjanov> as PoC
18:21:17 <huichun_> can we add intel plan on that pad?
18:21:39 <tmckay> huichun_, yes!
18:21:40 <tmckay> please do
18:21:54 <huichun> ok
18:22:04 <tmckay> SergeyLukjanov, okay on Ironic
18:22:08 <tmckay> sounds good
18:22:26 <SergeyLukjanov> huichun, that's for what this etherpad was created, it'll be awesome to see highlights from your plan for liberty
18:22:51 <SergeyLukjanov> #topic Open discussion
18:23:07 <huichun> SergeyLukjanov: thanks Sergey
18:23:11 <SergeyLukjanov> Nikolay_St, what stuff you'd like to discuss?
18:23:50 <Nikolay_St> SergeyLukjanov: JSON format that you mention in comment
18:24:32 <SergeyLukjanov> do you have a new proposal?
18:26:17 <elmiko> #link https://review.openstack.org/#/c/177855/
18:26:23 <elmiko> SergeyLukjanov: i'd love to get more feedback on that
18:26:26 <Nikolay_St> SergeyLukjanov: nope. just want to see what'd you want from it. may be we can storage inside JSON some error codes for each component if any
18:27:07 <SergeyLukjanov> Nikolay_St, I'm looking on it from the other point of view - what should user see in horizon?
18:27:07 <huichun__> so these days we are talking about that could we add thirdparty libs management in sahara ?  most use case is that, if we want run a edp job, this job depends on one thirdparty lib and maybe other jobs depend on it too, so can we add a horizon page like lib management? just original thoughts in our team
18:27:12 <elmiko> sorry to interrupt Nikolay_St
18:27:51 <SergeyLukjanov> IMO the best case is to be able to show overall ternary status + description message
18:28:06 <elmiko> huichun__: nice idea
18:28:25 <SergeyLukjanov> like status health is Yellow because you're HDFS is drunk but still functional (some of data nodes are dead, but still < replication factor)
18:28:35 <huichun> elmiko: so we can call it share lib management or something else
18:28:49 <SergeyLukjanov> huichun, a very good topic for summit discussions
18:28:57 <elmiko> huichun: and these are shared libs for use in the cluster right?
18:29:10 <huichun> elmiko: yes
18:29:16 <SergeyLukjanov> huichun, in fact job binaries could be used for it
18:29:24 <elmiko> huichun: then yes, shared lib management makes sense to me
18:29:44 <huichun> SergeyLukjanov: so I will tell weiting to talk it with you on summit
18:29:49 <crobertsrh> huichun:  Maybe a way to upload a lib and just mark it shared rather than have a separate page?
18:29:55 <tmckay> huichun, we've had some bps out for a long time I think about supporing files and archives tags in Oozie.  That would relate
18:30:05 <crobertsrh> In general, we have too many pages already
18:30:06 <tmckay> huichun, a way to push up common libs to the cluster
18:30:53 <huichun> tmckay: yes actually original idea comes from Ozzie share lib with you
18:30:54 <tmckay> course, should not be Oozie-specific
18:31:18 <Nikolay_St> SergeyLukjanov: ok, get it. will thin about it.
18:31:56 <huichun> tmckay: but the user can hardly find the Ozzie.sharelib and use it successfully
18:32:14 <tmckay> huichun, agreed.  We should make it easy
18:32:28 <tmckay> huichun, my feeling on EDP stuff for liberty -- make it all easier
18:32:49 <tmckay> imho, "easier" is better than "new features" at this point
18:33:05 <huichun> tmckay: ok
18:33:25 <tmckay> huichun, but some new features are good :) like scheduler and coordinated jobs
18:33:31 <tmckay> I think that falls into "easier"
18:33:44 <SergeyLukjanov> tmckay, ++ :)
18:33:55 <huichun> tmckay: ^_^
18:34:35 <tmckay> what I'm talking about is finding rough edges in the workflow and removing them
18:35:07 <tmckay> lowering the bar to adoption, that kind of thing.  Some of the UI wizard stuff crobertsrh did is part of this
18:35:19 <elmiko> +1
18:35:56 <huichun> tmckay: so you mean that we should make the sharelib more common sense not oozie specific, right?
18:36:23 <tmckay> huichun, yes, if we can figure out a way to do sharelib for Spark, great
18:36:50 <tmckay> then we have a general feature
18:36:59 <elmiko> that would have nice implications for the wrapper lib ideas too
18:37:07 <SergeyLukjanov> yup
18:37:20 <tmckay> huichun, same thing for Telles Storm stuff
18:37:28 <huichun> tmckay: ok, I will take a research on that , details will offline by email with you
18:37:37 <tmckay> huichun, thank you
18:37:51 <SergeyLukjanov> yeah, Storm stuff is a super cool example to test our internal and external APIs
18:38:35 <SergeyLukjanov> sorry folks, I need to go
18:38:44 <SergeyLukjanov> thanks!
18:38:50 <elmiko> SergeyLukjanov: later
18:38:56 <tmckay> okay.  Do we have other stuff?  If not we can all leave with Sergey :)
18:39:10 <elmiko> nothing from me
18:39:33 <huichun__> nothing from me too
18:40:17 <tmckay> okay, I'll wait 5 minutes and end if nobody brings up anything
18:40:32 <crobertsrh> nothing here
18:41:31 <tmckay> huichun__, so, just to clarify, above I meant my personal focus ("easy" versus "new feature"), I do not want to discourage new ideas.  Please pursue your ideas!
18:41:56 <tmckay> huichun__, but there are things I would like to fix that bother me, which I think will make a better user experience.  That's all.
18:42:07 <huichun> tmckay:  got it ^_^
18:44:58 <huichun> tmckay: so which nickname is SergeyReshetnyak?
18:45:09 <tmckay> sreshetnyak I think
18:46:01 <tmckay> okay, folks, last call ...
18:46:59 <huichun> sreshetnyak:  hi Sergey I have replied you the HA on CDH, so if you have any ideas, we can talk with email ^_^
18:50:15 <tmckay> #endmeeting