18:01:24 <SergeyLukjanov> #startmeeting sahara
18:01:24 <openstack> Meeting started Thu May 14 18:01:24 2015 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:28 <openstack> The meeting name has been set to 'sahara'
18:01:33 <Nikolay_St> o/
18:01:36 <tosky> hi
18:01:39 <SergeyLukjanov> #link http://wiki.openstack.org/wiki/Meetings/SaharaAgenda
18:01:50 <SergeyLukjanov> #topic sahara@horizon status (crobertsrh, NikitaKonovalov)
18:01:52 <elmiko> heyo/
18:01:56 <SergeyLukjanov> #link https://etherpad.openstack.org/p/sahara-reviews-in-horizon
18:02:24 <alazarev> o/
18:02:28 <crobertsrh> hello/
18:02:42 <NikitaKonovalov> I've added a change for volume types to that etherpad recently
18:03:13 <crobertsrh> Not much new UI-wise for me at the moment.  Was working on a few other bits.
18:03:14 <NikitaKonovalov> despite asking in horizon channel there are not much reviews appearing
18:04:26 <NikitaKonovalov> there may one reason for that, if you are implementing a blueprint in horizon please make sure it is targete for a milestone
18:04:38 <NikitaKonovalov> those changes are getting attention usuallyt
18:04:38 <crobertsrh> Good point
18:05:17 <SergeyLukjanov> NikitaKonovalov, add this note to the etherpad to remind :)
18:05:25 <NikitaKonovalov> that's all the news I have
18:05:37 <NikitaKonovalov> SergeyLukjanov: ok, I'll add a note
18:07:19 <SergeyLukjanov> #topic News / updates
18:07:23 <SergeyLukjanov> folks, please
18:07:40 <sreshetn1ak> no updates from me
18:08:16 <Nikolay_St> working on health checks for cdh. plan to put it on review tomorrow|on Monday
18:08:41 <elmiko> i've been working on a castellan prototype for sahara and working with the upstream team to improve the interaction with castellan. also i'm creating some architectural descriptions of how we might leverage hadoop secure mode and the apache knox project. finally, i'm doing some exploration of the sahara code in preparation for the keystone session object blueprint.
18:10:08 <huichun_> working on scheduled edp jobs,  updated spec https://review.openstack.org/#/c/175719/
18:11:11 <huichun> SergeyLukjanov: hi Sergey, thanks for your comment, I have updated my spec, you can have a check~
18:11:28 <SergeyLukjanov> huichun, I'll take a look on it today
18:11:28 <tmckay> submitted a few bug fixes -- JSON nulls, and cluster template update.
18:11:29 <tmckay> https://review.openstack.org/#/c/181477/
18:11:29 <tmckay> https://review.openstack.org/#/c/182783/
18:11:58 <tmckay> huichun, I see that you assigned the JSON null bug to yourself, sorry, I didn't see that earlier :)
18:12:21 <tmckay> also not sure why my CR is not listed under the bug --- I cited the number
18:12:30 <huichun> tmckay: ^_^
18:12:54 <tmckay> SergeyLukjanov, question as to whether or not the cluster template update bug after it's approved should be backported to Kilo
18:13:15 <huichun> tmckay: I have update the scheduled Eco jobs spec, you can have a check~
18:13:24 <tmckay> basically, update of a cluster template will wipe out the node groups even when node group info is not supplied in the update
18:13:36 <elmiko> oh yea, i should mention i'm chasing several security related bugs that i would like enter about our usage of hard coded passwords.
18:13:56 <tmckay> huichun, yes, I wanted to go through all of the EDP proposals before summit (today and tomorrow).  Thank you.
18:13:58 <SergeyLukjanov> tmckay, I think it could be backported
18:15:20 <tmckay> SergeyLukjanov, so, logistical question on that.  I changed an exception message in the process.  But maybe I should break the commit apart, so that it can be cherrypicked without the message change.  Because that would mean someone would have to retranslate for Kilo, right?  Do we want to avoid that? I assume so.
18:15:50 <SergeyLukjanov> tmckay, yup, we should avoid changing translated strings
18:16:16 <tmckay> ok, I'll redo the CR
18:17:54 <SergeyLukjanov> #topic Open discussion
18:18:16 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Design_Summit/Liberty/Etherpads
18:18:17 <elmiko> i'd like to thank alazarev for adding some nice questions to the security session pad. thanks alazarev!
18:18:40 <alazarev> elmiko, np :)
18:19:41 <crobertsrh> Please take some time to add your suggestions to the UI etherpad.  Even if it's messy.  I'll do what I can to organize things nicely.
18:21:43 <alazarev> crobertsrh, I would say "to all etherpads" :)
18:21:56 <crobertsrh> yes, I suppose I was being a bit selfish :)
18:22:56 <elmiko> <shameless plug> i'd love more opinions on #link https://review.openstack.org/#/c/179393/ </shameless plug>
18:22:57 <tmckay> yes, I need to get my Summit game on and review all the pads
18:23:20 <tmckay> start thinking in Canadian
18:29:46 <SergeyLukjanov> folks, I'd like to propose to cancel next two irc meetings
18:29:50 <SergeyLukjanov> on a summit week and week after
18:30:09 <elmiko> fine by me
18:30:12 <crobertsrh> +1
18:30:40 <huichun_> +1
18:30:53 <alazarev> +1
18:31:50 <tmckay> +1
18:31:52 <crobertsrh> More importantly, what color are the t-shirts this time around?
18:32:05 <elmiko> lol
18:32:48 * crobertsrh is hoping to get to the point where he only wears Sahara t-shirts.
18:33:02 <crobertsrh> well, pants too
18:33:08 <mattf> thank goodness
18:33:12 <tmckay> I hope the sweatshirts are larger this time.  I had to give mine to my daughter
18:33:54 <SergeyLukjanov> :)
18:34:02 <SergeyLukjanov> I've not ordered sahara t-shirts this time
18:34:35 <elmiko> tmckay: mine got snatched by the wife ;)
18:34:36 <SergeyLukjanov> #agreed to cancel next two irc meetings - summit week and week after
18:37:08 <crobertsrh> Oh...
18:37:16 <crobertsrh> Has anyone else run into:  https://bugs.launchpad.net/horizon/+bug/1453953
18:37:16 <openstack> Launchpad bug 1453953 in OpenStack Dashboard (Horizon) "[data processing] Unable to upload job binaries" [Undecided,New]
18:37:31 <SergeyLukjanov> crobertsrh, probably NikitaKonovalov
18:37:58 * NikitaKonovalov looking at the bug
18:38:04 <crobertsrh> Someone mentioned it last week (or maybe 2 weeks ago).  It was written against Sahara, but I moved it over to Horizon.
18:38:30 <crobertsrh> I seem to be able to reproduce it, but I have no idea why it suddenly appeared.  I don't think we've touched that part for awhile.
18:39:08 <elmiko> is it possibly something with string types and the six package?
18:39:19 <NikitaKonovalov> something bad happens in the kesytone session inside saharaclient
18:39:20 <elmiko> it smells like a py2/3 thing
18:39:27 <elmiko> ahh
18:39:57 <NikitaKonovalov> looks like it is trying to log the contents, and fails to parse json
18:40:09 <SergeyLukjanov> oh...
18:40:38 <NikitaKonovalov> and will happen on all binaries, which are actually "binary" files, not text
18:40:52 <crobertsrh> yep, that is all accurate
18:41:17 <NikitaKonovalov> I guess it should be moved to saharaclient then :)
18:41:47 <SergeyLukjanov> we need a volunteer to ensure it fixed ;)
18:42:05 <NikitaKonovalov> I can take that
18:42:10 <crobertsrh> many thanks
18:43:49 <SergeyLukjanov> anything else to chat?
18:44:01 <SergeyLukjanov> if not I'm going to close the meeting and grab coffee
18:44:21 <crobertsrh> Nothing here.  Who is going to be at summit this time?
18:44:39 <elmiko> coffee sounds good
18:44:44 <SergeyLukjanov> from mirantis - me, alazarev and aignatov (for sahara stuff)
18:45:25 <elmiko> from red hat we have, me, mattf, crobertsrh, and tmckay (for sahara)
18:45:38 <crobertsrh> Anyone else?
18:45:48 <crobertsrh> See you all there!
18:46:01 <SergeyLukjanov> thanks folks!
18:46:03 <SergeyLukjanov> #endmeeting