18:00:21 <SergeyLukjanov> #startmeeting sahara
18:00:22 <openstack> Meeting started Thu Oct 15 18:00:21 2015 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:25 <openstack> The meeting name has been set to 'sahara'
18:00:27 <crobertsrh> hel\o/
18:00:29 <SergeyLukjanov> huichun, how was you holidays?
18:00:35 <elmiko> o/
18:00:37 <huichun> nice thx guys
18:00:47 <SergeyLukjanov> #link http://wiki.openstack.org/wiki/Meetings/SaharaAgenda
18:00:48 <vgridnev> hey!
18:01:07 <SergeyLukjanov> actually I wan't to start today with cleaning up the design summit schedule
18:01:30 <SergeyLukjanov> #topic Mitaka / Tokyo design summit
18:01:39 <SergeyLukjanov> #link https://etherpad.openstack.org/p/mitaka-sahara-session-plans
18:01:55 <SergeyLukjanov> I've put a few more items there
18:02:04 <SergeyLukjanov> let's discuss the items one by one
18:02:25 <elmiko> i have 1 conflict on thursday at 11:50
18:02:26 <SergeyLukjanov> if you'll scroll the ideas, I've added the "Sessions schedule proposal for summit" section
18:02:55 <SergeyLukjanov> it's a 2nd working session
18:03:21 <elmiko> yea, just wanted to give a heads up. i'm gonna be doing one of the fishbowls for security project as well
18:03:26 <SergeyLukjanov> I've agreed with heat guys to move there session to avoid conflict and that's great
18:03:49 <SergeyLukjanov> elmiko, ack, so let's put some stssion in sahara summit that you could skip
18:04:05 <elmiko> SergeyLukjanov: thanks, i appreciate it =)
18:04:05 <SergeyLukjanov> we have 2 fish bowls from 9am, than 5 working sessions
18:04:25 <SergeyLukjanov> so, let's start with topics for fishbowls
18:04:40 <SergeyLukjanov> initial proposal is UX and Sahara state
18:04:54 <elmiko> sounds good to me
18:05:03 <SergeyLukjanov> IMO Sahara state should be the last session (if it even should be)
18:05:21 <elmiko> you want something more design oriented instead of state?
18:05:48 <SergeyLukjanov> yeah, because state is the two parts - what's done in Liberty (retrospective)
18:05:55 <SergeyLukjanov> and what will be doing in Mitaka
18:06:02 <elmiko> good point
18:06:11 <SergeyLukjanov> *but* if it'll be 1st or 2nd session - it'll be before actual discussion:)
18:06:44 <SergeyLukjanov> I think the good place for the retro is the beginning of meetup and plans overview - end of meetup
18:06:48 <crobertsrh> For UX, I assume we're not just talking about the UI, right?
18:06:51 <SergeyLukjanov> what do you think about it guys?
18:07:09 <elmiko> SergeyLukjanov: i think that makes sense
18:07:34 <crobertsrh> Yeah, +1
18:07:37 <SergeyLukjanov> crobertsrh, I think so, we definitely need to discuss the overall UX for the operations
18:07:49 <elmiko> +1
18:08:00 <elmiko> especially the plans for our own repo (again...)
18:08:06 <SergeyLukjanov> ++
18:08:36 <SergeyLukjanov> if no objections for the "sahara state" I'll put an #agreed note
18:09:18 <SergeyLukjanov> #agreed to start meetup with "what's done in Liberty" and end it with "Plans overview for Mitaka"
18:09:47 <SergeyLukjanov> so, I think we agreed to keep UX as fishbowl
18:10:16 <SergeyLukjanov> from my point of view it should be dedicated to the UX issues and improvements
18:10:27 <SergeyLukjanov> and to have separated UI session to discuss tech debt
18:10:41 <SergeyLukjanov> like moving back to own repo, integration tests for the UI and etc.
18:10:48 <crobertsrh> +1...they are different things for sure
18:10:54 <elmiko> should we do the other fishbowl about the possibility of ssh vs. guest agent?
18:11:11 <elmiko> or are you saying 2 fishbowls on ux?
18:11:59 <crobertsrh> I don't think so...I think he's saying that the UI session is a working session
18:12:13 <crobertsrh> ...where we talk about lots of largely known UI things.
18:12:37 <SergeyLukjanov> UX as fishbowl and UI as working session
18:12:45 <crobertsrh> UX is a fishbowl where we hope to gather issues and ideas for improvement from "the community"
18:12:55 <SergeyLukjanov> yup
18:13:01 <SergeyLukjanov> and propose some improvements for UX
18:13:19 <SergeyLukjanov> (i have idea that we should teach sahara to auto-download images)
18:13:37 * SergeyLukjanov becoming to old for doing it each time
18:13:41 <SergeyLukjanov> too old*
18:13:46 <SergeyLukjanov> :)
18:13:46 <crobertsrh> Ha
18:14:09 <crobertsrh> Maybe even boot a "plain" image and then install the plugin's bits from there??
18:14:20 <SergeyLukjanov> any objections for fishbowl UX and working session for UI tech things?
18:14:25 <crobertsrh> No objection from me
18:14:26 <SergeyLukjanov> crobertsrh probably
18:14:29 <elmiko> none from me
18:15:01 <SergeyLukjanov> #agreed to have fishbowl UX and working session for UI tech things
18:15:18 <SergeyLukjanov> so, we have 1 mire fishbowl and 4 working sessions :)
18:15:40 <elmiko> maybe plugins for the second fishbowl?
18:16:05 <crobertsrh> Seems like it could have a wider audience
18:16:09 <SergeyLukjanov> I'm afraid it's too technical
18:16:29 <SergeyLukjanov> oh, we have two proposas for plugins
18:16:35 <crobertsrh> Or possibly EDP as fishbowl?
18:16:50 <SergeyLukjanov> in fact we have "new plugins" and "decouple plugins"
18:16:56 <SergeyLukjanov> crobertsrh, I like this idea
18:17:17 <SergeyLukjanov> the future of EDP - which new jobs should be supported and etc
18:17:23 <SergeyLukjanov> collect feedback from users
18:17:35 <crobertsrh> Yes
18:17:36 <elmiko> fair
18:17:38 <SergeyLukjanov> propose some new job types and capabilities
18:18:09 <elmiko> seems like we could put plugins future in with edp as well. at least in terms of getting ideas for new plugins from users.
18:18:13 <SergeyLukjanov> it could be something missed - like what are the new plugins and edp job types we should support in mitaka
18:18:19 <SergeyLukjanov> :)
18:18:20 <elmiko> lol
18:18:27 <SergeyLukjanov> sounds like agreed :)
18:18:28 <huichun> will better edp job log included?
18:18:30 <crobertsrh> +1
18:18:36 <huichun> SergeyLukjanov:
18:18:40 <crobertsrh> huichun:  That could fall under UX or EDP, I guess
18:18:46 <SergeyLukjanov> huichun I would say it's technical or UX part
18:19:08 <crobertsrh> I don't think anyone would say we don't need better edp logging though :)
18:19:19 <SergeyLukjanov> #agreed fishbowl session for "new plugins and edp jobs"
18:19:27 <SergeyLukjanov> crobertsrh, yeah :)
18:20:12 <SergeyLukjanov> okay, 2 fishbowls and 1 working session agreed
18:20:43 <SergeyLukjanov> I think we definitely need a Security working session
18:21:01 <crobertsrh> +1
18:21:21 <elmiko> yea, i think we have more than enough to plan for mitaka
18:21:27 <SergeyLukjanov> agree
18:21:31 <tosky> egafford is not around, but I think we need the one for image generation
18:21:43 <SergeyLukjanov> we could review the design for new security approach elmiko working on
18:22:19 <elmiko> plus i have a bunch of other security work that we can talk about and hopefully get more folks interested in helping =)
18:22:21 <SergeyLukjanov> elmiko, are you prefer to skip the UI tech part vs something else?
18:22:39 <elmiko> hmm
18:22:53 <crobertsrh> tosky:  I really like image generation as a topic as well.
18:22:56 <elmiko> i do find the ui stuff interesting, but i'm gonna have to miss something.. :/
18:23:02 <elmiko> tosky: +1
18:23:18 * crobertsrh boos elmiko and his apathy toward the UI
18:23:37 <elmiko> what... i actually want to attend that one
18:23:55 <elmiko> i'm just acknowledging that i will have to miss *something*
18:24:15 * crobertsrh may retract his boo
18:24:21 <elmiko> haha
18:24:23 <elmiko> ;)
18:24:29 <SergeyLukjanov> I'm +1 for image generation improvements
18:25:28 <crobertsrh> #agreed?
18:25:28 <SergeyLukjanov> no objections for image gen working session?
18:25:44 <SergeyLukjanov> #agreed to have security working session
18:25:55 <SergeyLukjanov> #agreed to have image gen working session
18:26:20 <elmiko> +1
18:26:26 <SergeyLukjanov> okay, two more sessions
18:26:35 <huichun> +1 for image gen working
18:26:46 <tosky> so, who is going to propose api v2?
18:26:50 * tosky looks at elmiko
18:26:51 <crobertsrh> Do we dare go for api2?
18:26:52 <elmiko> <.<
18:26:54 <elmiko> >.>
18:26:59 <elmiko> i was just about to say something
18:27:15 <crobertsrh> It's the api v2 world tour....Atlanta, Paris, Vancouver, Tokyo
18:27:23 <elmiko> i think we have a solid plan for apiv2, if folks want to discuss the plan more i'm all game. otherwise, imo, it's just down to execution at this point.
18:27:52 <huichun> i heard about v2 since when I am in Sahara ^^
18:28:13 <SergeyLukjanov> elmiko, I think we should book an hour to go through the API changes and highlights during the meetup
18:28:19 <elmiko> i could do an exhaustive run-down of what i think we will need to do to release an experimental v2 by mitaka-rc
18:28:19 <crobertsrh> Sahara v2 was formerly Savanna v2 :)
18:28:31 <elmiko> SergeyLukjanov: cool, i'm good with that =)
18:28:46 <elmiko> crobertsrh: lol, so true... i had to finally close out the bp that matt put together
18:28:55 <SergeyLukjanov> :)
18:28:56 <crobertsrh> Yeah, might be good to get everyone on the same page and really fired-up for it.
18:29:02 <elmiko> awesome
18:29:03 <SergeyLukjanov> agree
18:29:26 <SergeyLukjanov> and got an agreement on the first steps and start reviewing design step by step and implementing this steps ;)
18:29:49 <crobertsrh> Yes
18:29:56 <elmiko> sounds good, i will work on the pad for that and put together something about how we can divide the task nicely
18:30:10 <SergeyLukjanov> what's about having a working session dedicated to the deprecation policies and plugins decoupling?
18:30:25 <elmiko> that's probably wise
18:30:25 <SergeyLukjanov> #agreed api v2 on meetup
18:31:22 <SergeyLukjanov> I think it's time to review the plugins deprecation policy and it's high coupled with how we'd like to develop plugins in 1 year
18:31:23 <tosky> what's left from the list?
18:31:40 <SergeyLukjanov> no objections for working session dedicated to the deprecation policies and plugins decoupling?
18:31:50 <crobertsrh> I do not object.
18:31:53 <tosky> so separate from the one from new plugins?
18:31:55 <elmiko> SergeyLukjanov: yea, it would be nice to have some sort of deprecation policy we could point users towards
18:32:15 <elmiko> tosky: new plugins and edp will share a fishbowl
18:32:20 <tosky> oh, right
18:32:33 <SergeyLukjanov> cool, we have one more slot
18:32:34 <tosky> it's an "f"
18:33:04 <SergeyLukjanov> f?
18:33:17 <tosky> the letter before fishbowl, I misread on the pad
18:33:55 <SergeyLukjanov> we have agents in a list
18:34:05 <tosky> the remaining items on the list are: Tests, EDP logs, Zaqar vs ssh (or is it this part of Security?)
18:34:35 <crobertsrh> Tests are important
18:34:40 <elmiko> i think we should really try to talk with the trove folks before we plan on a guest agent
18:34:58 <SergeyLukjanov> I'm now checking when the trove sessions will be
18:35:00 <elmiko> yea, i'd be more for a testing session that guest agent
18:36:55 <SergeyLukjanov> so, for the testing session - we could discuss future of scenario framework, think about how to improve unit test coverage, probably on some improved functional and upgrades testing
18:37:42 <huichun> so should we generate a test coverage report?
18:39:19 <elmiko> coverage appears to be broken currently
18:39:28 <elmiko> (at least, it is for me)
18:40:01 <SergeyLukjanov> I will check
18:40:09 <SergeyLukjanov> sounds like agreed on a testing session?
18:41:21 <elmiko> i opened this a week ago, https://bugs.launchpad.net/sahara/+bug/1503912
18:41:21 <openstack> Launchpad bug 1503912 in Sahara "Coverage tests have several errors" [Medium,Incomplete]
18:42:36 <SergeyLukjanov> elmiko, I'll take a look, have a few ideas
18:42:49 <SergeyLukjanov> #agreed to have a testing working session
18:42:51 <elmiko> cool, thanks =)
18:43:14 <elmiko> i think coverage is awesome, and working towards 100% should definitely be a goal
18:43:16 <SergeyLukjanov> okay, we're done with design summit schedule
18:43:24 <SergeyLukjanov> elmiko, agreed
18:43:55 <SergeyLukjanov> folks, I think we should discuss chairs for the sessions as well
18:44:09 <SergeyLukjanov> crobertsrh, would you like to take the UX and UI?
18:44:28 <SergeyLukjanov> elmiko - security
18:44:30 <crobertsrh> I'd rather just take the UI.  I wouldn't mind co-chairing UX though.
18:44:35 <elmiko> i can certainly take sec and api v2
18:44:46 <crobertsrh> I'm afraid that if I do the UX that I'll wind-up making it more about UI.
18:44:59 <SergeyLukjanov> I'll take deprecation and co-chair plugins related
18:44:59 <elmiko> maybe egafford would want to take UX?
18:45:07 <crobertsrh> I bet he would.
18:45:11 <SergeyLukjanov> elmiko, yup, I think so
18:45:19 <elmiko> (he's already on the way to japan)
18:45:29 <SergeyLukjanov> image gen - egafford too?
18:45:35 <SergeyLukjanov> tosky, will you be on summit?
18:45:46 <elmiko> i'd say yea, unless tosky will be there
18:45:46 <SergeyLukjanov> elmiko, oh, week before, cool :)
18:45:57 <tosky> SergeyLukjanov: I will
18:46:38 <crobertsrh> Awesome!  I didn't realize that tosky was going to be there!
18:46:44 <SergeyLukjanov> cool, would you like to co-chair the image gen with egafford?
18:46:50 <tosky> so Ethan and/or me, totally fine as you wish :)
18:47:01 <elmiko> nice =)
18:47:30 <SergeyLukjanov> tosky, I think you're interested a lot in testing things, so, let's co-chair the tests session
18:47:41 <tosky> ack, fine by me
18:47:49 <SergeyLukjanov> cool
18:47:58 <SergeyLukjanov> and we have someone to chair the edp part of "New plugins and edp jobs"
18:48:05 <SergeyLukjanov> egafford or tmckay I think
18:48:06 <crobertsrh> tmckay
18:48:18 <elmiko> +1
18:48:20 <SergeyLukjanov> let's put Trevor for it
18:48:32 <crobertsrh> Wow, Trevor should have been assigned a lot more since he's not here today.
18:48:38 <SergeyLukjanov> :)
18:48:43 <elmiko> lol, totally crobertsrh
18:49:05 <SergeyLukjanov> cool we have a schedule :)
18:49:13 <SergeyLukjanov> Thu morning (Oct 29), 9:00am - 4:10pm
18:49:13 <SergeyLukjanov> f: UX (agreed) - egafford?
18:49:13 <SergeyLukjanov> f: New plugins and edp jobs (agreed) - sl + tmckay
18:49:13 <SergeyLukjanov> w: Security (agreed) - elmiko
18:49:13 <SergeyLukjanov> w: UI tech (agreed) - croberts         // conflicts: elmiko
18:49:14 <SergeyLukjanov> w: Image gen (agreed) - egafford + tosky
18:49:15 <SergeyLukjanov> w: deprecation policies and plugins decoupling (agreed) - sl
18:49:16 <SergeyLukjanov> w: tests (agreed) - tosky + sl
18:49:21 <SergeyLukjanov> I'll put it into sched today
18:49:33 <elmiko> SergeyLukjanov: i thought we were going to do some planning for apiv2, is that on friday?
18:49:47 <SergeyLukjanov> anyone mind I'm writing myself "sl"? :)
18:49:56 <crobertsrh> elmiko:  I think that is a friday thing
18:50:05 <SergeyLukjanov> elmiko, yeah, I thought we agreed to book slot on friday meetup, are you ok with it?
18:50:08 <elmiko> SergeyLukjanov: fine by me
18:50:16 <crobertsrh> When you're the PTL, you can do as you please :)
18:50:16 <elmiko> yes, friday is great =)
18:50:22 <elmiko> whoa whoa whoa...
18:50:42 <elmiko> ;)
18:51:15 <SergeyLukjanov> hm, me trying to google the transation for "whoa" :)
18:51:22 <elmiko> haha
18:51:42 <elmiko> it's an exclamation, like "whoa!, hold on there"
18:52:00 <crobertsrh> Heh
18:52:40 <crobertsrh> There was an actor, Joey Lawrence, that made pretty much his entire career out of saying, "whoa!"
18:52:48 <SergeyLukjanov> :)
18:52:58 <SergeyLukjanov> heh, thx for explanation and sorry for my english :)
18:53:06 <elmiko> no worries =)
18:53:16 <crobertsrh> Your English is superior to my Russian, so keep with it!
18:53:34 <elmiko> +1
18:53:45 <SergeyLukjanov> :)
18:53:55 <SergeyLukjanov> #topic Important news and updates
18:54:00 <SergeyLukjanov> we have only 6 mins left
18:54:07 <SergeyLukjanov> so, do we have something important to share?
18:54:25 <SergeyLukjanov> crobertsrh, vgridnev, any important things on horizon side?
18:54:26 <crobertsrh> I've got 4 manila-related UI patches up for review.  They are on the list.  Take a peek if you have a chance.
18:54:44 <crobertsrh> 2 old ones and 2 new ones for adding shares to ng and cluster templates.
18:54:46 <SergeyLukjanov> crobertsrh, do you have running and working manila?
18:54:50 <vgridnev> yes, the several
18:54:51 <crobertsrh> I do
18:55:00 <SergeyLukjanov> crobertsrh RDO or devstack?
18:55:04 <crobertsrh> devstack
18:55:46 <crobertsrh> there is a manila plugin for devstack.  Works well for me.
18:56:24 <vgridnev> Ok, then I going to try that soon
18:56:35 <SergeyLukjanov> crobertsrh any complex config or works out of the box?
18:56:41 <elmiko> yea, manila plugin for devstack seem solid. works for me too
18:56:48 <crobertsrh> I'm going with the out of the box setup.
18:56:57 <SergeyLukjanov> oh, congrats vgridnev with becoming the core :)
18:57:05 <crobertsrh> Yes, congrats again!
18:57:06 <elmiko> \o/ grats vgridnev =)
18:57:14 <tosky> congratulations :)
18:57:17 <SergeyLukjanov> cool, I should try manila plugin too
18:57:27 <vgridnev> thanks, folks
18:57:28 <huichun> congrats
18:57:50 <SergeyLukjanov> 2 mins left :)
18:57:53 <elmiko> zaqar works nicely as well with devstack. we are using it for a demo of spark stream processing sahara controller logs =)
18:58:11 <elmiko> come see our talk at summit!
18:58:18 <SergeyLukjanov> elmiko :)
18:59:02 <crobertsrh> +1 elmiko
18:59:19 <SergeyLukjanov> hope it'll not conflict with design summit
18:59:27 <crobertsrh> of course not :)
18:59:30 <elmiko> i looked, i don't think it will
18:59:49 <elmiko> well, for me at least ;P
18:59:55 <SergeyLukjanov> okay, thx folks!
18:59:59 <SergeyLukjanov> #endmeeting