14:00:07 <elmiko> #startmeeting sahara
14:00:08 <openstack> Meeting started Thu Dec 17 14:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <openstack> The meeting name has been set to 'sahara'
14:00:16 <vgridnev> hey folks
14:00:18 <elmiko> hi folks
14:00:21 <esikachev> hey!
14:00:21 <NikitaKonovalov> hi
14:00:26 <huichun> hi
14:00:31 <tosky> hi
14:00:35 <egafford> o/
14:00:42 <elmiko> #chair vgridnev
14:00:43 <openstack> Current chairs: elmiko vgridnev
14:01:04 <AndreyPavlov> hi
14:01:09 <elmiko> i'll give folks a minute or two to roll in before we get started
14:02:41 <elmiko> ok then
14:02:55 <elmiko> #topic sahara@sahara-dashboard
14:03:00 <elmiko> ;)
14:03:23 <elmiko> i think croberts might be out
14:03:30 <elmiko> anything to report here vgridnev ?
14:03:45 <vgridnev> actually it's going, there are several changes was proposed, also integration tests job was merged to project config
14:03:55 <elmiko> cool
14:04:11 <vgridnev> so we need to wait for some changes on horizon side
14:04:41 <elmiko> what changes are we waiting for?
14:04:44 <NikitaKonovalov> vgridnev: so horizon will be running our intergation tests in their gate?
14:05:16 <vgridnev> to make pluggable integration tests, let me search for the link
14:05:24 <elmiko> vgridnev: thanks
14:05:41 <vgridnev> NikitaKonovalov, no, will run our own tests
14:06:16 <vgridnev> #link https://review.openstack.org/#/c/253608/
14:06:28 <NikitaKonovalov> ok, at least we will no when our dashboard breaks after some horizon changes
14:07:17 <tosky> or that the tests are broken by some horizon core change
14:07:22 <tosky> but yeah, better than now
14:07:30 <elmiko> should be nice
14:07:31 <vgridnev> yep, it's probably bad, but we need to make our integrations tests working first
14:07:38 <elmiko> anything else for this topic?
14:07:48 <vgridnev> I think no, let's move on
14:07:56 <elmiko> #topic News/Updates
14:08:02 <elmiko> so, what's everyone been up to?
14:08:50 <vgridnev> I'm working with improving ambari plugin right now
14:09:09 <NikitaKonovalov> I'm still in internal research and testing, so not much to share
14:09:28 <egafford> Image validation SPI spec is up; I have a working and tested sahara.plugins.images module. Doing cleanup before review @ this point.
14:09:31 <tosky> a bit of reviews and small enhancement, nothing more for now
14:09:31 <NikitaKonovalov> I hope I'll get some of the docs finished and finally published to upstream
14:09:39 <elmiko> i'm working on migrating the cdh passwords into the external key manager, but i've hit a snag
14:09:59 <elmiko> also, going to start setting up a prototype for the apiv2 work
14:10:40 <esikachev> working on spec, fixing bugs in scenario framework
14:11:42 <elmiko> ok, moving along
14:11:55 <elmiko> #topic Discuss sahara scenario tests extraction
14:11:57 <tmckay> I'm going to add a spec and patch for a --ironic or --baremetal flag on sie
14:12:05 <tmckay> doh, missed the updates :)
14:12:10 <elmiko> oops, sorry tmckay
14:12:11 <tmckay> I was typing
14:12:14 <tmckay> heh
14:12:15 <elmiko> np
14:12:40 <elmiko> #link https://review.openstack.org/#/c/250419/
14:12:58 <elmiko> this spec is looking good, is there anything more to discuss on the topic?
14:13:16 <vgridnev> spec is almost approved, but I think that we should wait for SergeyLukjanov to approve it
14:13:23 <esikachev> +1
14:13:29 <elmiko> i'm ok with that
14:14:05 <tosky> I have an implementation question, related to repository extraction, but I guess it can wait (for the record: if in such cases a mechanism like git grafting is used)
14:14:32 <elmiko> you can ask now if you'd like tosky
14:14:44 <tosky> (or it is just "initial import, dump of the revision xyz from this repository")
14:15:39 <tosky> I think right now it's mostly done with a dump of the last version from the previous repository (I could check with sahara dashboard for example), but still it would be nice to easily track the old history
14:16:03 <vgridnev> tosky, you can create local repo, but this repo will be imported during moving to openstack namespace
14:16:13 <elmiko> so, it sounds like the question is are we going to keep the git history when migrating to the new repository? (is that accurate tosky ?)
14:16:46 <tosky> elmiko: keep the history is one way (apply git filtering to the old repository and extract the history)
14:17:07 <egafford> I'm still concerned that this will make it harder to make plugins truly plugins (unless plugins require multiple repos to implement, and plug into a server framework and a test framework,) but I think we're deciding that that's okay for now (and we have a lot of harder work in the server to allow plugins to detach anyway, so it's probably fine.)
14:17:10 <tosky> the other way is allow to access the history from the new repository, but without importing it; this is git grafting
14:17:15 <elmiko> yea, i guess we can't keep the whole history, but only the scenario parts
14:17:37 <tosky> for reference to git grafting: https://git.wiki.kernel.org/index.php/GraftPoint
14:17:43 <elmiko> tosky: thanks!
14:17:53 <elmiko> egafford: it's a good point
14:18:32 <elmiko> egafford: i think we would need much more work on the plugin separation before we could contemplate scenario tests bundled with plugins
14:18:38 <egafford> It is, but I can see the argument that we should do this now, and maybe we can wire the test repo for plugability later when we get closer to that long-term goal.
14:18:39 <tosky> basically you don't have the old history, but the repository allow "joining" the old repository (if the user does some steps) and do a unified search
14:19:07 <tmckay> tosky, +1
14:19:24 <elmiko> egafford: imo, when we get closer to having true plugin separation, then we should revisit scenario test bundling as well
14:19:37 <tmckay> as time goes on, the need to search the old repo lessens
14:19:45 <elmiko> tosky: might be worth it, if we can setup the infra to do it
14:19:50 <elmiko> true
14:20:09 <elmiko> tosky: do you know if any other openstack projects have done this?
14:20:17 <tosky> elmiko: I have to say I don't know the details, but you don't need special infrastructure, it's the way you create the new repository and you organize the old one before the removal/split
14:20:22 <tmckay> I found myself wanting to search before the "savanna" rename a few times, but not many ...
14:20:36 <tosky> and no, I don't think it was done before, but I may be wrong
14:20:37 <elmiko> tosky: ah, interesting
14:20:52 <tosky> that's why SergeyLukjanov could have helped with his infra knowledge :)
14:20:54 <elmiko> tosky: would you mind making a comment about that on the review?
14:21:01 <tosky> elmiko: sure
14:21:09 <tosky> I will keep the +1
14:21:33 <elmiko> #action tosky to comment on the scenario separation spec about git grafting the history
14:21:42 <elmiko> cool, thanks
14:22:00 <elmiko> any other questions/comments/concerns about the scenario test separation?
14:22:24 <tmckay> it would have been handy in the rename move, I think :)
14:22:32 <tmckay> the grafting, I mean
14:22:39 <elmiko> agreed
14:23:15 <elmiko> ok, rolling along...
14:23:22 <elmiko> #topic API v2 progress
14:23:30 <elmiko> not a ton to report here
14:23:35 <elmiko> the spec could use more reviews
14:23:42 <elmiko> #link https://review.openstack.org/#/c/212172/
14:24:02 <elmiko> other than that, i am still working on setting up the wiki page for the individual work items to be generated
14:24:22 <elmiko> and i am starting to create a local prototype for the /v2 endpoints
14:24:48 <elmiko> any questions or comments about v2?
14:25:14 <tmckay> v2 is awesome
14:25:19 <elmiko> lol
14:25:30 <tmckay> the best api ever
14:25:43 <elmiko> best until v3!
14:25:44 <elmiko> ;)
14:25:59 <elmiko> ok then...
14:26:01 <tmckay> whoa, v3 ... that's never been done before!
14:26:06 <elmiko> haha
14:26:12 <elmiko> #topic New CLI
14:26:51 <elmiko> was there anything else to discuss on this topic, or should we remove it from the agenda?
14:27:09 <vgridnev> let's remove that
14:27:12 <egafford> It's a pretty great new CLI!
14:27:13 <AndreyPavlov> hmm I guess we have already discussed everything few weeks ago :)
14:27:18 <elmiko> yea, i think so
14:27:27 <elmiko> i'll remove it after the meeting
14:27:38 <tosky> (elmiko: added a comment to the spec related to tests, which I missed before, my fault)
14:27:44 <elmiko> #topic Open discussion
14:27:48 <elmiko> tosky: ack, thank you!
14:27:59 <elmiko> any other business folks?
14:28:03 <tosky> yes:
14:28:19 * elmiko hands the mic to tosky
14:28:24 <tosky> please vote on this review on tempest https://review.openstack.org/#/c/255968/ (thanks vgridnev)
14:28:45 <tmckay> general comment, I should be more active upstream starting in January.  I've been buried in a hole for a while ;-)
14:28:55 <tmckay> so, you can count on me for patches, reviews, etc
14:28:55 <tosky> the tests there could move to our repository at some point, but pending some dependencies; in the meantime we need that change to support the testing on different clusters
14:29:03 <elmiko> tmckay: \o/
14:29:17 <elmiko> tosky: ack, added to the queue
14:29:24 <tosky> vgridnev already put you all in the review, but please take a look :)
14:30:00 <elmiko> for those of us who are unfamiliar with tempest, is there anything we should know about that review?
14:30:22 <vgridnev> nothing. just vote with +1
14:30:31 <tosky> :d
14:30:33 <tosky> :D
14:30:38 <elmiko> lol, easy enough...
14:31:00 <elmiko> #link https://review.openstack.org/#/c/255968/
14:31:05 <tosky> it simply add support for default templates for the various supported plugins, so that the API tests works in any case, regardless of the set of enabled plugins
14:31:24 <tosky> no fancy code change, if you check the code, just some additional dictionaries
14:31:24 <elmiko> ah, cool
14:31:36 <elmiko> thanks tosky, and vgridnev
14:32:14 <elmiko> any other topics to discuss?
14:32:32 <vgridnev> will we have next 2 meetings?
14:32:48 <elmiko> i imagine not for next week
14:33:03 <tmckay> even the week after ...
14:33:04 <elmiko> and it seems like many openstack projects are taking the following week off as well
14:33:08 <tmckay> many of us will be PTO
14:33:11 <elmiko> yea
14:33:22 <tmckay> first week of January?
14:33:27 <elmiko> i think so
14:33:35 <tmckay> that would be the 7th
14:33:44 <elmiko> yea
14:33:51 <tosky> but then, for people in Russia, don't you have your holidays that time?
14:33:55 <elmiko> so, next meeting will be January 7th 1800UTC
14:34:10 <NikitaKonovalov> we have hollidays 1 - 10th of January
14:34:13 <elmiko> good question tosky
14:34:16 <tmckay> heh
14:34:23 <tmckay> so adjourn til the 14th?
14:34:27 <elmiko> i think so
14:34:35 <tmckay> there is always IRC, and openstack-dev, after all
14:34:41 <elmiko> ok, scratch that earlier memo
14:34:55 <elmiko> next meeting will be January 14th, 1400UTC
14:35:03 <elmiko> in openstack-meeting-3
14:35:11 <huichun> vgridnev schedule edp patch is too old https://review.openstack.org/#/c/182310/         My intergation test patch https://review.openstack.org/#/c/255173/ has rebase issue
14:35:32 <vgridnev> what kind of rebase issues?
14:35:40 <huichun> So can Intergation test patch do not rebase on that?
14:36:07 <huichun> Rebase error I am working on that issue
14:36:07 * tmckay brb
14:39:05 <elmiko> any other topics?
14:40:15 <vgridnev> 5
14:40:18 <vgridnev> 4
14:40:21 <vgridnev> 3
14:40:23 <vgridnev> 2
14:40:24 <AndreyPavlov> NOOOO
14:40:31 <vgridnev> 1.5
14:40:40 <vgridnev> 1
14:40:42 <vgridnev> #endmeeting