14:00:35 <elmiko> #startmeeting sahara
14:00:36 <openstack> Meeting started Thu Apr  7 14:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:40 <openstack> The meeting name has been set to 'sahara'
14:00:42 <elmiko> #chair vgridnev
14:00:43 <openstack> Current chairs: elmiko vgridnev
14:00:50 <elmiko> #chair SergeyLukjanov
14:00:50 <tosky> o/
14:00:50 <openstack> Current chairs: SergeyLukjanov elmiko vgridnev
14:00:54 <elmiko> hi =)
14:00:54 <mionkin> hi
14:00:59 <pgadiya> hello
14:01:04 <vgridnev> hey folks
14:01:43 <elmiko> #topic News / updates
14:01:54 <Poornima> Hello everyone
14:02:02 <vgridnev> it's announced that Mitaka was released!
14:02:06 <elmiko> \o/
14:02:54 <vgridnev> also, FYI:
14:02:57 <vgridnev> #link https://review.openstack.org/#/q/status:open+project:openstack/governance+branch:master+topic:sahara-tags
14:03:14 <esikachev> hi
14:03:20 <elmiko> vgridnev: that's nice to see
14:03:22 <vgridnev> this additional tags for sahara in governance ^^
14:03:24 <tosky> so, rejoice!
14:03:25 <crobertsrh> hello/
14:04:53 <elmiko> i've mainly been working on my presentation for openstack summit, and some internal stuff
14:05:07 <elmiko> although, i am happy to see that the service.api refactor spec got merged =)
14:05:46 <esikachev> i am working on prepearing sahara-tests for release, added filters for jobs on sahara-ci
14:06:10 <pgadiya> I am testing my changes which I have made w.r.t API v2 development on my local environment. Once tested will send the patch for review
14:06:24 <tosky> working on moving tempest API tests, almost ready (and thanks again to SergeyLukjanov, vgridnev and esikachev for the time spent and the support)
14:06:42 <Poornima> I am going through sahara service api now
14:06:55 <crobertsrh> I've had a couple of fixes for a couple of ugly UI issues....
14:07:27 <crobertsrh> One patch seems to break the integration tests, but I'm not sure why.  Any tips would be great since I'm currently unable to run the integration tests locally.  https://review.openstack.org/#/c/301789/
14:08:12 <vgridnev> crobertsrh, ok, I will try soon
14:08:14 <NikitaKonovalov_> o/ I'm mostly busy with intrnal stuff, but promiss elmiko to start working on slides
14:08:35 <vgridnev> it's important fix for us, I think
14:08:39 <elmiko> NikitaKonovalov_: awesome =)
14:09:32 <vgridnev> anything else new?
14:10:07 <vgridnev> #topic API v2 progress
14:10:17 <vgridnev> #link https://review.openstack.org/#/c/273316/
14:10:19 <elmiko> ok
14:10:22 <vgridnev> #link https://wiki.openstack.org/wiki/Sahara/api-v2
14:10:34 <vgridnev> elmiko, how is it going?
14:10:44 <elmiko> just waiting for some reviews on
14:10:46 <elmiko> #link https://review.openstack.org/#/c/298464/
14:10:56 <elmiko> then i'm hoping to add more patches on top
14:11:11 <elmiko> i'm happy to hear that pgadiya and Poornima are getting up to speed as well =)
14:11:16 <vgridnev> i've approved today spec about service.api, so going to take look on patch above
14:11:22 <elmiko> yea, thanks vgridnev
14:11:31 <vgridnev> ok, cool
14:11:33 <elmiko> otherwise, not much to report
14:11:46 <vgridnev> ok, next then
14:11:51 <vgridnev> #topic Scenario tests releases (tosky, esikachev)
14:12:26 <vgridnev> folks, what do we need additional in the first release of sahara-tests?
14:12:41 <esikachev> for release, i think, we need this patches#link https://review.openstack.org/#/c/295717/ #link https://review.openstack.org/#/c/295110/
14:12:54 <tosky> as anticipated before, I'm testing the tempest tests converted as tempest plugin inside sahara-tests - I'd like to have it as well, coming before end of today
14:13:42 * tmckay is here but distracted by another meeting where he has to talk ...
14:13:49 <tosky> agree with both reviews esikachev  pointed out; I reviewed one, and I was collecting details about reno
14:13:57 <vgridnev> I think that we need to make release till end of the next week, I think. Or if it will be possible to in the begging of the next week.
14:14:10 <tosky> I think that the reno one should have few other details
14:14:28 <esikachev> vgridnev: +1 for begging of the next week
14:14:49 <esikachev> tosky: ok
14:14:50 <vgridnev> ops, beginning, I think
14:14:57 <tosky> beginning is better than begging :)
14:15:13 <elmiko> hehe
14:15:23 <esikachev> :)
14:15:25 <vgridnev> I will take another look on reno stuff then
14:15:34 <vgridnev> ok, anything else?
14:15:57 <esikachev> thats all from me
14:15:58 <tosky> not from my side
14:16:02 <vgridnev> #topic Newton summit topics and schedule preparing (vgridnev, NikitaKonovalov)
14:16:53 <vgridnev> ok, first. Sad news: I'm not going to summit this time, btw I have crazy ideas to join via Hangouts or something like that
14:17:26 <elmiko> sad that you won't be there, but having the hangout will be good =)
14:17:27 <vgridnev> NikitaKonovalov will be my representative at the summit
14:17:37 <crobertsrh> If the conference network permits :)
14:17:43 <elmiko> good point
14:17:54 <Poornima> vgridnev, elmiko me too
14:18:04 <Poornima> on hangout
14:18:12 <elmiko> great
14:18:22 <elmiko> hopefully the laptops won't outnumber us ;)
14:18:27 <vgridnev> oh, forgot link
14:18:30 <vgridnev> #link #link https://etherpad.openstack.org/p/sahara-newton-summit
14:18:45 <crobertsrh> Sounds like one or more of us should try to get some sort of meeting solution set up and communicate it to others during summit
14:19:19 <elmiko> crobertsrh: do you mean like online meeting solution?
14:19:23 <crobertsrh> Yeah
14:19:44 <elmiko> +1
14:19:44 <crobertsrh> Of course, time zone might also impact people's chance to attend "remotely"
14:20:05 <crobertsrh> I think Austin is UTC-6, right?
14:20:16 <elmiko> that sounds about right
14:20:48 <vgridnev> about schedule: most of meeting are going to be started at the morning, so I for sure will have abilities to join
14:21:15 <crobertsrh> That is good
14:22:01 <vgridnev> we have draft schedule already in etherpad, I think that we should spend next meeting to finalise schedule
14:22:15 <elmiko> vgridnev: +1
14:22:18 <crobertsrh> I will be out next week
14:22:24 <crobertsrh> I think elmiko and tmckay will be as well
14:22:39 <tmckay> oh, next meeting? Yeah.
14:22:43 <elmiko> yea, gonna miss next weeks meeting. oops
14:23:03 <elmiko> but, i can certainly follow along if we propose something via email
14:23:09 <crobertsrh> We can always discuss in the regular channel if there's anything we can't address today
14:23:41 <vgridnev> +1, then I think that I will start finalising schedule together with Nikita
14:24:04 <vgridnev> I guess that we will need chairs for sessions, right?
14:24:04 <elmiko> just propose it to the ML once you and NikitaKonovalov_ have a plan
14:24:09 <elmiko> yes
14:24:15 <crobertsrh> At a first look, I don't see anything controversial on the schedule pad at the moment
14:24:25 <elmiko> i will volunteer to run the apiv2 and security sessions, as is tradition ;)
14:24:52 <crobertsrh> I'll run the UI session, per tradition
14:24:58 <elmiko> (assuming we use them)
14:25:04 <vgridnev> So, if you want to lead a session, please post this data to ether pad, so that we will have ability to understand that
14:25:12 <elmiko> ack
14:25:16 <tmckay> I will heckle crobertsrh in the UI session, so that's covered
14:25:26 <crobertsrh> whew, thanks tmckay
14:25:34 <elmiko> wow...
14:25:48 <elmiko> i will heckle tmckay heckling crobertsrh XD
14:25:56 <tmckay> HA :)
14:26:00 <crobertsrh> You get him good elmiko, he deserves it
14:26:08 <egafford> I will break the cycle of violence by not heckling elmiko
14:26:09 <elmiko> gotta preserve the chain of responsibility
14:26:15 <elmiko> hahaha!
14:26:40 <tmckay> egafford, you will be mocked for that. Mocking is different than heckling
14:26:53 <vgridnev> #action vgridnev, NikitaKonovalov to prepare draft schedule at post results in ML
14:28:15 <vgridnev> ok, anything else that we should cover in there?
14:28:31 <vgridnev> BTW, please continue collecting ideas
14:28:54 <vgridnev> More ideas is better always
14:29:23 <Poornima> elmiko, If we write a patch do we need to share it on same branch
14:29:36 <vgridnev> #topic Revisiting Sahara Blueprints
14:29:45 <Poornima> https://review.openstack.org/#/c/273316/ is already merged to git
14:29:49 <vgridnev> #link https://etherpad.openstack.org/p/sahara-bp-revisit
14:30:11 <vgridnev> so, we have few blueprints to discuss
14:30:18 <Poornima> or we need file a bug and create branch across that bug ?
14:30:36 <elmiko> Poornima: if you use the "Partial-Implements: bp v2-api-experimental-imp" in your commit message, it will be put on the appropriate topic
14:30:58 <elmiko> Poornima: no need to file a bug
14:31:13 <vgridnev> there are few blueprints that we should mark to implemented state, I guess
14:31:13 <elmiko> just make sure to use the "Partial-Implements" tag in your commit message
14:31:29 <vgridnev> #link https://blueprints.launchpad.net/sahara/+spec/cluster-creation-with-trust
14:31:41 <Poornima> got you :)
14:31:46 <vgridnev> is it true that this one is implemented ^^
14:32:04 <elmiko> i /think/ it's fully implemented
14:32:38 <vgridnev> ok, then
14:32:42 <vgridnev> #link https://blueprints.launchpad.net/sahara/+spec/scalable-savanna
14:32:44 <egafford> +1; I believe that you and I finished that off vgridnev.
14:32:57 <egafford> (Re: trusts, not scalability.)
14:33:18 <vgridnev> egafford, got it
14:34:14 <egafford> Scalability bp seems done as of Kilo (by default settings,) yes?
14:34:35 <elmiko> yea, seems like it
14:34:42 <vgridnev> for me too, ok
14:35:02 <vgridnev> and this one, finally: https://blueprints.launchpad.net/sahara/+spec/fake-test-plugin
14:35:21 <vgridnev> do we want to extend fake plugin in some way?
14:35:25 <elmiko> not sure if we achieved all those goals, but i thought fake plugin was in
14:35:31 <crobertsrh> It's mostly done, isn't it?
14:35:39 <crobertsrh> I can't think of ways that it's not done
14:35:46 <elmiko> right
14:37:18 <vgridnev> ok, then it's implemented. I guess that it was done for heat / direct engine testing, and it good enough in our gates
14:37:30 <elmiko> sounds good
14:38:10 <vgridnev> and finally, there are two blueprints, which are looks strange for me:
14:38:11 <tosky> it was done for upstream gates, so they don't require a full image build
14:38:16 <vgridnev> https://blueprints.launchpad.net/sahara/+spec/cluster-suspend-resume
14:38:23 <vgridnev> https://blueprints.launchpad.net/sahara/+spec/development-environment-vagrant
14:38:54 <elmiko> that suspend/resume sounds complicated
14:39:01 <vgridnev> we have spec approved there, but with out actual details of implementation
14:39:33 <elmiko> imo, we should drop the vagrant one in favor of a playbook for kolla
14:39:57 <elmiko> (which would by definition include an ansible route for deploying sahara)
14:40:22 <egafford> elmiko: +1; personally I love vagrant, but reuse of OpenStack ecosystem tools will only improve all our lives in the long run.
14:40:40 <crobertsrh> +1 for ansible/kolla
14:40:41 <pino|work> egafford: ... when they make sense
14:40:55 <egafford> pino|work: Valid, but kolla's kinda great, though young.
14:40:57 <elmiko> it's a nice idea, and i don't have an active objection to it. but if we are talking about designating resources, my preference is for kolla.
14:41:18 <pino|work> egafford: it was a general note, not directed to kolla
14:41:46 <elmiko> regardless of the kolla integration, having an ansible playbook for sahara would be awesome
14:41:46 <pino|work> (it actually was targeted to something else, but that's mildly ot)
14:42:31 <egafford> I don't see the drafter in the meeting at the moment.
14:43:01 <vgridnev> ok, it looks like we agreed about invalidating vagrant spec
14:43:07 <elmiko> yea, haven't see him in awhile
14:43:18 <egafford> Yeah, it's been dead since Sept. 2014.
14:43:43 <vgridnev> about suspend stuff, I think that we should remove spec, and keep that as idea
14:44:04 <elmiko> i'm ok with that, we probably need to rewrite the spec anyway
14:44:08 <crobertsrh> Yeah, fine idea, just not likely to happen anytime "soon"
14:44:46 <vgridnev> ok, thanks folks
14:44:55 <vgridnev> let's move on then
14:45:19 <vgridnev> #topic Open discussion
14:45:48 <vgridnev> anything additional that we should to discuss?
14:46:14 <elmiko> nothing from me
14:46:17 <crobertsrh> Nothing from me
14:46:40 <vgridnev> I'm going to prepare fixes to put in stable/mitaka shortly, just FYI.
14:46:57 <vgridnev> since stable/mitaka is now opened for post-release things
14:48:04 <crobertsrh> Yes, I think the 2 cosmetic, but ugly UI fixes should be backported
14:48:22 <vgridnev> crobertsrh, +1
14:48:50 <vgridnev> anything else?
14:49:04 <huichun> vgridnev:  suspend and resume will move to N?
14:49:17 <vgridnev> huichun, for jobs?
14:49:23 <huichun> Yes
14:49:50 <vgridnev> yes, N is now opened, let's make that happen
14:50:20 <vgridnev> 5
14:50:26 <vgridnev> 4
14:50:29 <vgridnev> 3
14:50:30 <vgridnev> 2
14:50:36 <vgridnev> 1
14:50:42 <tosky> a long 1
14:50:44 <vgridnev> thanks, folks!
14:50:45 <elmiko> lol
14:50:47 <elmiko> thanks all
14:50:51 <vgridnev> #endmeeting