14:00:26 <vgridnev> #startmeeting sahara
14:00:27 <openstack> Meeting started Thu Aug 11 14:00:26 2016 UTC and is due to finish in 60 minutes.  The chair is vgridnev. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:30 <vgridnev> #link https://wiki.openstack.org/wiki/Meetings/SaharaAgenda
14:00:30 <egafford> o/
14:00:31 <openstack> The meeting name has been set to 'sahara'
14:00:34 <vgridnev> o/
14:00:41 <elmiko> hi o/
14:01:43 <tellesnobrega> hey o/
14:02:21 <mionkin> hi
14:02:23 <vgridnev> #chair egafford
14:02:23 <openstack> Current chairs: egafford vgridnev
14:02:29 <vgridnev> ha mode
14:02:42 <tosky> hi
14:02:56 <vgridnev> #topic News / updates
14:03:44 <vgridnev> working on kerberos integration, 75 % of patches are ready for review ( I think )
14:03:58 <tosky> I'm a bit stuck on documenting the source of the jars, but I plan to have a doc patch soon
14:04:34 <vgridnev> tosky, have you saw https://review.openstack.org/#/c/351920/ ?
14:04:40 <egafford> Starting on the Ambari image generation yaml. Going pretty well; testing is really lovely compared to DIB (since it's idempotent and in-place, so any changes already on the image are already on the image and you don't have to wait for them.)
14:04:53 <tosky> vgridnev: ups, no
14:05:11 <vgridnev> tosky, spark and cdh jobs are happy (main consumers of job)
14:05:18 <mionkin> I finished work on designate and now working on replacing old CLI commands in grenade
14:05:20 <tosky> yeah, interesting
14:05:22 <egafford> Most of it's done; working on how best to deal with shared resources (like java setup scripts, etc.)
14:05:35 <vgridnev> ok, not absolutely happy
14:06:41 <tosky> vgridnev: there are the usual quota issues, but I guess we can talk later about them
14:06:44 <tosky> later in the meeting
14:06:58 <vgridnev> sure
14:08:02 <vgridnev> one more release of client is going to be done later this week ( I think today or friday )
14:08:34 <vgridnev> that will include sorting for pagination, and designate
14:09:32 <mionkin> it's great
14:11:34 <vgridnev> #topic Open discussion
14:12:01 <vgridnev> uh, voting for talks finished, so now we should wait for results
14:12:12 <tosky> so, is there anything we can do to help with quota issues in the Sahara CI?
14:12:30 <tosky> like reduce the number of the slots (even if it would slow down the jobs)
14:14:06 <vgridnev> is it still present? will take a look on that one more time
14:14:08 <tosky> I think that most of the failures come from that; even in the review you mentioned above (see errors like: APIException: Quota exceeded for instance: Requested 6, but available 3)
14:15:46 <NikitaKonovalov> tosky: I've seen this already. For some reason quotas on ci labs went very low.
14:15:53 <NikitaKonovalov> I've updated them
14:15:57 <NikitaKonovalov> should be fine now
14:16:00 <tosky> oh, thanks
14:20:03 <vgridnev> do we need some extra ATCs for sahara? see for details: [openstack-dev] [all][ptl][tc] extra ATCs for newton
14:20:32 <vgridnev> I can propose a commit if there are good candidates
14:22:01 * egafford checks Stackalytics for the actual ATC list...
14:23:10 <egafford> elmiko managed to get 2 in \o/
14:23:59 <vgridnev> note: Sergey Lukjanov and Alexander Ignatov already has ATC
14:24:22 <elmiko> lol
14:24:36 <elmiko> sadly, i don't think our group is gonna make the trip to barcelona =(
14:24:43 <egafford> I don't see anyone missing from the list of folks who've actually submitted patches. tmckay, croberts, and elmiko all have ATC this cycle, and... yeah. :(
14:25:59 <vgridnev> so, who is going to travel to Barca? egafford tellesnobrega and tosky ?
14:26:26 <tellesnobrega> vgridnev, unfortunately i'm not making this time
14:26:29 <tosky> 95% on my side, yes
14:26:45 <egafford> vgridnev: I think it might just be tosky and I this time. Brazil is far from Barcelona.
14:27:51 <tellesnobrega> :(
14:27:54 <egafford> tellesnobrega: Is there still a chance that you might make it if some preso gets accepted or something, or is it Just a No at this point.
14:27:59 <egafford> ?
14:28:39 <tellesnobrega> egafford, i didn't submit the preso, I got too busy with other stuff and missed the deadline
14:28:56 <tellesnobrega> SotK, I would say its pretty much a firm no
14:29:02 <egafford> Ah, ok. Well, you got a lot of other stuff done, so that's good at least.
14:29:15 <tellesnobrega> unless some miracle happens :)
14:29:39 <vgridnev> tosky, yes, it is easier for folks who in europe to get attended
14:29:43 <vgridnev> this time
14:31:46 <egafford> vgridnev: Is it time to start talking about pruning our core reviewer list a little?
14:32:17 <vgridnev> we can discuss that; sure
14:32:28 <vgridnev> #topic Core review list
14:32:31 <egafford> We've talked about it for the last 2 cycles or so; folks who are still in Sahara's orbit a little we should probably keep, but some folks probably just aren't coming back.
14:33:28 <egafford> alazarev has moved on entirely, and I don't think I ever met John Speidel, for instance.
14:34:02 <vgridnev> them are no longer in list
14:34:18 <vgridnev> ok
14:34:39 <egafford> https://launchpad.net/~sahara-drivers/+members#active
14:34:51 <egafford> Is this the wrong list?
14:34:54 <vgridnev> uh, sahara-drivers
14:35:00 <vgridnev> https://review.openstack.org/#/admin/groups/133,members
14:36:05 <egafford> Nice. Okay, that's a pretty sensible group; there's at least a chance that any of those people could contribute a review.
14:37:13 <egafford> We could be more aggressive in removing people, but it doesn't seem necessary.
14:38:51 <tosky> oh, not sure it's really important, but could I be added to https://launchpad.net/~sahara-tests-drivers ?
14:39:13 <tenobreg> yeah, we can wait another cycle and do this again
14:39:14 <egafford> +1; you sure do drive sahara tests.
14:40:09 <vgridnev> egafford, we can be more aggressive, so we need to define some policy probably
14:40:42 <egafford> Yeah, agreed.
14:41:30 <vgridnev> like if you are core and there are 2 cycles with very low rate in reviews, so then sorry, you will be removed
14:41:38 <tenobreg> maybe have a minimum number of reviews each cycle, and if the core stay below this threshold for 2 cycles, we can remove
14:42:32 <egafford> vgridnev: Yeah; I want to say we can make exceptions in rare cases where someone is legitimately away for a full year but plans to come back, but in that case we can always just vote to re-add people.
14:42:38 <egafford> It's a year; that's a long time.
14:42:54 <egafford> Any idea of a threshold for reviews?
14:43:47 <elmiko> probably some percentage of total reviews in a cycle?
14:43:59 <egafford> elmiko: Yeah, definitely.
14:44:11 <tellesnobrega> elmiko, +1
14:44:52 <vgridnev> no percentage is bad
14:45:01 <vgridnev> I ate 36%
14:45:06 <vgridnev> http://stackalytics.com/?module=sahara-group
14:46:07 <vgridnev> 50 reviews per cycle is really good value; at least 2 reviews per week in cycle
14:46:15 <NikitaKonovalov> I'd say a core reviewer should at least have a vote on all (or almos all) specs. This guaratess that the core team actually agrees on what is going to be implemented
14:46:57 <vgridnev> NikitaKonovalov, agreed, specs is also good idea
14:47:03 <tellesnobrega> this is a good point NikitaKonovalov, core have to review 80% of specs, and have at least 50 reviews per cycle
14:47:17 <tellesnobrega> something like that
14:47:43 <egafford> I like total reviews per cycle; say someone is legitimately away at the beginning of a cycle (for any reason) and misses a bunch of specs.
14:48:28 <egafford> I think encouraging the cores to always vote on specs is really good but I don't know that we should implement a cutoff metric based on it, because it could end up hurting people somewhat randomly.
14:48:42 <egafford> I do like the 50 review per cycle rule.
14:48:48 <tosky> uhm, I'm a bit below, need to raise my value :)
14:48:54 <egafford> tosky: Heh.
14:49:13 <egafford> You've got 4 left; I think you're gonna be ok.
14:49:40 <tellesnobrega> and you can always pick it up on the next cycle, as long as you don't stay 2 cycles below that
14:50:39 <egafford> Seems totally reasonable to me. A flat number of reviews per cycle is really easy to know if you're going to make it (so it's really transparent) and it's a good measure of contribution across the whole cycle.
14:50:40 <vgridnev> uh, I forgot about stable main team: alazarev still there, but I don't have access to remove.  I think that we need to define our team for stable
14:51:01 <vgridnev> and, should we remove matt from core list?
14:51:14 <vgridnev> and probably make some replacement?
14:52:15 <vgridnev> tellesnobrega is in top3 right now, for example
14:52:29 <vgridnev> I like matt -> tellesnobrega replacement
14:52:36 <egafford> vgridnev: :D
14:52:46 * egafford doesn't even have to ping you about that now!
14:52:47 <egafford> \o/
14:52:56 <tellesnobrega> i like that replacement as well :)
14:53:44 <egafford> Solid +2.
14:54:06 <vgridnev> for stable team, I think that we should just remove andrew from list
14:54:11 <egafford> And yeah, mattf has no reviews for 2 cycles.
14:54:29 <tosky> definitely +2
14:55:29 <egafford> vgridnev: Agreed re: alazarev, I think we're ok there. We may want to replace Trevor with someone more active next cycle if elmiko, tmckay, and croberts continue to slowly drift away.
14:56:14 <elmiko> i think you should definitely replace me
14:56:26 <elmiko> i doubt i will be able to work on openstack after this cycle
14:56:36 <elmiko> (if you would even call this "working on openstack")
14:57:04 <egafford> elmiko: Do you speak for tmckay and/or croberts when you say that?
14:57:27 <elmiko> i can't say for sure, but probably. let me ask them
14:57:50 <vgridnev> #action I have to document our core policy somewhere, post that in ML, and then nominate tellesnobrega for core, post in ML about removing folks from stable team.
14:58:23 <vgridnev> we have around 2 mins
14:58:25 <crobertsrh> I am only doing a few reviews here and there.  I haven't done any coding in awhile now.
14:58:46 <egafford> crobertsrh: Your review numbers are weirdly solid, though, so thanks.
14:59:12 <crobertsrh> Reviews are a habit that I just can't seem to break :)
14:59:49 <egafford> No pressure on our side to break it. ;)
14:59:50 <elmiko> tmckay says that goes for him too
15:00:10 <vgridnev> #endmeeting