14:10:13 <vgridnev> #startmeeting sahara
14:10:14 <openstack> Meeting started Thu Dec 15 14:10:13 2016 UTC and is due to finish in 60 minutes.  The chair is vgridnev. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:10:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:10:18 <openstack> The meeting name has been set to 'sahara'
14:10:29 <tosky> o/
14:10:48 <raissa> o/
14:10:49 <shuyingya> o/
14:11:37 <vgridnev> hello, I missed that, sorry, issues with calendar
14:11:42 <vgridnev> anyone else around?
14:11:57 <sl_> o/
14:12:49 <vgridnev> is egafford is going to join?
14:12:58 <vgridnev> ok, let's start with updates
14:13:06 <vgridnev> #topic News / updates
14:13:39 <tosky> not too much apart from few review (mainly switching the default to newton)
14:13:50 <vgridnev> was working with HDP 2.5, fixing https://bugs.launchpad.net/sahara/+bug/1649644 and some internal stuff
14:13:51 <openstack> Launchpad bug 1649644 in Sahara "Vanilla cluster on centos7 hangs in Waiting state in case of indirect access" [High,In progress] - Assigned to Vitaly Gridnev (vgridnev)
14:14:16 <vgridnev> I guess I will upload something related to HDP 2.5 soon
14:14:40 <tosky> is it going to use the same version of ambari used by HDP 2.4, or is there a new version?
14:14:58 <vgridnev> ambari will be upgraded to newest one
14:15:02 <shuyingya> working on support latest cdh plugin. and have some questions about it, need further investigate
14:15:13 <tellesnobrega> o/
14:15:27 <vgridnev> actually I did not found any issues with upgrade of that
14:16:29 <tosky> can the newer ambari deploy the older versions of HDP? Maybe we can unify a bit more content on the image
14:17:49 <vgridnev> tosky, self-explanatory table
14:17:50 <vgridnev> https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-installation/content/determine_stack_compatibility.html
14:18:24 <tosky> so yes, ambari 2.4 could be used for all versions :)
14:19:56 <vgridnev> yep, I guess HDP 2.3 will be working too
14:20:13 <vgridnev> tellesnobrega, any updates from you?
14:21:04 <tellesnobrega> not really, most working on downstream stuff, and waiting on the patch on the name check to land
14:21:31 <vgridnev> tellesnobrega, is egafford going to review that?
14:21:44 <tellesnobrega> other than that, I still have to come back to storm+apache integration
14:21:58 <tellesnobrega> i have to talk to her
14:22:02 <tellesnobrega> but she probably will
14:23:09 <vgridnev> ok, any updates from her? I don't remember last time she was at the meeting
14:23:24 <vgridnev> #topic Open discussion
14:23:51 <tellesnobrega> she is very busy upstream, but she will probably send some patches upstream on the CLI image generation soon
14:23:57 <tellesnobrega> busy *downstream
14:24:16 <vgridnev> uh, ok
14:25:30 <vgridnev> we probably need to discuss our schedule for future meetings, actually. Christmas and New Year are soon
14:25:33 <tosky> as general note, I will be on vacation the next two weeks; I may be hanging on freenode, but definitely less activity :)
14:26:33 <shuyingya> Hi vgridnev, about the cdh plugin, the resource dir contains some config files. about the json file, where I can find it?
14:26:57 <vgridnev> shuyingya, 1 min
14:27:28 <shuyingya> ok
14:27:44 <vgridnev> shuyingya, https://github.com/openstack/sahara/blob/master/sahara/plugins/cdh/v5_7_0/resources/cdh_config.py
14:27:59 <tellesnobrega> about the meetings, we sure need to figure that out, tosky will be mostly out, egafford will also, since the office shuts down
14:28:44 <vgridnev> you are deploying a cluster with most of all services, and then you get default configs
14:29:30 <vgridnev> about the meetings, 1 min, I will take a look on calendar
14:30:35 <shuyingya> vgridnev, aha, not read this code yet.
14:30:49 <shuyingya> thx
14:31:32 <tellesnobrega> can I get some eyes on this patch? https://review.openstack.org/#/c/282506/
14:32:07 <tellesnobrega> its been there for quite some time (my bad as well), I will review today, but if anyone else can do the same, I appreciate
14:32:07 <vgridnev> 1. we can cancel future 3 meetings, Dec. 22 Dec. 29, and Jan. 5. If we need something to discuss, let's do that in openstack-sahara channel. important updates also let's track in openstack-sahara and mailing list
14:32:37 <vgridnev> tellesnobrega, ok
14:33:02 <tellesnobrega> thanks
14:33:27 <vgridnev> so, what do you think guys about that plan?
14:33:33 <tellesnobrega> meeting plans looks good
14:33:50 <shuyingya> I am fine with it
14:34:01 <tosky> fine by me
14:34:42 <vgridnev> #action send meeting plan to ML
14:34:59 <vgridnev> anything else we can discuss?
14:36:32 <shuyingya> tosky, about https://review.openstack.org/#/c/409092/, why do we need create a project and an user other default admin?
14:36:44 * tosky looks
14:37:58 <tosky> shuyingya: what is the real world scenario for sahara usage? admin is special, you want to try with a normal user
14:38:06 <tosky> if I understand the question
14:38:56 <shuyingya> tosky, thanks. that make sense
14:39:24 <shuyingya> but do you have idea about the last comment I posted?
14:40:25 <tosky> shuyingya: and if you delete the tenant first?
14:40:59 <shuyingya> also can't delete the user. it requires a tenant.
14:41:26 <tosky> I'm pretty sure that tempest does it elsewhere, when dynamic credentials are used
14:41:49 <tosky> because a separate user and tenant are created and then removed
14:42:03 <tosky> but I did not investigate the sequence of operations
14:42:45 <shuyingya> ok, I will investigate it.
14:45:03 <vgridnev> anything else we need to cover?
14:45:16 <tellesnobrega> not from me
14:45:23 <tosky> happy holidays everyone!
14:45:25 <shuyingya> me too
14:45:36 <tellesnobrega> happy holidays you all
14:45:45 <shuyingya> happy vacation, tosky
14:45:55 <shuyingya> happy holidays, all.
14:46:00 <vgridnev> thanks all
14:46:02 <vgridnev> #endmeeting