18:03:26 <tellesnobrega> #startmeeting sahara
18:03:27 <openstack> Meeting started Thu Mar 16 18:03:26 2017 UTC and is due to finish in 60 minutes.  The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:31 <openstack> The meeting name has been set to 'sahara'
18:03:44 <tosky> o/
18:03:49 <mariannelm> o/
18:03:51 <jeremyfreudberg> o/
18:03:55 <zemuvier> o/
18:04:33 <tellesnobrega> sorry for being a couple minutes late
18:04:35 <raissa> o/
18:04:51 <esikachev> hi
18:05:01 <rodrigods> o/
18:05:06 <tellesnobrega> #topic News/Updates
18:05:55 <tellesnobrega> SotK, I'm working on image gen still, finishing cdh on centos and starting on ubuntu soon
18:06:06 <tellesnobrega> SotK, sorry again
18:06:12 <SotK> :) np
18:06:36 <esikachev> i am working on debugging sahara-ci, spec for sahara-scenario api and first patch for implementation scenario api
18:06:41 <zemuvier> I am helping esikachev with debugging of sahara-ci after its updating
18:07:58 <jeremyfreudberg> I've been digging around with how Pig on Vanilla jobs are working right now. Basically the Pig libs are living in HDFS and are brought in by oozie
18:08:02 <tellesnobrega> other than that, I'm trying to keep up with boston summit news and other projects and will start bug triage asap
18:09:03 <jeremyfreudberg> So when you run a pig job through EDP, oozie creates a "pig-wf" which can load those libs but otherwise they are inaccessible
18:09:07 <zemuvier> tellesnobrega any news from travel support team?
18:09:59 <tellesnobrega> jeremyfreudberg, nice, do you feel there is a need to change that? or this should work fine?
18:10:06 <tellesnobrega> zemuvier, not yet, nobody contacted me
18:10:19 <zemuvier> tellesnobrega sad :(
18:10:41 <tellesnobrega> zemuvier, I will try to get in touch with them
18:10:51 <jeremyfreudberg> tellesnobrega, so the issue is there is no way run pig without oozie, unless you copy the libs to local disk first, seems wrong to me
18:11:18 <tellesnobrega> jeremyfreudberg, it seems wrong to me too. Do you want to write a spec on how you plan to fix it?
18:11:25 <tosky> we could dig into the history to see why it was done this way - maybe recommended by upstream some time ago?
18:12:19 <jeremyfreudberg> tellesnobrega, sure. might require some changes to vanilla plugin, not just Sahara-Image-Elements like I originally thought
18:12:56 <tellesnobrega> tosky, true. jeremyfreudberg let's make it like this. I will take a look into history with tosky help (please tosky :) ) and we let you know the reason for that. If we don't find one then you can start planning changing it
18:13:07 <tellesnobrega> tosky, jeremyfreudberg does that sound goodw
18:13:08 <tellesnobrega> ?
18:13:28 <jeremyfreudberg> tellesnobrega, cool, sounds fine to me
18:14:54 <tellesnobrega> anyone else has news?
18:15:45 <mariannelm> nope, I'm not doing any particular changes right now, but I have some free time, so if there is a task that I could help, I would be happy to do it
18:16:57 <tellesnobrega> mariannelm, nice, i will email you with some tasks
18:17:29 <jeremyfreudberg> tellesnobrega, by the way, I just remembered - did you find out what the plan was for uploading the ocata images to sahara-files?
18:17:54 <tosky> Vitaly wrote something earlier, for the record: "<vgridnev>     I will skip today's meeting, nothing to say.Just several fixes and waiting for review in project-config https://review.openstack.org/#/c/442382/"
18:18:11 <tellesnobrega> jeremyfreudberg, no I didn't, i will do so
18:18:18 <tosky> we did it for some files already
18:18:21 <tosky> like oozie stuff iirc
18:18:52 <tosky> oh, no, it was the hadoop-swift blob
18:19:16 <tellesnobrega> tosky, do we have a deadline for uploading this imagesw
18:19:22 <tosky> but I don't find the job that do the publishing
18:19:57 <tosky> tellesnobrega: I was not at the PTG, you tell me :) probably the sooner the better, as Ocata is out
18:20:19 <tellesnobrega> tosky, cool, I will take a look into that and let you guys know by next meeting
18:20:36 <tellesnobrega> #action tellesnobrega to look into ocata images uploading
18:20:44 <tellesnobrega> #topic Open Discussion
18:21:36 <tellesnobrega> about Boston summit, anyone is planning to attend?
18:21:47 <esikachev> me :)
18:21:50 <jeremyfreudberg> yes, will definitely be there, giving talk too
18:21:56 <mariannelm> yes o/
18:22:02 <zemuvier> i will try to
18:22:25 <tellesnobrega> jeremyfreudberg, awesome. mariannelm and zemuvier you guys are depending on TSP right?
18:22:31 <mariannelm> yes
18:22:38 <zemuvier> yes
18:22:46 <zemuvier> and esikachev too i think
18:22:55 <esikachev> yep
18:23:01 <tellesnobrega> cool, I will try and look into this
18:23:20 <tosky> tellesnobrega: re image publishing, look into openstack-infra/project-config, check the job 'gate-sahara-extra-artifacts'
18:23:21 <jeremyfreudberg> lucky i only live one mile from the summit this time :p
18:23:59 <tellesnobrega> tosky, thanks
18:24:14 <tellesnobrega> jeremyfreudberg, there is a open question about onboarding rooms, training new people on the project
18:24:16 <esikachev> jeremyfreudberg: i only live 2000 miles from the summit Ж)
18:24:40 <tellesnobrega> I'm not planning to ask for a room for Sahara, since there will be so feel of us there
18:25:43 <tellesnobrega> not sure if we will be able to have that availability
18:26:38 <jeremyfreudberg> tellesnobrega, it's your decision, sure we don't have many saharans going to the summit but the chance to grow the team is good
18:27:51 <tellesnobrega> jeremyfreudberg, yes, that is exactly my thinking, I will think on that and let you guys know if we can still get some space
18:28:06 <tellesnobrega> the slots are for 90 minutes, but I think we can share with other projects
18:29:05 <tellesnobrega> SotK, mariannelm zemuvier esikachev I will look into TSP see if I can influence them into taking you guys.
18:29:20 <tellesnobrega> other than that, do we have anything to discuss?
18:29:33 <jeremyfreudberg> just one more thing, can we add a pike folder here: http://git.openstack.org/cgit/openstack/sahara-specs/tree/specs
18:29:59 <zemuvier> tellesnobrega let us know if you hear something new about tsp
18:30:09 <tellesnobrega> yes, it should be there already, I think after esikachev's patch merge we will have it
18:30:13 <tellesnobrega> zemuvier, will do
18:30:27 <tellesnobrega> but I will create that today just to be sure
18:30:39 <jeremyfreudberg> tellesnobrega, thanks
18:30:52 <esikachev> thanks
18:31:22 <zemuvier> thanks
18:32:10 <tellesnobrega> mariannelm, how do you feel about working on the api v2?
18:32:39 <mariannelm> yeah, I think I can do that
18:32:52 <tellesnobrega> nice, I will send you some tasks on that
18:32:58 <mariannelm> cool!
18:33:19 <mariannelm> also, do you know why my patch wasn't merged?
18:33:46 <tellesnobrega> mariannelm, no idea, maybe some issues on gate, maybe esikachev and tosky know that
18:34:07 <esikachev> which patch you mean?
18:34:16 <tellesnobrega> https://review.openstack.org/#/c/427447/2
18:34:23 <tellesnobrega> or because ci didn't passa
18:34:24 <tellesnobrega> pass
18:35:10 <esikachev> let's try again
18:35:11 <tellesnobrega> checking again and will make it pass :)
18:35:17 <esikachev> :)
18:35:37 <mariannelm> thank you :)!
18:36:24 <tellesnobrega> anything else folks?
18:37:03 <tosky> in the worst case (the review above is not merged with no visible reasons), the way is ask #infra
18:37:14 <tosky> but let's see
18:37:16 <tosky> it's running now
18:37:19 <tellesnobrega> nice
18:38:28 <tellesnobrega> I guess this all for today
18:38:39 <tellesnobrega> thanks all, lets keep up the good work :)
18:38:52 <esikachev> thanks all
18:38:56 <tellesnobrega> #endmeeting