18:00:02 <tellesnobrega> #startmeeting sahara
18:00:03 <openstack> Meeting started Thu Apr 27 18:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:07 <openstack> The meeting name has been set to 'sahara'
18:00:21 <tosky> o/
18:00:59 <esikachev> o/
18:02:14 <tellesnobrega> i guess it will be only the three of us today
18:02:24 <tellesnobrega> lets get it started and people can join as we go
18:02:30 <tellesnobrega> #topic News/Updates
18:03:19 <tellesnobrega> I got CDH image working but validation is still in progress, now I'm working on ambari image, seems like I'm facing a timeout issue, cluster is failing, but most of the stuff I could install afterwards using ambari UI
18:03:35 <tosky> I'm going to add additional build jobs to support the new building method, but in the meantime I'm fixing the issues on the current gates
18:03:37 <tellesnobrega> I have to check if anything is missing from the image, but hopefully that won't be long
18:04:04 <tellesnobrega> also, I'm preparing the OpenStack talk
18:04:10 <esikachev> unfortunately, I have not any updates
18:04:12 <tosky> I fixed two of the issues, but one requires a bit of toughts
18:04:16 <tosky> namely https://bugs.launchpad.net/sahara/+bug/1686400
18:04:17 <openstack> Launchpad bug 1686400 in Sahara "Building of Spark images fails as it requires CDH 5.4" [Undecided,New]
18:04:34 <tellesnobrega> it will be on Wednesday afternoon, 17:30 to 18:10 iirc
18:04:54 <tellesnobrega> on tuesday we have the onboarding session, esikachev can you help me out with that?
18:05:06 <esikachev> sure
18:05:22 <esikachev> what i need to do?
18:05:27 <tellesnobrega> it will be basically a time to introduce people how to work on sahara, and if you can, you could explain a little about the tests
18:05:41 <tellesnobrega> what type of tests we have, how to implement, how to run
18:06:09 <tellesnobrega> basically that, I will start a presentation and we can work on it this coming week
18:06:27 <tellesnobrega> nothing too fancy I would say, just some steps to guide people
18:07:19 <esikachev> ok, no problems. fyi, from 4th may I will be in New York and from 7th in Boston
18:07:46 <esikachev> small vacation :)
18:07:47 <tellesnobrega> awesome, I'll get to boston on the 8th, monday only
18:07:50 <tellesnobrega> nice
18:07:59 <tellesnobrega> I'll do the same, but after the summit
18:08:18 <tellesnobrega> hopefully we can finish this up by tuesday
18:08:20 <esikachev> you can ping me by email in any time
18:08:27 <tellesnobrega> great, thanks
18:08:52 <tellesnobrega> #topic OpenDiscussion
18:09:36 <esikachev> tellesnobrega: are you ready for speed mentoring?
18:10:00 <esikachev> or you will skip it?
18:10:51 <tosky> before the meeting, jeremyfreudberg reminded about the plan to upload Ocata images to sahara-files
18:11:27 <tosky> I can take a look at it; I guess that we need to do something similar to what we do for the other build artifacts from sahara-extras
18:11:42 <tosky> if infra allows it, of course
18:12:02 <tosky> do we want to manually trigger the refresh of the images, right?
18:12:25 <tellesnobrega> esikachev, I won't make it, I will get there monday afternoon
18:12:39 <tellesnobrega> I sent an email to the responsibles explaining the situation
18:12:59 <tellesnobrega> tosky, yes, we need that asap if infra allows it
18:13:19 <esikachev> you mean upload images to sahara-extra?
18:13:40 <esikachev> or about images on sahara-files?
18:13:44 <tellesnobrega> esikachev, I don't think that is. Upload the images to sahara-files
18:13:53 <tellesnobrega> to update them with ocata images
18:14:19 <clarkb> what is sahara-files?
18:14:29 <tosky> esikachev: if you can upload to sahara-files, that would be fine as well; but I was thinking that maybe the best solution long term is uploading them to $somewhere on infra
18:14:34 <tosky> if infra allows it
18:14:38 <tosky> and we have infra here :)
18:14:59 <tosky> clarkb: http://sahara-files.mirantis.com/images/upstream/
18:15:09 <esikachev> sahara-files is mirantis account on rackspace
18:15:39 <esikachev> I uploaded them manually
18:15:59 <esikachev> Or am I wrong?
18:16:07 <tellesnobrega> we use it to keep sahara ready images so users don't need to build their own if they don't want to
18:16:18 <tosky> esikachev: about uploading manually, about using sahara-files, or about something else?
18:16:54 <esikachev> about uploading images to sahara-files
18:17:01 <clarkb> as for infra uploading to things like that we have to segregate credentials to do that onto special servers so that they aren't exposed. So general process is build job stores artifcat on tarballs.openstack.org, then subsequent job runs on privileged host to copy artifact from tarballs to $otherlocation
18:17:44 <clarkb> might be best to describe exactly what you are thinking of doing without too many implementation details to a message on openstack-infra@lists.openstack.org and we can go from there
18:18:10 <tellesnobrega> thanks clarkb, we will do that
18:18:29 <tellesnobrega> who can take that action? tosky, esikachev?
18:19:11 <esikachev> i can build and upload, but it will be tomorrow
18:20:07 <tellesnobrega> esikachev, thanks
18:20:09 <esikachev> can you specify plugins and versions?
18:20:34 <tellesnobrega> about sending the email to infra so we start thinking about storing the images there, tosky can you send that email?
18:20:56 <tosky> yes, I can
18:21:08 <tellesnobrega> I would say, anything that is not deprecated in ocata should be built
18:21:20 <tellesnobrega> deprecated ones the user can take care if they want
18:21:24 <tosky> clarkb: we already have a job to upload some artifacts
18:21:37 <tosky> but I won't into details
18:21:52 <tellesnobrega> #action tosky to email infra about storing sahara images on OpenStack infra
18:22:55 <tosky> clarkb: and as you are here :) https://review.openstack.org/#/c/458815/
18:23:14 <tosky> a follow-up of a discussion few weeks ago
18:23:19 <clarkb> thanks will review
18:23:27 <tosky> vgridnev: \o/
18:24:18 <tellesnobrega> the other topic that I want to throw out there so we can start thinking about is the next PTG, it will be held in Denver and I was asked if Sahara will make it
18:24:34 <vgridnev> I've missed that meeting actually. Anyway, I don't have updates from me, still no activities on my change to the devstack-gate project
18:24:45 <tellesnobrega> I think that jeremy can make it, since he is "close"
18:25:17 <tellesnobrega> I would like to know if esikachev and vgridnev think that you can make it, because I don't think it makes sense to have only two people in the room
18:25:35 <tellesnobrega> also shuyiang but he isn't here
18:26:06 <tellesnobrega> tosky, would be awesome to have you there as well
18:26:24 <tosky> eh
18:26:27 <tosky> let's see
18:26:37 <tellesnobrega> :)
18:26:39 <tosky> I was hoping from some other locations, but let's see
18:26:45 <tellesnobrega> lol
18:26:51 <vgridnev> I don't think I will be able to visit Denver
18:27:13 <esikachev> I will try, but I am not sure
18:27:44 <esikachev> only, if TSP will help :)
18:27:52 <tellesnobrega> ok. I don't like the idea of the team not meeting for too long
18:28:09 <tellesnobrega> I will ask around and try so we make it there
18:28:25 <tellesnobrega> I'll let you know
18:28:30 <tosky> clarkb: not sure you can take a look to this change in devstack-gate, useful for our multinode testing: https://review.openstack.org/#/c/447158/
18:30:03 <tellesnobrega> anyone has other topics?
18:30:35 <esikachev> i haven't
18:31:05 <tellesnobrega> I actually have one other topic, since vgridnev is also here
18:31:22 <tellesnobrega> I was thinking about the possibility of us taking the plugins code out of sahara
18:31:28 <tellesnobrega> and have it as a library
18:31:52 <tosky> I remember that we discussed about it in the past
18:31:57 <tellesnobrega> this will allow users to have access to newest plugin versions without having to wait for a new OpenStack release
18:32:56 <tellesnobrega> I talked with elmiko (michael mccune) today, he is looking for logs of this previous discussion, but he remembered the that overall idea was well accepted I also think this could be a great step forward for sahara
18:33:31 <tellesnobrega> just throwing the idea, take some time to think it over, I will write a spec on it after the summit
18:33:40 <tellesnobrega> we can discuss it in more details
18:38:30 <tellesnobrega> if no one has anything else to discuss today, lets end it and we got 20 minutes back to work
18:38:46 <tellesnobrega> thanks guys, please remember to review our open patches
18:39:08 <tellesnobrega> #endmeeting