18:00:06 <tellesnobrega> #startmeeting Sahara
18:00:07 <openstack> Meeting started Thu May 25 18:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:10 <openstack> The meeting name has been set to 'sahara'
18:00:15 <esikachev> hi
18:00:18 <vgridnev> o/
18:00:23 <zemuvier> hi all
18:00:26 <jeremyfreudberg> o/
18:00:38 <rodrigods> o/
18:01:42 <tellesnobrega> #topic News/Updates
18:02:07 <vgridnev> No updates from me, was doing several reviews
18:02:26 <jeremyfreudberg> just fixing everything related to nova-network removal
18:02:34 <tellesnobrega> hey guys, I was on PTO since the summit until yesterday... still getting back in track with emails and to dos
18:02:36 <esikachev> i have not any update. planing to reinstall devstacks on our ci hosts
18:02:58 <tellesnobrega> esikachev, why is that needed? major breakage?
18:03:03 <zemuvier> i don't have anything interesting too
18:03:22 <egafford> No update other than that I exist again.
18:03:37 <esikachev> for testing on master version of devstack
18:03:39 <jeremyfreudberg> the walmartlabs people have also been talking to me about their improved hadoop-swift driver (tellesnobrega that was the email I sent you)
18:03:41 <tellesnobrega> great to have you back here egafford
18:03:52 <egafford> Good to be back. :)
18:03:57 <tellesnobrega> esikachev, I see, thanks
18:04:27 <tellesnobrega> jeremyfreudberg, awesome, I will try yo get to it today and reply accordingly and will spread to the whole community
18:05:06 <tellesnobrega> I guess one update I have is that we got an intern on the outreachy program, she is going to be working on the templates import export option (side project)
18:05:16 <jeremyfreudberg> tellesnobrega, cool, they had some questions about what they want to do with their code (should it go into sahara-extra, should it go to Apache, should it go somewhere else??)
18:05:19 <tellesnobrega> and if time permits, she may help us out with some other stuff
18:05:58 <egafford> tellesnobrega: Awesome! Is she about on IRC yet?
18:06:11 <egafford> (The internship cycle starts soon, yes?)
18:06:12 <tellesnobrega> jeremyfreudberg, cool, I have to think about it and we should discuss the options
18:06:57 <tellesnobrega> egafford, it does... she was hanging out in #openstack-sahara a while back... I will talk to her soon and ask her to be available there
18:07:16 <tellesnobrega> her irc nick was changing between iwona and pinus
18:07:35 <tellesnobrega> so if anyone sees her around say hi and welcome her to the team
18:08:46 <tellesnobrega> #topic Boston Summit and next steps
18:09:53 <tellesnobrega> I just want to summarize a little of what happened at the summit and how that affected us, there will probably be other stuff than what I'm saying here, but I didn't catch up with jeremyfreudberg's info on swifta and with esikachev's on the session that he attended for Queen's community goals
18:10:39 <tellesnobrega> First of all, there was only a few of us there, I recall esikachev, jeremyfreudberg, egafford (partially), marianne (she won't be here for a while) and alina
18:11:34 <esikachev> alina = zemuvier :)
18:11:57 <tellesnobrega> esikachev, thanks :)
18:12:16 <tellesnobrega> We didn't have any proposals on the forum, but we did have a onboarding room where we instead of instructing new contributors (because none showed up) we explained to a possible costumer how sahara works and how it could e useful to his use case
18:12:44 <tellesnobrega> turned out to be really productive if we consider the aspect that we might get a new user
18:12:53 <egafford> He was a public cloud operator, so it would be pretty cool to have them.
18:13:02 <tellesnobrega> yes
18:13:30 <egafford> (Since Sahara really gets exciting when it provides ease of use to public cloud customers without the overhead of operating their own stack.)
18:14:45 <tellesnobrega> The other important thing that happened (sadly concurrent with the onboarding) was the presentation of the swifta, a new swift driver that promises to fix some important issues with the current driver, such as large files problems
18:15:31 <jeremyfreudberg> beyond large files, also better thread management, fixes issues with object listing, more efficient rename, etc
18:15:57 <jeremyfreudberg> #link https://www.openstack.org/videos/boston-2017/introducing-swifta-a-performant-hadoop-file-system-driver-for-openstack-swift
18:16:01 <tellesnobrega> I still have to read jeremyfreudberg's email and get in touch with them, but from what jeremyfreudberg has told me, they need a place to host their code, and we need to understand that code and see where it could fit and we could and should maintain it
18:16:11 <tellesnobrega> thanks jeremyfreudberg :)
18:17:40 <jeremyfreudberg> yes, exactly, they are heading towards open-source release soon, but the governance is still "up in the air"
18:18:03 <jeremyfreudberg> not to mention they based their work off icehouse branch of sahara-extra, so we have to rebase it too
18:18:54 <tellesnobrega> jeremyfreudberg, true
18:19:10 <tellesnobrega> that shouldn't be too problematic, sahara-extra doesn't change much
18:19:11 <tellesnobrega> Other than that, but not as important, I presented the projects update, where I gave a brief overview of sahara and probable directions we are heading in the next cycles
18:20:05 <tellesnobrega> I guess that is all I have to say about the summit, if I stumble into anything else I will email
18:21:20 <tellesnobrega> #topic Open Discussion
18:22:21 <egafford> Any particularly high-prio reviews at present?
18:22:36 <vgridnev> Do we want to drop some legacy code which is related to the direct engine (some stuff around deletion of resources)
18:22:42 <tellesnobrega> egafford, yes, the work jeremyfreudberg is doing on nova-network
18:22:57 <esikachev> about tosky's idea for publishing images on https://tarballs.openstack.org. i found the link with trove project with images https://tarballs.openstack.org/trove/images/
18:23:23 <jeremyfreudberg> egafford: https://review.openstack.org/#/c/466778/ (my last patchset just broke the tests again, but the prior patch should be "reviewable")
18:23:34 <egafford> jeremyfreudberg: Ack; thanks.
18:23:53 <tellesnobrega> vgridnev, that sounds like a good idea, if it is not being used, best we take it out, can you work on that? or are you just suggesting to someone else?
18:24:32 <vgridnev> I actually noticed that right there https://review.openstack.org/#/c/466778/18
18:24:36 <amrith> esikachev ... trove doesn't use those images; they are stale, they cause much anguish and problems.
18:24:47 <tellesnobrega> esikachev, do you want to follow up on luigi's email to infra and see if you can make it happen? or do you want me to do it?
18:24:57 <egafford> amrith: Thanks for the heads up. :)
18:25:19 <esikachev> tellesnobrega: i can
18:25:35 <amrith> egafford .. np
18:25:36 <tellesnobrega> esikachev, thanks
18:25:44 <tellesnobrega> amrith, thanks
18:25:48 <vgridnev> I guess that I can do that
18:26:13 <tellesnobrega> vgridnev, thanks
18:29:01 <jeremyfreudberg> so... regarding that old direct engine code, anyone who is interested please jump in on my/vgridnev's conversation on the patch
18:29:22 <jeremyfreudberg> there is some more info there
18:29:40 <tellesnobrega> jeremyfreudberg, yes, I will follow up there too, but I agree with what vgridnev said, will leave a comment there
18:30:32 <tellesnobrega> do we have anything else to discuss?
18:30:48 <tellesnobrega> anyone who went to the summit has anything to add?
18:31:12 <jeremyfreudberg> i remember some forum about some protected api thing
18:31:56 <jeremyfreudberg> i didn't go to it, nor do i remember exactly what it was, but it something about, for example, having the instances created by sahara or similar service being protected
18:32:05 <jeremyfreudberg> anyone remember that?
18:32:43 <tellesnobrega> jeremyfreudberg, yes, I remember talking to adam young about it, I can try to ping him and see what was the outcome of that
18:33:03 <jeremyfreudberg> ok well if it was adam young, he works pretty closely with my organization, I can just ask him myself
18:33:12 <tellesnobrega> I will try to find more info on that
18:34:34 <tellesnobrega> jeremyfreudberg, cool, I'm not sure he was on this forum, but I remember talking to him about something related to it and I know he is working with API issues and grants and what not
18:36:07 <jeremyfreudberg> tellesnobrega, actually he couldn't have been the host of that forum, otherwise I would have been there
18:36:16 <jeremyfreudberg> so yeah, I guess just ask him
18:36:22 <tellesnobrega> jeremyfreudberg, cool
18:36:33 <tellesnobrega> I will look around too
18:36:54 <tellesnobrega> #action jeremyfreudberg and tellesnobrega to find more about the protected api "thing"
18:37:04 <jeremyfreudberg> nice
18:39:04 <tellesnobrega> anyone else?
18:41:37 <tellesnobrega> I guess we can call the meeting
18:41:47 <tellesnobrega> thanks everyone
18:41:56 <tellesnobrega> welcome back egafford :}
18:42:17 <tellesnobrega> #endmeeting