18:00:11 <tellesnobrega> #startmeeting sahara
18:00:12 <openstack> Meeting started Thu Jun 22 18:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:15 <openstack> The meeting name has been set to 'sahara'
18:00:24 <zemuvier> hi
18:00:57 <jeremyfreudberg> o/
18:02:25 <tellesnobrega> waiting for people to show up
18:02:33 <jeremyfreudberg> tosky will be here soon
18:02:39 <tellesnobrega> yeah
18:04:15 <tosky> here I am
18:04:28 <tellesnobrega> #topic News/Updates
18:04:53 <tellesnobrega> I'm working on internal stuff as well as the image gen, CDH is ready for new reviews
18:05:24 <tellesnobrega> #link https://review.openstack.org/#/c/448712/
18:05:39 <tosky> apart from the internal stuff, I'm trying to test the current master with Sahara services deployed inside containers using TripleO
18:05:46 <tosky> (the feature landed few days ago)
18:05:55 <tellesnobrega> other than that, I'm working in iwona on the import and export of templates
18:06:10 <tellesnobrega> I will ask questions later about that
18:06:44 <jeremyfreudberg> I'm working on a few downstream requests. Some extra config option about proxy_command, some additional sahara-extra auth stuff. should be upstream for this release
18:07:46 <jeremyfreudberg> Also looking into Vanilla upgrade, but have some mild concerns about it, plus waiting for stable Hadoop 2.8.1 to land
18:08:26 <tosky> which kind of concerns (or maybe we can talk about them under a separate topic)
18:09:12 <jeremyfreudberg> mainly timeline concerns, about new CI and the HBase on Vanilla that yingya was working on
18:09:18 <jeremyfreudberg> a separate topic is probably better
18:09:35 <tenobreg> sorry, apparently my internet went down
18:09:38 <tenobreg> I'm back now
18:10:07 <tosky> uh, that may be a problem for closing the meeting (you should regain your identity)
18:10:15 <tenobreg> trying
18:10:34 <tenobreg> i will probably drop and I will change it later
18:10:40 <tenobreg> #chair tosky
18:10:53 <jeremyfreudberg> that should work
18:10:56 <tenobreg> not sure if I can set you as chair so you can close it
18:11:14 <jeremyfreudberg> you should be good now anyway
18:11:17 <tosky> you can't set me as chair until you are chair :)
18:11:21 <tellesnobrega> now I'm myself again
18:11:28 <tellesnobrega> :)
18:11:34 <tosky> I'd suggest to set someone else as chair right now
18:11:43 <tellesnobrega> #chair tosky
18:11:44 <openstack> Current chairs: tellesnobrega tosky
18:11:45 <tellesnobrega> just in case
18:11:56 <tosky> now it seems to work
18:11:58 <tosky> oki
18:12:23 <tellesnobrega> jeremyfreudberg, I missed most of what you said, so anytime you want a new topic to come up let me know and I will set it
18:12:30 <jeremyfreudberg> sure
18:12:38 <jeremyfreudberg> did you miss everything i said?
18:12:41 <jeremyfreudberg> or just some
18:12:54 <tellesnobrega> I just the last line
18:13:14 <tellesnobrega> saying it would be better on another topic
18:13:41 <jeremyfreudberg> yeah. My main update was "I'm working on a few downstream requests. Some extra config option about proxy_command, some additional sahara-extra auth stuff. should be upstream for this release". But then I want to spend a few minutes talking about logistics of Vanilla plugin upgrade
18:14:04 <tellesnobrega> sounds good
18:14:16 <tellesnobrega> quick topic about PTG
18:14:23 <tellesnobrega> #topic Queens PTG
18:14:36 <tellesnobrega> does anybody has news on being able to attend or not?
18:14:52 <tellesnobrega> most folks aren't here, but we haven't heard from zemuvier
18:15:13 <tellesnobrega> zemuvier, are you planning to attend PTG? does it depend entirely on TSP?
18:15:14 <zemuvier> yes, esikachev and I have been sent a request to travel support programm
18:15:35 <zemuvier> so I hope we can join this PTG
18:15:36 <tellesnobrega> great, let us know when you get updates
18:15:43 <zemuvier> sure
18:15:59 <tellesnobrega> thanks
18:16:08 <tellesnobrega> #topic Documentation Migration
18:16:21 <tellesnobrega> about this, not sure if you guys has a chance to read this spec
18:16:30 <tellesnobrega> #link https://review.openstack.org/#/c/472275/13
18:16:44 <asettle> Thank you, tellesnobrega
18:16:51 * asettle peaks in
18:16:58 <tellesnobrega> asettle, no worries
18:17:41 <tellesnobrega> basic idea is, project related documentation is being migrated back into project repo, there is a really detailed guideline on the spec on how this is being achieved
18:18:08 <jeremyfreudberg> I think that's fine by us, I think most of us tend to forget about sahara stuff in openstack-manuals anyway
18:18:13 <tellesnobrega> the goal is to finish phase 1 in pike iirc, (asettle feel free to jump in)
18:18:18 <tosky> so is it this about the installation/user documentation? Because we already have some documentation (developer) in the repository
18:19:20 <asettle> tosky: yes :)
18:19:30 <tellesnobrega> it is installation/user/contributors should be on sahara repo and cli info should be in python-saharaclient repo, I do think that we won't have a big problem with this
18:19:37 <asettle> The openstack-manuals team managers user and operator and contributor info :)
18:19:41 <asettle> Yeh, you got it tellesnobrega :)
18:20:42 <tellesnobrega> I want to know if anyone of is willing to take the lead on this (making sure it is where it should)
18:20:49 <tosky> oh, ok; I guess I need to read the spec, but is there something that will be done by the doc team which will have to start with? I mean, will they provide the list of things to be moved, and we moved from there?
18:21:09 <tosky> or we need to check all the bits that we have inside openstack-manuals?
18:21:14 <tosky> no problem in both cases, just to know
18:22:03 <tellesnobrega> tosky, it is already described on the spec
18:22:35 <tosky> ack
18:22:38 <tosky> time to RTFM
18:23:12 <tellesnobrega> basically yes
18:23:45 <tellesnobrega> for now I will be leading the effort, and if anyone wants to help out let me knoe
18:23:46 <tellesnobrega> know
18:26:01 <tellesnobrega> #topic Vanilla Plugin Upgrade
18:26:04 <tellesnobrega> jeremyfreudberg, you are up
18:26:10 <jeremyfreudberg> tellesnobrega, great
18:28:03 <jeremyfreudberg> So as everyone knows, plugin upgrade is high priority for every release. And it has been long time since Vanilla upgrade. I am looking into Hadoop 2.8.x and Spark 2.1.0 on Vanilla plugin for Pike. Some issues are 1) waiting for stable Hadoop 2.8.1 to release 2) getting some artifacts uploaded to sahara-files 3) waiting for new CI and 4) coordinating with Yingya about Hbase on Vanilla
18:28:26 <jeremyfreudberg> In particular #2 and #3 are good to discuss here
18:28:37 <tellesnobrega> ok
18:29:22 <tellesnobrega> so about #3, I'm waiting for response from red hat to see if we can get resources to deploy the new CI here, having a meeting with my manager soon and will ask if he got any responses
18:29:34 <tellesnobrega> about #2, what artifacts are we talking about?
18:29:53 <tosky> for #3 there is a possible alternative way: check how much infra resources can we (ab)use with a multinode jobs
18:30:16 <tosky> Vitaly nicely created a multinode Spark jobs, I suspect that a simple Vanilla jobs may not be too much resource-consuming
18:30:24 <tellesnobrega> tosky, true
18:30:26 <jeremyfreudberg> tosky, good points
18:30:27 <tosky> that can't probably scale for CDH or MapR
18:30:32 <tosky> but Vanilla, maybe
18:31:01 <jeremyfreudberg> tellesnobrega, about artifacts we definitely need new Oozie and new "Hadoop native libs"
18:31:07 <jeremyfreudberg> and maybe something else I'm forgetting
18:31:28 <tellesnobrega> tosky, we need to contact infra team to figure that out right?
18:31:35 <tosky> yep
18:31:55 <tellesnobrega> tosky, I know I ask this a lot to you, but can you ping infra team about that?
18:32:35 <tosky> I can
18:33:23 <tellesnobrega> tosky, thanks :)
18:33:28 <jeremyfreudberg> thanks tosky
18:33:45 <tellesnobrega> #action tosky to ping infra about how much resource we can use for vanilla testing on openstack ci
18:34:12 <tosky> (or push a review with a new a job and see what happens, while trying to look innocent)
18:35:27 <tellesnobrega> tosky, there is always that option
18:35:38 <tellesnobrega> jeremyfreudberg, abour sahara-files, it resides on mirantis right?
18:36:05 <jeremyfreudberg> yep, it is a mirantis domain pointing to their rackspace cloud storage
18:36:08 <tellesnobrega> jeremyfreudberg, it is still up, probably have to check with zemuvier how to send files there
18:36:33 <tellesnobrega> and if we can expect it to be running for a while
18:36:55 <jeremyfreudberg> yes, would be good to know.
18:37:08 <tellesnobrega> zemuvier, ^
18:37:26 <zemuvier> yes, i think it's still up, but i'm not sure
18:37:49 <zemuvier> i can find it out a little bit later
18:38:01 <tellesnobrega> thanks :)
18:38:06 <jeremyfreudberg> zemuvier, thanks
18:38:29 <tellesnobrega> #action zemuvier to look into sahara-files and figure out if will be kept running and how to upload new resources to it
18:38:33 <tellesnobrega> zemuvier, sounds good ^
18:38:34 <tellesnobrega> ?
18:39:05 <zemuvier> tellesnobrega: yes, okay :)
18:40:04 <tellesnobrega> thanks
18:40:05 <tosky> I thought that we already started pushing some resources outside sahara-files (apart from the images, which needs some changes in the storage amount)
18:40:26 <tosky> iirc we push something to tarballs.openstack.org
18:40:36 <jeremyfreudberg> actually, tosky has a good point, this stuff is small enough to push to infra-team managed tarballs site
18:40:44 <tellesnobrega> jeremyfreudberg, even better
18:41:21 <jeremyfreudberg> https://tarballs.openstack.org/sahara/dist/ would be the place
18:41:29 <tellesnobrega> jeremyfreudberg, perfect
18:41:43 <tellesnobrega> #link https://tarballs.openstack.org/sahara/dist/
18:42:25 <jeremyfreudberg> so I guess really the question is how to upload to there, and also have some migration plan?
18:44:11 <tellesnobrega> that sounds about right
18:44:27 <tellesnobrega> jeremyfreudberg, I will have you figure that out, sounds good?
18:44:47 <jeremyfreudberg> sure
18:44:48 <tosky> just check the history of the sahara jobs in project-config
18:44:54 <jeremyfreudberg> yep
18:46:59 <jeremyfreudberg> I believe it's https://review.openstack.org/#/c/367271/ ,fyi
18:47:23 <jeremyfreudberg> but I will certainly get as much info as I can
18:50:00 <tosky> that's for the publishing, yes; the build part was already there and you can find it easily from the job names
18:51:40 <jeremyfreudberg> yep
18:52:08 <tosky> as it is controlled by the script in sahara-extras, you may not even need a new job
18:52:47 <jeremyfreudberg> right
18:55:30 <jeremyfreudberg> tellesnobrega, anything else to discuss?
18:56:03 <tellesnobrega> not from me
18:56:15 <tosky> oh, just a note
18:56:42 <tosky> I suggested Telles to create some x.y.z tags at least for Ocata; sahara-image-elements have few changes
18:57:08 <jeremyfreudberg> makes sense to me
18:57:09 <tosky> maybe also for Newton (even if the end of phase 2, in one or two months, could be a good time too)
18:57:22 <tosky> oki :)
18:57:57 <tosky> nothing else from me
19:00:45 <jeremyfreudberg> tosky, end the meeting
19:01:31 <tosky> uh
19:01:34 <tosky> thanks all!
19:01:39 <tosky> #endmeeting