14:00:03 <tellesnobrega> #startmeeting sahara
14:00:03 <openstack> Meeting started Thu Dec  7 14:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'sahara'
14:00:15 <tosky> o/
14:01:16 <shuyingya> o/
14:01:42 <tellesnobrega> I believe there will be only us three today
14:01:56 <tellesnobrega> jeremy emailed me saying he couldn't make it
14:02:25 <tellesnobrega> so lets start
14:02:29 <tellesnobrega> #topic News/Updated
14:02:32 <tellesnobrega> #topic News/Updates
14:02:48 <tosky> can I quote my news update from the last meeting? :D
14:02:57 <tellesnobrega> yeah
14:03:04 <shuyingya> :)
14:03:08 <tellesnobrega> I'm almost finished with the sahara side of decommission of specific node
14:03:29 <tosky> working on internal testing, and keeping an eye on zuul changes; I'm waiting for two changes to land and than we can have native jobs in sahara-tests at least
14:03:39 <tellesnobrega> shuyingya, about your comment, I'm adding a validation step, so we can't add more instances than the difference from the current count and the new count
14:03:46 <tellesnobrega> does that make sense to you?
14:04:15 <shuyingya> I'm working on vanilla upgrade. most of time spend on image building because of Chinese network block. :(
14:04:27 <shuyingya> of course. That would be great
14:04:35 <tellesnobrega> awesome
14:04:55 <tosky> shuyingya: did you setup a reverse caching proxy?
14:05:35 <shuyingya> of course. but Chinese can't access google because of gov block
14:06:04 <tellesnobrega> shuyingya, is there anything we can do to speed up?
14:06:15 <tellesnobrega> like, creating the image and making it available to you?
14:06:18 <shuyingya> so I have to download some package through vpn
14:06:34 <shuyingya> I am almost finished it now:)
14:06:47 <tellesnobrega> shuyingya, good to hear
14:06:52 <tellesnobrega> let me know if you need help
14:07:00 <shuyingya> sure
14:07:25 <tellesnobrega> I need to start working on dashboard part of the decommission of specific node
14:08:25 <shuyingya> sounds good.
14:09:35 <shuyingya> I have a question. do you know how to upload the package ( oozie binary package and hadoop native libs) to tarball.openstack.org?
14:09:55 <tellesnobrega> hmm, tosky may know it
14:09:59 <tellesnobrega> I actually don't
14:10:06 <tellesnobrega> but I can ask around
14:10:17 <shuyingya> looks like we try to avoid use the old mirantis-file.com
14:10:34 <shuyingya> thanks :) tellesnobrega
14:10:45 <shuyingya> tosky, if you know, please let me know
14:10:45 <tellesnobrega> yeah, we should use tarballs
14:11:17 <tosky> I should almost know, but I didn't want to change the jobs (there is oozie to upload, yes) because there is a pending change in the way zuulv3 manages the upload
14:12:18 <tosky> but if it is urgent, next week (close to Christmas, and after New Year) I can try to patch something with the current process
14:12:41 <shuyingya> I can wait
14:13:21 <shuyingya> I can use my local server for testing
14:13:39 <tellesnobrega> great
14:13:41 <shuyingya> but if we merge the vanilla-2.8.2 image build patch, we have to upload it.
14:14:14 <tellesnobrega> #action tellesnobrega to send email to figure out how to upload files to tarballs.openstack.org
14:14:27 <shuyingya> :)
14:14:28 <tellesnobrega> shuyingya, you will see an email going around
14:14:38 <tosky> ack, if everyone agrees, can I have half of January as deadline for that? (just before Q-3)
14:15:18 <tellesnobrega> tosky, for what specifically? sending the files to tarballs?
14:15:32 <tosky> the way to send stuff there is basically a job; you just need to make sure that the build process on sahara-extra generates the artifact, and fix the job
14:16:01 <tosky> tellesnobrega: for fixing the job which uploads stuff on tarballs from sahara-extra
14:16:14 <tellesnobrega> that is fine
14:16:16 <tellesnobrega> :)
14:17:21 <tellesnobrega> anymore news?
14:18:38 <tellesnobrega> #topic Queens 2
14:19:09 <tellesnobrega> today I'm cutting q2, lets try to get as much stuff in as we can today, I will try to send a new patch on decommission after the meeting so you both can review
14:19:26 <tellesnobrega> I sent a patch for spark 2.2.0
14:19:35 <tellesnobrega> and storm 1.1.1 (image-generation only)
14:19:43 <tellesnobrega> I believe those are cool to merge
14:20:01 <shuyingya> I will review it later :)
14:20:24 <tellesnobrega> thanks
14:20:54 <shuyingya> 7 December is the deadline to cut Q2?
14:21:35 <tellesnobrega> yes
14:21:52 <tellesnobrega> #link https://releases.openstack.org/queens/schedule.html
14:22:20 <shuyingya> what is Membership Freeze?
14:22:46 <tellesnobrega> I believe it is for new projects to be affiliated under openstack umbrella
14:23:00 <tellesnobrega> under the current release
14:23:30 <tellesnobrega> rewording, deadline for projects to have at least 1 release in order to participate on the release
14:23:44 <shuyingya> got it :)
14:24:10 <tellesnobrega> I believe we can have a pretty good q2 release
14:25:14 <shuyingya> yes, you guys pay a lot of effort on it.
14:25:25 <tellesnobrega> all of us
14:25:27 <shuyingya> >V<
14:25:33 <shuyingya> haha
14:25:34 <tosky> yep, all :)
14:26:08 <tellesnobrega> ok, lets move on
14:27:12 <shuyingya> My leader asks me to apply dublin PTG travel support today, have you guys already applied it?
14:27:41 <tellesnobrega> shuyingya, we (from Red Hat) can't really apply, but I will be there
14:28:06 <tellesnobrega> company policy
14:28:24 <shuyingya> so bad :(
14:29:17 <tellesnobrega> it actually isn't, the idea is, we have a big company to pay for our trip, so lets not get money from people who really needs the support
14:31:07 <shuyingya> I misunderstood your meaning  :)
14:31:16 <tellesnobrega> :)
14:31:36 <tellesnobrega> #topic Open Discussion
14:31:50 <tellesnobrega> lets move to our last topic of the day
14:32:24 <tellesnobrega> I have a topic, I would like to know if we all agree on adding shuyingya to the core team
14:32:56 <tellesnobrega> he has shown a great knowledge of the code base, does great reviews and is always participating as much as possible
14:33:27 <tellesnobrega> tosky, shuyingya ^
14:33:38 <shuyingya> I have a good news to share with you that my team will get first POC in a university:)
14:34:03 <tellesnobrega> that is awesome, congrats shuyingya :)
14:34:09 <tosky> oh, I agree with adding shuyingya as core
14:34:13 <shuyingya> thanks, tellesnobrega.
14:35:06 <tellesnobrega> shuyingya, you deserve it. Have deserved for a while now, and being a advocate for Sahara in China makes you deserve a lot more
14:36:48 <shuyingya> I'm so excited to be in core team. I will try my best to make sahara more stable and prosperous
14:36:52 <shuyingya> :)
14:37:05 <tellesnobrega> that is great to hear
14:37:38 <tellesnobrega> I will send out the email today, and start working on making you core, if no one objects (which I doubt will happen
14:38:24 <shuyingya> thanks :) tellesnobrega tosky
14:38:37 <tellesnobrega> I guess that closes all my topics
14:38:46 <tellesnobrega> does anyone have anything else to discuss
14:38:47 <tellesnobrega> ?
14:39:30 <shuyingya> nothing from my side
14:40:02 <tosky> nothing from me; I will be definitely more chatty when the job status becomes clean
14:40:12 <tellesnobrega> Just to let you all know, jeremy is going to working on the saharaclient part of APIv2
14:40:20 <tosky> good news
14:40:40 <tellesnobrega> we all hoping you get it done :)
14:41:12 <tellesnobrega> ok guys, lets close for today and we get 20 minutes back
14:41:46 <shuyingya> bye
14:41:47 <tellesnobrega> thanks all
14:42:35 <tellesnobrega> #endmeeting