14:01:34 <tellesnobrega> #startmeeting sahara
14:01:38 <openstack> Meeting started Thu Mar 15 14:01:34 2018 UTC and is due to finish in 60 minutes. The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:41 <openstack> The meeting name has been set to 'sahara'
14:02:09 <tellesnobrega> I guess we are all here
14:02:15 <tellesnobrega> #topic News/Updates
14:02:20 <jeremyfreudberg> o/
14:02:25 <shuyingya> o/
14:02:54 <tellesnobrega> I'm currently working on plugins split from sahara core, I got a working version, probably need some more work
14:03:04 <jeremyfreudberg> i'll need to leave a bit early, maybe at 47-48 minutes past the hour, if we make it that far
14:03:04 <tellesnobrega> I'm also writing the spec for it right now
14:03:08 <shuyingya> I would like to introduce a new sahara contributor to you all :) zchkun
14:03:18 <tellesnobrega> that is great news shuyingya
14:03:23 <tellesnobrega> hi zchkun :)
14:03:25 <tellesnobrega> welcome
14:03:30 <jeremyfreudberg> awesome! welcome zchkun
14:03:36 <zchkun> hi all
14:03:57 <tosky> o/
14:04:05 <jeremyfreudberg> anyway, for my update, i'm working on the whole "admin manage everything" thing.... it's actually already coming along, i have a working prototype already (that was fast)
14:04:20 <tellesnobrega> jeremyfreudberg, great to hear :D
14:04:49 <tosky> I'm testing few patches (by Telles and Elise) that fixes the support for RHEL - and at least one is ready for merge
14:05:03 <tosky> as news: the storyboard migration is coming... tomorrow
14:05:10 <tosky> (if there are no issues)
14:05:11 <tellesnobrega> I think shuyingya just merged the soci* one
14:05:15 <shuyingya> I am working on finishing the tasks about hbase support. need install a master branch env to test patches.
14:05:25 <jeremyfreudberg> shuyingya, thanks for that
14:05:26 <shuyingya> tosky, cool
14:05:28 <tosky> or at least he tried to merge, because THE GATES ARE BROKEN!
14:05:36 <tellesnobrega> yes
14:05:48 <tosky> some regression happened, infra people are waiting for zuul people
14:06:34 <tellesnobrega> once this patch merges I'm proposing a few backports on it
14:07:24 <tellesnobrega> any more news? updates?
14:07:58 <tosky> in case people didn't notice (even if there is a report on the list), yesterday we had the virtual PTG
14:08:10 <tosky> to complement and complete few points from the in-person PTG
14:08:19 <tellesnobrega> I was going to talk about it on a separated topic
14:08:22 <shuyingy_> zchkun try to understand about hadoop 2.8.2 upgrade patches. He is going to do the hadoop 3.0.0 upgrade.
14:08:23 <tosky> ah, oki
14:08:42 <shuyingy_> does anyone want to work on 2.7.5 upgrade
14:09:10 <jeremyfreudberg> i can grab it
14:09:17 <tellesnobrega> thanks jeremyfreudberg
14:09:23 <shuyingy_> if not, I think it would be a great opportunity for zchkun to understand the step to upgrade
14:09:52 <tellesnobrega> if zchkun has the time and is willing to do it, that would be great
14:10:15 <jeremyfreudberg> yeah, i'd say it comes down to who has more time.... although i'm certainly happy to do it
14:10:19 <tellesnobrega> of course he can do it as a learning step and than work on 3
14:10:34 <zchkun> yes,I have
14:10:44 <tellesnobrega> so better option is
14:10:58 <tellesnobrega> zchkun, you take upgrade to 2.7.5 and if you need help you can reach out to jeremyfreudberg
14:11:01 <tellesnobrega> is that ok with you both?
14:11:15 <tellesnobrega> and shuyingy_ can also help out
14:11:18 <jeremyfreudberg> that sounds right to me
14:11:25 <zchkun> ok, no problem
14:11:32 <tellesnobrega> thanks
14:11:41 <jeremyfreudberg> thanks zchkun
14:11:41 <shuyingy_> :) thanks zchkun
14:11:52 <tellesnobrega> moving on to the next topic then
14:12:06 <tellesnobrega> #topic Dublin/Virtual PTG
14:12:26 <tosky> and for the future we should try to support minor versions (x.y.z) more and more for the same x.y of the plugin (if the plugin declares that it does not break the compatibility)
14:12:36 <tosky> (sorry)
14:12:45 <tellesnobrega> tosky, no problem
14:12:47 <tellesnobrega> that is true
14:13:26 <tellesnobrega> yesterday we held a virtual PTG to cover the topics that weren't fully covered in Dublin due to jeremyfreudberg not being able to make it (flight cancellations)
14:13:42 <tellesnobrega> the outcome of that can be found here
14:13:46 <tellesnobrega> #link https://etherpad.openstack.org/p/sahara-rocky-VIRTUAL-ptg
14:14:03 <tellesnobrega> the outcome of PTG is here:
14:14:08 <tellesnobrega> #link https://etherpad.openstack.org/p/sahara-rocky-ptg
14:14:46 <jeremyfreudberg> yes, and thanks all for participating, i think it was a success
14:14:47 <tellesnobrega> I have also written a summary of the PTG to openstack-dev, please read and ask question if necessary
14:15:35 <tellesnobrega> jeremyfreudberg, it was, we can think on working a couple more of those through out the cycle to keep tabs and sync
14:15:44 <tellesnobrega> things to think about it later on
14:15:55 <jeremyfreudberg> not a bad idea
14:16:11 <tosky> we can convert most of them in stories (with tasks) from next week, with storyboard
14:16:22 <tosky> if there is no story/bug yet
14:16:22 <tellesnobrega> tosky, yes
14:16:27 <jeremyfreudberg> +1
14:16:45 <tosky> the storyboard team will probably implement epics at some point - but for now we should leave just with stories and their tasks
14:16:52 <tellesnobrega> I guess we can close this topic and move on to talk about storyboard a little
14:16:58 <jeremyfreudberg> yup
14:17:01 <tellesnobrega> #topic Storyboard
14:17:27 <tellesnobrega> Not sure if you are all familiar with Storyboard, but it will be our new tracking system starting next week
14:17:49 <tellesnobrega> storyboard team is working on migrating sahara this friday so we can start monday
14:18:02 <tellesnobrega> bug numbers will remain the same from launchpad
14:18:20 <shuyingy_> tellesnobrega just my question.
14:18:35 <shuyingy_> where to find the bug number
14:18:45 <tellesnobrega> I recommend we all take some time to read storyboard documentation and learn about all the storyboard features so we can make the best of it
14:18:52 <tellesnobrega> shuyingy_, in storyboard?
14:18:55 <shuyingy_> yes
14:19:15 <shuyingy_> I should read the storyboard documentation first
14:19:25 <tellesnobrega> shuyingy_, as we all should for sure
14:20:09 <jeremyfreudberg> yes, and there are new commit message anchors as well
14:20:19 <tellesnobrega> shuyingy_, if you go to stories, the list shows the number before the name
14:20:19 <jeremyfreudberg> Story: (which will work the same as closes-bug, i think)
14:20:30 <jeremyfreudberg> and I think there is Task: as well
14:20:40 <jeremyfreudberg> not sure how partial and related bug will carry over (tosky?)
14:22:01 <SotK> Story: is meant to leave a comment on the story when the patch is sent/updated/merged, Task: updates the task status (to Review, and then to Merged)
14:22:20 <tosky> (SotK is from the storyboard team)
14:22:29 <SotK> Story: also links to the story when viewing the commit message in Gerrit
14:22:49 <SotK> (I say "meant to" as the commenting functionality is currently broken and being investigated)
14:22:58 <jeremyfreudberg> (we know SotK well from how many times they are accidentally pinged by tellesnobrega )
14:23:06 <tellesnobrega> true :)
14:23:14 <jeremyfreudberg> and the answer on related-bug partial-bug, how it will work on storyboard/
14:23:15 <jeremyfreudberg> ?
14:24:23 <SotK> I'm not familiar with what those two do in relation to Launchpad
14:24:55 * SotK reads
14:25:52 <tellesnobrega> basically they mark a patch partially fixes a bug, it doesn't mark it as done when merged but it shows up as part of the work
14:26:27 <SotK> sounds similar to what just including Story: and not Task: does
14:26:27 <tosky> well, maybe it means that we need to create more granular tasks
14:26:39 <tosky> or what SotK wrote
14:26:41 <jeremyfreudberg> yes, exactly, the bot will comment about a related patch / partial patch being proposed/merged, but not update the final open/closed result of the bug
14:26:49 <jeremyfreudberg> so pretty close to what SotK says, in fact
14:26:53 <tellesnobrega> cool
14:26:54 <SotK> yeah, having more granular tasks would be my recommendation here I think
14:26:55 <tellesnobrega> thanks SotK
14:27:05 <tellesnobrega> (this time was not accidental)
14:27:20 <SotK> since sb allows you to have more than one task (think bugtask in launchpad) against a given project
14:27:51 <SotK> but either approach is fine, whatever works best for you :)
14:27:59 <SotK> heh, yw
14:28:16 <jeremyfreudberg> thanks SotK
14:28:22 <tosky> thanks!
14:28:35 <tellesnobrega> #action all team to read up on storyboard documentation
14:28:52 <tellesnobrega> lets move on
14:29:02 <tellesnobrega> #topic Open Discussion
14:29:33 <tellesnobrega> I don't have anything specific to discuss here, anyone?
14:29:44 <jeremyfreudberg> i encourage everyone to vote on the S naming poll
14:30:05 <tellesnobrega> jeremyfreudberg, yes
14:30:10 <jeremyfreudberg> https://civs.cs.cornell.edu/cgi-bin/vote.pl?id=E_40b95cb2be3fcdf1&akey=8cfdc1f5df5fe4d3
14:30:22 <jeremyfreudberg> i proposed a few good ones (in my opinion)
14:30:54 <tellesnobrega> Summit will be held in Berlin, names are mostly in German, but some are nice
14:31:14 <jeremyfreudberg> yes, this is the first time we will have a name that really feels foreign
14:31:43 <jeremyfreudberg> (previously we had mitaka and ocata as foreign names but those didn't feel too foreign to me)
14:32:31 <jeremyfreudberg> any other topics to bring up now?
14:33:08 <shuyingy_> I don't have anything to talk here :)
14:33:11 <tosky> yes, just to be sure: vanilla/2.8.2 image generation, should we merge now and backport to queens? What did we decide? https://review.openstack.org/#/c/542184/
14:33:38 <tellesnobrega> tosky, good question
14:33:40 <jeremyfreudberg> it would be nice to backport, if that's kosher
14:33:57 <tellesnobrega> we can merge and backport it
14:34:31 <tosky> shuyingy_: any comment on ^^ (your patch :)
14:34:33 <tosky> ?
14:35:11 <shuyingy_> I think it is ready to merge. feel free to +2. haha:)
14:35:19 <tellesnobrega> we have 2.8.2 on queens, it is best to have it on SIE as well
14:35:28 <tellesnobrega> shuyingy_, done
14:35:46 <jeremyfreudberg> \o/
14:35:47 <shuyingy_> thanks, guys
14:35:57 <tosky> of course, after a recheck when the gates are fixed
14:36:27 <tellesnobrega> actually, my patch merged, so it might be fixed
14:36:29 <tellesnobrega> lets see
14:36:50 <tosky> oh
14:36:53 <tosky> it depends on the job
14:37:09 <tosky> devstack jobs (for sure devstack-tempest jobs) are affected
14:37:12 <jeremyfreudberg> the gate queue for SIE is basically a no-op, it's just pep8 (everything else is non-voting and therefore excluded)
14:37:16 <tosky> right
14:37:17 <tosky> oki
14:37:59 <tellesnobrega> anything else for today?
14:38:44 <jeremyfreudberg> nothing from me
14:39:19 <shuyingy_> me neither
14:39:52 <tellesnobrega> tosky?
14:40:00 <tosky> nothing from me
14:40:21 <tellesnobrega> I guess we can close for tday
14:40:27 <tellesnobrega> jeremyfreudberg, we did make it in time :)
14:40:31 <shuyingy_> see you
14:40:35 <jeremyfreudberg> yup
14:40:37 <jeremyfreudberg> thanks all
14:40:38 <tosky> o/
14:40:43 <tellesnobrega> thanks all
14:40:48 <tellesnobrega> see you
14:40:51 <tellesnobrega> #endmeeting