#openstack-meeting-alt: satori

Meeting started by zns at 15:00:04 UTC (full logs).

Meeting summary

  1. rollcall (zns, 15:00:34)
  2. Project kick-off (zns, 15:01:59)
    1. : https://blueprints.launchpad.net/satori/+spec/poc-commandline-parsing (zns, 15:02:29)
    2. https://blueprints.launchpad.net/satori/+spec/poc-dns-detection (zns, 15:02:29)
    3. https://blueprints.launchpad.net/satori/+spec/nova-instance-detection (zns, 15:02:29)
    4. https://wiki.openstack.org/wiki/Satori/OpinionsProposal (caleb_, 15:04:01)
    5. AGREED: include a base set of generic opinions in satori (zns, 15:05:51)

  3. Pushed 0.1.3 (zns, 15:06:09)
    1. ACTION: cgroom include a base set of generic opinions to spec (zns, 15:07:04)
    2. https://wiki.openstack.org/wiki/ProjectTypes (caleb_, 15:13:12)
    3. AGREED: we will use the gerrit workflow once in stack forge (not the github workflow) (zns, 15:17:04)

  4. Upcoming blueprints (zns, 15:17:18)
    1. https://blueprints.launchpad.net/satori/+spec/poc-system-info (zns, 15:17:36)
    2. https://blueprints.launchpad.net/satori/+spec/poc-resource-opinions (zns, 15:17:36)
    3. we will use gerritt workflow once in stackforge (gondoi, 15:17:53)
    4. AGREED: plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use (zns, 15:29:03)
    5. ACTION: ins implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use (zns, 15:30:11)
    6. ACTION: zns - that was autocorrect (zns, 15:30:53)
    7. ACTION: zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use (caleb_, 15:31:47)

  5. What features should be implemented before we announce to the User List? (zns, 15:32:25)
    1. http://satori.readthedocs.org/en/latest/ should probably also get some love. (caleb_, 15:39:40)
    2. AGREED: first plugin or two with a simple (one call) interface and then evolve into a plugin interface as/when needed (zns, 15:39:51)
    3. ACTION: gusmaskowitz Update user documentation in satori/doc (caleb_, 15:42:12)
    4. ACTION: jasonpgignac will update docs for pypi and http://satori.readthedocs.org/en/latest/ (zns, 15:42:16)
    5. ACTION: gondoi will update docs for pypi and http://satori.readthedocs.org/en/latest/ (zns, 15:43:48)
    6. ACTION: gusmaskowitz will update docs for pypi and http://satori.readthedocs.org/en/latest/ (zns, 15:44:09)
    7. http://guides.rubyonrails.org (jasonpgignac, 15:46:50)
    8. ACTION: samstav catch exceptions in CLI so we don't stack trace (consider --debug mode allowing exceptions through to allow for debugging) (zns, 15:52:59)

  6. Keeping an eye on https://wiki.openstack.org/wiki/PythonOpenStackSDK (zns, 15:53:24)
    1. AGREED: monitor openstackclient and adopt as it grows in popularity (zns, 15:57:24)


Meeting ended at 15:58:04 UTC (full logs).

Action items

  1. cgroom include a base set of generic opinions to spec
  2. ins implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use
  3. zns - that was autocorrect
  4. zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use
  5. gusmaskowitz Update user documentation in satori/doc
  6. jasonpgignac will update docs for pypi and http://satori.readthedocs.org/en/latest/
  7. gondoi will update docs for pypi and http://satori.readthedocs.org/en/latest/
  8. gusmaskowitz will update docs for pypi and http://satori.readthedocs.org/en/latest/
  9. samstav catch exceptions in CLI so we don't stack trace (consider --debug mode allowing exceptions through to allow for debugging)


Action items, by person

  1. gondoi
    1. gondoi will update docs for pypi and http://satori.readthedocs.org/en/latest/
  2. gusmaskowitz
    1. gusmaskowitz Update user documentation in satori/doc
    2. gusmaskowitz will update docs for pypi and http://satori.readthedocs.org/en/latest/
  3. jasonpgignac
    1. jasonpgignac will update docs for pypi and http://satori.readthedocs.org/en/latest/
  4. samstav
    1. samstav catch exceptions in CLI so we don't stack trace (consider --debug mode allowing exceptions through to allow for debugging)
  5. zns
    1. zns - that was autocorrect
    2. zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use
  6. UNASSIGNED
    1. cgroom include a base set of generic opinions to spec
    2. ins implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use


People present (lines said)

  1. zns (102)
  2. caleb_ (68)
  3. jasonpgignac (40)
  4. gondoi (20)
  5. samstav (18)
  6. __walker (8)
  7. walker_ (3)
  8. openstack (3)
  9. gusmaskowitz (2)


Generated by MeetBot 0.1.4.