#openstack-meeting-alt: satori

Meeting started by zns at 15:00:14 UTC (full logs).

Meeting summary

  1. Review Action Items (zns, 15:02:31)
    1. https://wiki.openstack.org/wiki/Satori/OpinionsProposal (caleb_, 15:03:48)
    2. https://github.com/rackerlabs/satori/pull/12 (caleb_, 15:07:21)
    3. ACTION: caleb_ to better document the choice of the word opinion (zns, 15:14:19)
    4. ACTION: gusmaskowitz Add Terminology page (zns, 15:16:40)
    5. ACTION: caleb_ add UUIDs to the opinions example (caleb_, 15:23:23)
    6. AGREED: use URI to identify resources (zns, 15:31:29)
    7. ACTION: caleb_ change opinions example to URI keys (caleb_, 15:32:11)
    8. ACTION: caleb_ write spec for rule-ids in opinions (like PEP and PYLINT rule numbers) calling it [something-]id to allow for future opinion identifiers (zns, 15:51:03)
    9. We're in stack forge! (zns, 15:53:51)
    10. ACTION: jasonpgignac - I will doc how to submit with the new system (jasonpgignac1, 15:54:29)
    11. ACTION: gusmaskowitz will update docs for pypi and http://satori.readthedocs.org/en/latest/ (zns, 15:56:41)
    12. ACTION: samstav catch exceptions in CLI so we don't stack trace (consider --debug mode allowing exceptions through to allow for debugging) + blueprint (zns, 15:56:58)
    13. ACTION: zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use (zns, 15:57:11)
    14. https://wiki.openstack.org/wiki/Gerrit_Workflow (gondoi, 15:59:45)


Meeting ended at 16:00:06 UTC (full logs).

Action items

  1. caleb_ to better document the choice of the word opinion
  2. gusmaskowitz Add Terminology page
  3. caleb_ add UUIDs to the opinions example
  4. caleb_ change opinions example to URI keys
  5. caleb_ write spec for rule-ids in opinions (like PEP and PYLINT rule numbers) calling it [something-]id to allow for future opinion identifiers
  6. jasonpgignac - I will doc how to submit with the new system
  7. gusmaskowitz will update docs for pypi and http://satori.readthedocs.org/en/latest/
  8. samstav catch exceptions in CLI so we don't stack trace (consider --debug mode allowing exceptions through to allow for debugging) + blueprint
  9. zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use


Action items, by person

  1. caleb_
    1. caleb_ to better document the choice of the word opinion
    2. caleb_ add UUIDs to the opinions example
    3. caleb_ change opinions example to URI keys
    4. caleb_ write spec for rule-ids in opinions (like PEP and PYLINT rule numbers) calling it [something-]id to allow for future opinion identifiers
  2. gusmaskowitz
    1. gusmaskowitz Add Terminology page
    2. gusmaskowitz will update docs for pypi and http://satori.readthedocs.org/en/latest/
  3. samstav
    1. samstav catch exceptions in CLI so we don't stack trace (consider --debug mode allowing exceptions through to allow for debugging) + blueprint
  4. zns
    1. zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use


People present (lines said)

  1. zns (83)
  2. caleb_ (52)
  3. adrian_otto (48)
  4. jasonpgignac1 (36)
  5. samstav (12)
  6. gusmaskowitz (10)
  7. gondoi (9)
  8. openstack (3)
  9. hhoover (1)


Generated by MeetBot 0.1.4.