#openstack-meeting-alt: satori

Meeting started by zns at 15:00:05 UTC (full logs).

Meeting summary

  1. Review Action List (zns, 15:01:35)
    1. ACTION: zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use (zns, 15:03:49)
    2. https://wiki.openstack.org/wiki/Satori/NamingUnnamedThings (zns, 15:04:20)
    3. https://review.openstack.org/#/c/79798/ (zns, 15:05:03)

  2. general discussion (zns, 15:06:51)
    1. We now gate on PEP-257, python 33, and pypy (zns, 15:09:38)
    2. 100% test coverage for ssh_module (zns, 15:09:55)
    3. https://github.com/jordansissel/fpm (walker_, 15:17:27)
    4. ACTION: samstav implement localhost blueprint. (zns, 15:19:29)
    5. https://pypi.python.org/pypi/novaclient-auth-secretkey (zns, 15:23:43)
    6. http://stackoverflow.com/questions/8874638/how-to-maintain-pip-install-options-in-requirements-file-made-by-pip-freeze (samstav, 15:26:14)
    7. ACTION: samstav spike into exploring plugin install options for https://blueprints.launchpad.net/satori/+spec/satori-minimal (zns, 15:28:11)

  3. Release Announcement (zns, 15:30:07)
    1. ACTION: zns file bug for satori not working with ip address (zns, 15:34:34)
    2. ACTION: gondoi find more relaxed novalent requirement (zns, 15:35:46)
    3. AGREED: criteria for announcement; fix DNS bug, localhost support, relaxed nova client dependency, and at least one data plane discovery plugin (ohai-solo most likely) (zns, 15:39:22)
    4. https://review.openstack.org/79058 (gondoi, 15:41:13)
    5. https://wiki.openstack.org/wiki/IRC (hhoover, 15:45:24)
    6. https://www.openstack.org/brand/ (walker_, 15:47:56)
    7. ACTION: caleb_ buy adrian_otto a beer (zns, 15:54:03)
    8. ACTION: caleb_ buy walker_ beer too (walker_, 15:54:30)
    9. AGREED: punt all branding decisions until we have addressed more use cases (no OpenStack logo yet) (zns, 15:56:31)


Meeting ended at 15:57:34 UTC (full logs).

Action items

  1. zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use
  2. samstav implement localhost blueprint.
  3. samstav spike into exploring plugin install options for https://blueprints.launchpad.net/satori/+spec/satori-minimal
  4. zns file bug for satori not working with ip address
  5. gondoi find more relaxed novalent requirement
  6. caleb_ buy adrian_otto a beer
  7. caleb_ buy walker_ beer too


Action items, by person

  1. adrian_otto
    1. caleb_ buy adrian_otto a beer
  2. caleb_
    1. caleb_ buy adrian_otto a beer
    2. caleb_ buy walker_ beer too
  3. gondoi
    1. gondoi find more relaxed novalent requirement
  4. samstav
    1. samstav implement localhost blueprint.
    2. samstav spike into exploring plugin install options for https://blueprints.launchpad.net/satori/+spec/satori-minimal
  5. walker_
    1. caleb_ buy walker_ beer too
  6. zns
    1. zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use
    2. zns file bug for satori not working with ip address


People present (lines said)

  1. zns (93)
  2. caleb_ (50)
  3. walker_ (21)
  4. samstav (19)
  5. gondoi (14)
  6. jasonpgignac (11)
  7. adrian_otto (6)
  8. annegentle (6)
  9. hhoover (6)
  10. openstack (3)
  11. gusmaskowitz (1)


Generated by MeetBot 0.1.4.