15:00:01 <zns> #startmeeting satori
15:00:02 <openstack> Meeting started Mon Mar 31 15:00:01 2014 UTC and is due to finish in 60 minutes.  The chair is zns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:05 <openstack> The meeting name has been set to 'satori'
15:01:07 <zns> Hi there -Who's here for satori?
15:01:12 <hhoover> o/
15:01:14 <gusmaskowitz> o/
15:01:17 <jasonpgignac> o/
15:01:17 <walker_> o/
15:01:34 <samstav> o/
15:01:53 <gondoi> o/
15:01:55 <zns> #topic action items
15:02:30 <zns> First two action items are mine. No update (sorry about that). I'll carry them over.
15:02:40 <zns> #action zns address possible duplication between 1295391 and 1293670
15:02:49 <zns> #action zns start ML discussion & blueprint for built-in python data plane discovery
15:03:03 <zns> gondoi: Fix pythonwhois?
15:03:27 <gondoi> fixed.. can't remember the status of the review though
15:03:29 <gondoi> let me look
15:03:49 <gondoi> looks like it's still open
15:03:50 <gondoi> https://review.openstack.org/82187
15:04:13 <gondoi> i know i've had discussions offline about adding ip_info and netloc_info to round out that review
15:04:13 <zns> Was there a pending update to that that you and I discussed?
15:04:24 <zns> Or is it ready?
15:04:37 <gondoi> currently ready as is
15:04:49 <gondoi> ip_info and netloc_info would be added functionality
15:05:06 <zns> OK. We can merge that in and discuss netloc_info and ip_info in a separate blueprint?
15:05:14 <gondoi> sounds good to me
15:05:21 <gondoi> i'll take the action to create the blueprint
15:05:37 <zns> #action zns, gondoi discuss netloc_info and ip_info - gondoi to create blueprint
15:06:07 <zns> caleb_ is not online yet, so carrying his action item forward.
15:06:14 <zns> #action caleb_ Developer docs for doing discovery using Python rather than the command line
15:06:29 <zns> #topic Agenda planning and time to read up/prepare
15:07:31 <zns> I got feedback from the last meeting that the discussion was too confusing. Multiple threads were being discussed at the same time and the topics were presented too late not allowing time to read up/discuss the topics.
15:08:20 <zns> So I'm proposing that we discuss what topics we want to discuss in next week's meeting in this meeting so we have some time to prepare, create wiki's, blueprints, etc...
15:08:23 <zns> Thoughts?
15:08:44 <gondoi> sounds good to me
15:08:47 <jasonpgignac> I would suggest that by the time the next meeting comes up many more things will have arisen?
15:09:01 <jasonpgignac> Would it be better to just have the agenda somewhere everyone can add items to it?
15:09:26 <jasonpgignac> Because as I recall, many of the items that bogged down last weeks meeting we wouldn't have even known about a week ahead of time.
15:09:30 <zns> jasonpgignac: true. But for there to be enough context for people to have constructive discussion at this meeting, we need to have some prep time.
15:10:00 <jasonpgignac> *nods* So, as soon as you know you want to discuss something in the meeting, I'd think, you should post it to the agenda.
15:10:09 <hhoover> agenda could be put up here? https://etherpad.openstack.org/
15:10:23 <jasonpgignac> I mean, if we realize on Thursday that there's something we should discuss on Monday… it doesn't really matter of we set an agenda the monday before, you know?
15:10:24 <zns> How about a cut-off (Thursday) for topics for the following Monday meeting?
15:10:55 <jasonpgignac> I would be fine with that, but I imagine the rule will get broken as soon as we have something 'urgent' come up
15:11:04 <gusmaskowitz> zns I think a killer use case for Satori is to dig into details and apply opinion to Openstack-on-Openstack (Tripple-O) deployments. Would like to contribute to make a blueprint
15:11:21 <zns> I have not seen anything urgent come up yet.
15:11:36 <jasonpgignac> K. Is fine with me. Agreed.
15:11:57 <samstav> Another rule: Nobody is allowed to call their topic urgent
15:12:02 <zns> #agreed topics for the Monday meeting must be added with context by the previous Thursday.
15:12:29 <zns> #action zns manage the agenda and the Thursday cut-off for topics.
15:13:03 <zns> #topic New Ideas
15:13:15 <hhoover> it should be a "rule" that people posting agenda items include their IRC nick
15:13:42 <zns> gusmaskowitz: I like that. It would be a great openstack use case to have satori be able to discover and vet (opinions) a devstack or openstack deploy.
15:14:29 <zns> gusmaskowitz: do you want to create a spec and blueprint and we discuss next Monday?
15:14:45 <gusmaskowitz> I dont know how to but would like to try.
15:14:54 <gusmaskowitz> so any help is deeply appreciated.
15:15:02 <zns> #action gusmaskowitz create a spec and blueprint for Triple-O
15:15:16 <zns> gusmaskowitz: reach out to me offline and I'd be happy to help.
15:16:06 <gondoi> i have some feedback i listed on the meeting wiki page
15:16:08 <zns> Does anyone want to own creating the context for any of the other items in https://wiki.openstack.org/wiki/Meetings/Satori#Agenda_for_next_meeting_.5B2014-03-31.5D?
15:16:27 <gondoi> refresh i put my nick next to it (per hhoover suggestion) :D
15:16:54 <gondoi> SSH output is "noisy" and there should be a shared connection to prevent too many logins and busy logs
15:17:33 <gondoi> want me to just list the rest here and we can dive into any we want and just create blueprints after for the next meeting?
15:18:16 <zns> How about adding blueprint/spec URLs next to these topic items and adding them to next weeks agenda (before Thursday :-) )? I can help with that too.
15:18:38 <gondoi> sounds good
15:18:58 <zns> #action gondoi adding blueprint/spec URLs next to these topic items and adding them to next weeks agenda (zns to help)
15:19:54 <zns> So I'll send out an email with topic items and links to the mailing list on Thursday so we have time to read up before next Monday.
15:20:33 <zns> hhoover: you suggested ether pad. Would that not be a duplicate of https://wiki.openstack.org/wiki/Meetings/Satori?
15:20:52 <hhoover> it would be. I withdraw my suggestion
15:20:58 <zns> Thanks.
15:21:30 <zns> So... anything else to discuss today that we all already have context on?
15:21:45 <zns> If not, we can close early...
15:22:16 <zns> Oh, funny, someone's nick is "early"...
15:22:28 <samstav> /NICK late
15:22:37 <zns> /NICK and
15:22:55 <zns> OK. Until next week then...
15:23:04 <zns> Thank you for attending!
15:23:10 <zns> #endmeeting