15:00:24 <samstav> #startmeeting satori
15:00:25 <openstack> Meeting started Mon Apr 28 15:00:24 2014 UTC and is due to finish in 60 minutes.  The chair is samstav. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:28 <openstack> The meeting name has been set to 'satori'
15:01:40 <samstav> Who's here for the satori meeting?
15:01:44 <caleb_> o/
15:01:45 <zns> I
15:02:18 <jasonpgignac1> o/
15:02:40 <samstav> Howdy all
15:02:56 <samstav> #topic Action Items
15:03:58 <zns> I still have not done: "start ML discussion & blueprint for built-in python data plane discovery". I need to look back at the meeting minutes to remember what that was. Sorry, been otherwise occupied.
15:04:34 <samstav> k
15:04:35 <caleb_> I have an action to write some developer docs. I'm going to convert that to an issue since I keep punting it from week-to-week.
15:04:42 <zns> #action zns start ML discussion & blueprint for built-in python data plane discovery
15:05:38 <samstav> ok caleb_
15:05:50 <zns> I have a topic I want to bring up, samstav, when we get to it...
15:05:53 <samstav> #action caleb_ Developer docs for doing discovery using Python rather than the command line
15:06:21 <samstav> Sure thing. The list was short so we can get right to it
15:07:49 <zns> The OpenStack summit is coming up fast. We're going to be there and we should talk about satori. But we don't have a very OpenStack-relevant story yet. Ideally, we should be able to use satori for a DevStack discovery. Two questions; do you all agree that a DevStack demo is important/essential? Second, if so, do we have the bandwidth to get it done.
15:09:01 <samstav> I think we have the bandwidth if we prioritize it. We can already do some very interesting discovery on openstack resources, maybe something more closely aligned with what we've already accomplished?
15:09:22 <caleb_> Explain more about what a DevStack demo would do, zns
15:09:53 <zns> Discover a devstack setup; list relevant services and whatever DevStack does today...
15:10:26 <zns> Sorry, whatever "Satori does today".
15:10:33 <caleb_> ok, so its basically data plane discovery on a DevStack VM
15:10:42 <caleb_> localhost or via SSH?
15:10:45 <zns> I guess so.
15:10:50 <samstav> From the perspective of satori walking into a dark room, what do you expect that it will see if a host is running devstack?
15:12:53 <zns> I don't think there would be much difference between localhost or SSH; in terms of amount of work. We could demo either...
15:14:32 <samstav> are you thinking about a devstack jinja template that is built to look through sys info for specific services & applications ?
15:14:35 <caleb_> samstav: database, api services, etc
15:15:28 <zns> samstav: there will be a bunch of listening services, rabbit mq, keystone, glance, etc... as well.
15:15:42 <zns> I think the demo would be most valuable if it included opinions as well..
15:17:05 <zns> ... but we'd need to finish the schema changes, maybe the localhost work, and then a first take on opinions...
15:18:47 <caleb_> I'm not certain that we have the time to pull that off
15:19:00 <jasonpgignac1> That's a pretty big chunk of work, for sure.
15:19:04 <samstav> Does it need to be an opinion?
15:19:08 <zns> BTW, the schema changes I might be able to get done this week.
15:19:15 <caleb_> Unless we do a hackday or two
15:19:26 <samstav> What about the template idea I mentioned?
15:19:48 <zns> I agree. That's why I'm bringing this up. Another alternative would be for us to set aside some time to get that done during the summit and maybe aim for a demo later in the week.
15:20:37 <zns> samstav: what would it be if it's not an opinion?
15:20:53 <zns> samstav: template idea?
15:20:56 <samstav> objective
15:21:20 <samstav> "a devstack jinja template that is built to look through sys info for specific services & applications ?"
15:21:39 <zns> Basically building opinions into the template?
15:22:09 <zns> That could work... but code in Jinja templates is ugly (look at the current template and try to decipher what it does...)
15:22:11 <samstav> That depends on… if they are actually opinions, or really just filtered sysinfo
15:22:38 <caleb_> zns, samstav: Let's plan on at least one full day hackday prior to the summit, say a week before. Then we can review our progress
15:22:43 <caleb_> and complete during summit if needed
15:22:44 <zns> caleb_: I like the hack day idea. You're thinking before the summit?
15:22:55 <caleb_> rgr
15:24:20 <samstav> caleb_ that sounds good. I'd be hesitant to force quickly moving on the satori repository, but perhaps we could fork satori or open a new satori-atlanta repository that requires satori, performs discovery, and the code we write during the hackday will be devstack specific
15:25:21 <zns> samstav: I share your concern about forcing code fast, but only if that means lowering the bar on quality. But if we hack together and produce tested, working code... then why not?
15:25:49 <zns> How about Wednesday for the hack day?
15:26:13 <samstav> ok
15:27:18 <zns> So, what I'm hearing, is we'd like to get code done for a decent demo at the summit?  I think that would go a long way towards having constructive conversations at the summit about where satori fits in the ecosystem...
15:27:42 <zns> otherwise we'd be taking about ideas and vaporware... suboptimal...
15:30:35 <samstav> luckily everyday is a hack day
15:30:50 <zns> Re-proposing hack day for Monday, 5th.
15:31:14 <caleb_> I like Monday
15:31:54 <samstav> you like Monday?
15:32:00 <samstav> then you'd hate this song. https://www.youtube.com/watch?v=zd3TpjWyVX0&feature=kp
15:33:18 <zns> Monday - Cinqo de Mayo Hack Day...
15:33:26 <samstav> excellent
15:33:33 <jasonpgignac1> We should bring Mexican hacksnacks
15:33:40 <samstav> DONE
15:34:33 <zns> samstav: add a couple of decisions to the meeting?
15:34:41 <samstav> # agreed Satori hackday on Monday, May 5th
15:34:53 <samstav> #agreed Satori hackday on Monday, May 5th
15:35:42 <samstav> #agreed create an openstack-relevant story by discovering devstack with satori
15:36:43 <samstav> Any other topics to discuss before we close?
15:38:05 <samstav> Alright. Thanks for joining. Until next time...
15:38:18 <samstav> #endmeeting