15:01:04 <samstav> #startmeeting satori
15:01:05 <openstack> Meeting started Mon Jun  2 15:01:04 2014 UTC and is due to finish in 60 minutes.  The chair is samstav. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <openstack> The meeting name has been set to 'satori'
15:02:20 <gondoi> o/
15:03:45 <samstav> Just gondoi and I at the satori meeting today?
15:04:01 <gondoi> hhoover: you here?
15:04:32 <hhoover> o/
15:05:17 <samstav> There's not much on the agenda
15:05:39 <gondoi> action item is zns too, and he's not making it
15:05:52 <gondoi> which mailing list was that going to be on? openstack-dev?
15:06:26 <gondoi> if so, I missed it
15:06:28 <samstav> openstack-dev is what I thought
15:06:40 <gondoi> okay
15:06:53 <gondoi> wanna action that one again for this week so we can review again
15:07:04 <gondoi> can't remember who all can action
15:07:35 <samstav> yeah, I don't think it went out. That action item has been pushed many times, and I think the perspective gained from Atlanta is still being considered
15:07:48 <gondoi> okay
15:07:58 <samstav> #action zns start ML discussion & blueprint for built-in python data plane discovery
15:08:49 <samstav> #topic windows support
15:11:22 <samstav> Nico and I have worked with the ohai windows implementation and have put together a working prototype for dataplane discovery on windows machines
15:11:36 <samstav> #link https://github.com/rackerlabs/posh-ohai
15:11:48 <gondoi> awesome
15:11:53 <gondoi> is nico aware of these meetings?
15:12:29 <samstav> I believe he attended one in the past…
15:12:38 <gondoi> okay
15:12:38 <samstav> I'll encourage him to join next week.
15:12:44 <samstav> more directly.
15:14:09 <samstav> Nico is currently working on a submission to satori which will include an extension to our RemoteShell module which enables the windows support.
15:14:32 <samstav> That working prototype can be found here
15:14:39 <gondoi> :+1:
15:14:44 <samstav> #link https://github.com/samstav/satori/tree/windows-support
15:15:15 <samstav> We are currently running that branch on an internal project
15:17:10 <samstav> and gondoi has +1'd that submission before it has even landed. Nico will be glad to hear that
15:18:49 <samstav> side note: The windows-support piece will only work on a remote windows box if it is running SMB on port 445
15:20:08 <samstav> and we are looking for folks to help with rackerlabs/posh-ohai and creating windows-specific opinions
15:24:28 <samstav> another side note, for the record, it would be preferable to join these modules using python code, *rather* than running the psexec communication through a process started using popen
15:24:31 <samstav> #link https://github.com/samstav/satori/blob/windows-support/satori/pse.py#L155-L159
15:24:51 <samstav> I have not looked into the feasibility of this yet.
15:25:31 <samstav> I'm not going to action item myself on that until after we get the first iteration of windows support into satori
15:26:21 <samstav> #topic general discussion
15:26:34 <samstav> Anything else?
15:28:15 <samstav> going once
15:28:21 <gondoi> nothing from me
15:28:47 <samstav> cool. thanks. that's it then. thanks for attending.
15:29:05 <samstav> until next week.
15:29:10 <samstav> #endmeeting