15:08:06 <samstav_> #startmeeting satori
15:08:07 <openstack> Meeting started Mon Jun 16 15:08:06 2014 UTC and is due to finish in 60 minutes.  The chair is samstav_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:10 <openstack> The meeting name has been set to 'satori'
15:09:42 <samstav_> Getting started late today. Anyone here for the Satori meeting?
15:09:45 <hhoover> o/
15:09:50 <walker_> o/
15:12:21 <samstav_> Alright. Nico mentioned he was busy, but I was hoping we could ask him how his submission was coming along. I know zns made a few comments and there was work to be done.
15:12:44 <walker_> This is in regards to the Windows stuff?
15:12:49 <samstav_> #action items
15:12:59 <samstav_> Yes that was in regards to Windows stuff.
15:14:53 <samstav_> @walker_ #link https://review.openstack.org/#/c/98383/
15:15:00 <walker_> thanks
15:15:24 <samstav_> I think that was the right one. I'm a bit fumbly on a mobile device.
15:17:21 <_sam_stav> As far as action items, we've had only two over the past month or so.
15:17:50 <_sam_stav> #action zns start ML discussion & blueprint for built-in python data plane discovery
15:18:44 <_sam_stav> I'll go ahead and add an action for Nico, WRT addressing the comments on his submission.
15:19:40 <walker_> sounds good
15:20:08 <_sam_stav> #action nick-o Address comments on submission 98383
15:20:36 <_sam_stav> #topic windows support
15:20:56 <_sam_stav> Would like to make a couple comments and bring some links forward.
15:21:39 <_sam_stav> I have used the psexec code through satori to do dataplane discovery on Windows boxes. So far we've had pretty good success with it.
15:22:09 <_sam_stav> That uses a rackerlabs repo called posh-ohai
15:22:31 <_sam_stav> #link https://github.com/rackerlabs/posh-ohai
15:22:58 <_sam_stav> For Windows this is analgous to ohai-solo for gathering system info
15:23:39 <_sam_stav> #link https://github.com/rackerlabs/ohai-plugins
15:23:41 <walker_> cool
15:24:23 <_sam_stav> This is maintained by Nico and I spoke with a Racker named Ryan Severson about getting involved too.
15:24:43 <_sam_stav> (Posh-ohai that is)
15:26:34 <_sam_stav> Some bits of the implementation for the Windows support piece could be improved. I'm going to assign myself to one part in particular
15:26:44 <_sam_stav> #link https://github.com/samstav/satori/blob/windows-support/satori/pse.py#L155-L159
15:28:05 <_sam_stav> #action samstav See about removing the subprocess call to another python module. Do this seamlessly inside pse.oh instead
15:28:28 <_sam_stav> This might be possible, and would be cleaner if so.
15:29:29 <_sam_stav> I have also heard a lot of chatter about WinRM
15:29:39 <_sam_stav> We''ll want to keep our eye on that.
15:30:01 <_sam_stav> For talking to Windows machines. Sounds like a better alternative to the psexec module.
15:31:13 <_sam_stav> #topic general discussion
15:32:42 <_samstav> #topic general discussion
15:33:18 <_sam_stav> Ok, I am not sure about my mobile IRC client situation. The bot may not be picking up my tags.
15:34:13 <walker_> Ok, well - I think we are in good shape for now. Let's wrap things up and hope next week is better technology-wise
15:34:14 <walker_> :)
15:34:40 <_sam_stav> Sounds good. Thanks .
15:35:36 <_sam_stav> Adios.
17:00:04 <sarob> Training on openstack-meeting
20:00:43 <openstack> redrobot: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
20:01:02 <redrobot> eh...  ?  meeting in progress?
20:01:36 <redrobot> #endmeeting