15:01:22 <samstav> #startmeeting satori
15:01:23 <openstack> Meeting started Mon Jul  7 15:01:22 2014 UTC and is due to finish in 60 minutes.  The chair is samstav. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:27 <openstack> The meeting name has been set to 'satori'
15:02:43 <samstav> Hi, who's here for satori?
15:02:46 <walker_> o/
15:03:07 <n1ck-o> me, too :)
15:03:59 <gondoi> o/
15:04:28 <samstav> Cool. Thanks for coming walker_ n1ck-o gondoi
15:04:51 <samstav> We'll start with action items on record.
15:04:58 <samstav> #topic action items
15:06:14 <samstav> I think zns will be back for next Monday's meeting, and we'll continue to push his action item forward.
15:06:18 <samstav> #action zns start ML discussion & blueprint for built-in python data plane discovery
15:08:18 <samstav> n1ck-o had an item related to submission 98383
15:08:27 <samstav> #link https://review.openstack.org/#/c/98383/
15:08:52 <n1ck-o> yes, I had a look at this last week
15:09:02 <n1ck-o> but have not been able to make much progress
15:10:07 <samstav> Cool. I think you pushed some updates on June 30th which got us very close to being done there
15:10:24 <n1ck-o> unfortunately the unit tests are failing
15:10:32 <n1ck-o> for some reason I can't tell
15:10:38 <n1ck-o> might need some help with that
15:11:09 <samstav> Right, I see that. I'll assign myself to help track that down
15:11:34 <n1ck-o> awesome, thanks
15:12:53 <samstav> #action samstav Determine cause of failing unitttests happening on submission 98383, AFAWK only on Gerrit's jenkins
15:14:19 <samstav> #link http://logs.openstack.org/83/98383/4/check/gate-satori-python27/1057ea1/console.html.gz
15:14:50 <samstav> traceback ends with ValueError: need more than 1 value to unpack from the pythonwhois module
15:15:46 <samstav> n1ck-o the action item was specifically for addressing the comments on the windows-support submission. Would you say that is done?
15:16:42 <n1ck-o> samstav: no, the stuff I pushed last week only addressed the lack of meaningful error messages, I'll look at the comments specifically this week
15:18:53 <samstav> Ok, cool. Thanks n1ck-o. I'm going to go ahead and push that item forward as well.
15:19:16 <samstav> #action n1ck-o Address comments on submission 98383
15:22:31 <samstav> n1ck-o you mentioned in another conversation that you were already looking at importing the psexec module instead of using a subprocess call to it. I had an action item assigned to myself to look into this as well. Will we try to accomplish this now, and have it included in the current submission, or will this come afterward?
15:24:54 <n1ck-o> hmmm, tough question
15:25:32 <samstav> Since we have seen moderate success with the current implementation, my vote would be that it come after.
15:25:46 <n1ck-o> yeah, I think that makes sense
15:25:52 <samstav> ok
15:28:34 <samstav> #action samstav Create a blueprint including details and motivation behind removing the subprocess calls in the windows support implementation
15:37:09 <samstav> walker_ mentioned that there were some features running in fork which need a game plan in satori
15:37:36 <samstav> ( referencing the Agenda at https://wiki.openstack.org/wiki/Meetings/Satori#Previous_meetings )
15:37:53 <walker_> Yes, specifically changing some code around using "su -" in instances where 'sudo' is not available
15:38:49 <samstav> Cool, thanks. walker_ I'll go ahead and action you for a blueprint on that.
15:38:57 <walker_> ty
15:40:21 <samstav> #action walker_ Create a blueprint for choosing the escalation prefix ("sudo" OR "su -" OR ?) when running commands in ssh.py
15:41:18 <samstav> Are there any other features in fork we need to address? I believe it was just the escalation command and the windows support.
15:41:40 <walker_> I think that's all for now
15:42:46 <samstav> Unless there's a need for general discussion, I think that covers everything. Any objections to closing up?
15:43:38 <n1ck-o> nothing from me at this point
15:44:42 <samstav> Cool. Thanks walker_, gondoi, n1ck-o, for participating. Until next week..
15:44:49 <samstav> #endmeeting