15:00:12 <zns> #startmeeting satori
15:00:15 <openstack> Meeting started Mon Jul 28 15:00:12 2014 UTC and is due to finish in 60 minutes.  The chair is zns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <openstack> The meeting name has been set to 'satori'
15:01:30 <zns> Hi! Who's here for the satori meeting?
15:01:33 <samstav> o/
15:01:34 <walker_> o/
15:01:36 <walker_> ohai
15:01:43 <zns> solo :-)
15:01:49 <n1ck-o> o/
15:02:26 <zns> I promised a short meeting last week and we ended up taking the whole hour. So no promises today. Let's get started...
15:02:32 <zns> #topic Action Items
15:02:38 <zns> walker_ - Create a blueprint for choosing the escalation prefix ("sudo" OR "su -" OR ?) when running commands in ssh.py?
15:03:26 <walker_> #link https://blueprints.launchpad.net/satori/+spec/allow-non-sudo-escalation
15:03:57 <zns> Great, thanks.
15:03:58 <zns> samstav: 98383 and 106134 - I think those are almost ready for merge, right?
15:05:03 <samstav> yes, very close on 98383
15:05:10 <samstav> +2'd 106134
15:05:24 <zns> Great. Forward progress. Thanks.
15:05:33 <zns> Action items d and e don't look like real action items, are they? Refs to asyncio and event let.monkey_patch. walker_ , samstav ?
15:06:24 <samstav> I think those were just contextual links during the action items discussin
15:06:37 <zns> OK.
15:06:46 <samstav> Oh, sorry zns.
15:07:04 <samstav> I referenced the wrong submission #
15:07:28 <samstav> 106134 is abandoned (merged into 98383)
15:07:36 <zns> #topic general discussion
15:07:48 <samstav> But I +2'd 103612
15:08:27 <zns> And I think the Windows Support one has some minor fixes (spelling, style) and it will then pass. So very close.
15:08:47 <zns> So, when Windows support goes in, we should probably cut a new release to pypi.
15:09:07 <zns> n1ck-o: did your changes to impact also get submitted upstream?
15:09:15 <zns> impacket
15:10:17 <n1ck-o> well, it wasn't really a code change, I just changed one of the examples
15:10:17 <zns> I.e. should we expect them to get merged upstream or should we vendor that into the satori repo (can we? licensing?)
15:10:25 <n1ck-o> so unsure if they will merge if we ask
15:11:04 <n1ck-o> I think once we move the psexec.py stuff into satori there is no need to use my clone of impacket anymore
15:11:15 <samstav> ... I think I missed something. If it was just a change to the example, why do we have to depend on the fork?
15:11:47 <n1ck-o> well, the example is part of impacket
15:11:57 <n1ck-o> and that's how it was imported in psexec.py
15:12:50 <samstav> ah, I see.
15:12:52 <n1ck-o> https://github.com/samstav/satori/blob/bp/windows-support/satori/contrib/psexec.py#L34 see here
15:12:58 <n1ck-o> I don't like it either
15:13:35 <n1ck-o> and if you guys think it's cleaner to not import from impacket.examples I'm happy to rewrite that serviceinstall module
15:13:42 <zns_> Sorry - got disconnected. Did you get: Oh - so satori would work with upstream impacket?
15:13:43 <n1ck-o> which we will end up doing anyway I suppose
15:13:57 <n1ck-o> no, i didn't get that
15:14:48 <n1ck-o> but yes, once we move the stuff from psexec.py into satori, satori would work with upstream impacket again
15:15:00 <zns_> If we package satori with git dependencies, then it won't install without git. That's currently not a dependency.
15:15:25 <zns_> Sounds like we should do that.
15:15:36 <zns_> Before curting a pypi release.
15:15:41 <zns_> cutting
15:16:30 <samstav> Hey n1ck-o, sorry, can you remind me what you mean by "move the stuff from psexec.py into satori" ?
15:17:30 <n1ck-o> well, not call psexec.py via subprocess anymore
15:18:06 <samstav> Ok, I remember that. How does that change whether we will need the fork or not?
15:18:18 <zns_> n1ck-o: is the needed to remove the dependency on your fork of impacket or is that a separate change/optimization?
15:18:32 <n1ck-o> this can be separate really
15:18:46 <n1ck-o> if we just don't use impacket.examples.serviceinstall
15:19:05 <n1ck-o> but rewrite this to be a class inside satori
15:19:09 <zns_> You would bring that code into satori only.
15:19:10 <n1ck-o> or module
15:19:16 <n1ck-o> yes
15:19:18 <samstav> ok, cool.
15:19:29 <zns_> Cool. Should that be part of the current review?
15:19:37 <zns_> or patch...
15:19:42 <n1ck-o> no, I would make that a new one to be honest
15:20:37 <zns_> OK. So we cut a release until that comes in. Is it OK to give you an action item on that?
15:21:04 <zns_> "don't" cut a release, I meant
15:21:26 <n1ck-o> sure, that was the next thing I was going to work on anyway
15:22:34 <zns_> #action n1ck-o rewrite serviceinstall into satori and remove dependency on git.
15:23:02 <samstav> we need a name for those
15:23:06 <samstav> gitpendencies
15:23:38 <zns_> :)
15:24:16 <zns_> Any other topics to discuss?
15:25:17 <zns_> Going once...
15:25:24 <zns_> Are we done for today?
15:25:31 <samstav> I think so
15:26:21 <n1ck-o> nothing else from me
15:26:41 <zns_> Cool. Just for expectation setting, I think once we get the Windows support in we'll need to talk about roadmap and what we want/need to do next.
15:26:50 <zns_> Thank you, all
15:26:53 <zns_> #endmeeting
17:04:28 <catherine_d> hello, Is there refstack meeting going on now?
17:06:55 <openstack> davidlenwell: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
17:07:17 <davidlenwell> #endmeeting