18:04:52 <SergeyLukjanov> #startmeeting savanna
18:04:53 <openstack> Meeting started Thu Jun 20 18:04:52 2013 UTC.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:04:57 <openstack> The meeting name has been set to 'savanna'
18:05:00 <SergeyLukjanov> hi everyone
18:05:01 <SergeyLukjanov> who is around?
18:05:16 <aignatov3> hi
18:05:28 <nkonovalov_> hi
18:06:22 <SergeyLukjanov> not sure we'll have all guys that we need are here...
18:06:26 <akuznetsov> hi
18:06:29 <Nadya> hi
18:06:44 <SergeyLukjanov> let's wait for several mins
18:08:01 <SergeyLukjanov> ok, let's start from the agenda
18:08:22 <SergeyLukjanov> #topic Agenda
18:08:22 <SergeyLukjanov> #info UI updates
18:08:22 <SergeyLukjanov> #info Savanna core updates
18:08:22 <SergeyLukjanov> #info Vanilla plugin updates
18:08:22 <SergeyLukjanov> #info Swift integration updates
18:08:22 <SergeyLukjanov> #info HDP plugin updates
18:08:23 <SergeyLukjanov> #info Other updates
18:08:23 <SergeyLukjanov> #info General discussion
18:08:36 <SergeyLukjanov> #topic UI updates
18:08:55 <SergeyLukjanov> Nikita, please
18:09:21 <nkonovalov_> Most UI components are ready and now wear working on appereance improvements
18:09:39 <nkonovalov_> Also bug fixing is in progress
18:10:16 <SergeyLukjanov> that's all from you side?
18:10:25 <nkonovalov_> yes, I think so
18:10:33 <SergeyLukjanov> ok, let's move on
18:10:43 <aignatov3> is thee any opened issues?
18:10:46 <aignatov3> *there
18:10:55 <aignatov3> we should discuss
18:11:39 <nkonovalov_> the default values for node_group_tmplate configurations are on review stage
18:12:03 <nkonovalov_> and the detailed cluter info page is to be done
18:12:44 <aignatov3> good
18:12:49 <nkonovalov_> theese are actually areas for improvements
18:13:00 <SergeyLukjanov> ok, thank you, the next topic is the core side
18:13:01 <SergeyLukjanov> #info Savanna core updates
18:13:08 <SergeyLukjanov> I'll make some updates on it
18:13:31 <SergeyLukjanov> #info basic implementation of 'convert' method is available
18:13:44 <SergeyLukjanov> w/ REST API and UI parts
18:14:16 <SergeyLukjanov> #info all cluster creation flows are now supported (w/ and w/o templates) in REST API
18:15:01 <SergeyLukjanov> #info fqdn has been added to the /etc/hosts (just very simple implementation, issue for the improvement has been fired)
18:15:57 <SergeyLukjanov> I think that's all about core part
18:16:11 <SergeyLukjanov> the next topic is vanilla plugin
18:16:13 <SergeyLukjanov> #info Vanilla plugin updates
18:16:15 <aignatov3> ok, the next part is mine
18:16:18 <SergeyLukjanov> Alex please
18:16:21 <aignatov3> thx
18:16:44 <aignatov3> vanilla plugin has been merged last week to the main savanna repo
18:17:47 <aignatov3> so, it repeates  all logic from savanna 0.1
18:18:13 <SergeyLukjanov> and just more
18:18:28 <aignatov3> configurations parameters are returned through the REST in the correct way
18:18:36 <SergeyLukjanov> it's no supports for the different topologies
18:18:40 <SergeyLukjanov> now* :)
18:19:09 <aignatov3> Hadoop parameters  now are devided into more important configs and less important
18:20:03 <aignatov3> Now vanilla plugin is able to run defferent hadoop processes in different VMs each
18:20:56 <aignatov3> regrding configs again
18:21:16 <aignatov3> all configs can be modified in the Dasboard
18:21:25 <aignatov3> *savanna dashboard
18:21:34 <aignatov3> and exposed to Hadoop nodes
18:21:46 <aignatov3> and be applied as you want
18:21:51 <aignatov3> :)
18:21:55 <SergeyLukjanov> aignatov3, does it supports single node installation?
18:22:38 <SergeyLukjanov> I mean all-in-one cluster
18:22:48 <aignatov3> Ssure, all hadoop services can be run in the one node
18:23:43 <SergeyLukjanov> ok, thank you, let's go on
18:23:49 <SergeyLukjanov> the next topic is swift
18:23:56 <aignatov3> yes, I'm done
18:23:58 <SergeyLukjanov> #info Swift integration updates
18:24:13 <SergeyLukjanov> Nadya please
18:24:24 <Nadya> swift support is integrated to savanna-core and to vanilla-plugin
18:25:01 <SergeyLukjanov> that's great :)
18:25:04 <Nadya> I think this activity is over :)
18:25:16 <aignatov3> Swift Vanill configurations are defined as "Enable/Disable Swift integration"
18:25:29 <SergeyLukjanov> ok, thank you
18:25:33 <SergeyLukjanov> #info HDP plugin updates
18:25:53 <SergeyLukjanov> there are no any guys here from the HDP team
18:26:11 <SergeyLukjanov> so, I'll try to shortly update status of their plugin
18:26:33 <SergeyLukjanov> change request has been published
18:27:06 <SergeyLukjanov> we are working together on checking it and planing to merge it in asap
18:27:23 <SergeyLukjanov> #link https://review.openstack.org/#/c/33455/
18:27:41 <SergeyLukjanov> that's all about HDP plugin
18:27:42 <SergeyLukjanov> #info Other updates
18:27:57 <SergeyLukjanov> are there any other updates?
18:28:05 <Nadya> yes
18:29:04 <Nadya> As far as swift is integrated we've started to work on cluster-scaling
18:29:26 <SergeyLukjanov> on the manual scaling now
18:29:27 <Nadya> blueprint is published and will be updated soon
18:29:46 <aignatov3> yes. we have more blueprints
18:29:48 <SergeyLukjanov> #link https://blueprints.launchpad.net/savanna/+spec/manual-cluster-scaling
18:30:13 <aignatov3> vanilla hadoop installation from scratch
18:30:21 <aignatov3> bp is here
18:31:37 <aignatov3> #link https://blueprints.launchpad.net/savanna/+spec/vanilla-hadoop-from-scratch
18:32:53 <mattf> aignatov3, that's about install/setup of hadoop post-boot?
18:32:54 <aignatov3> also we jave merged diskimage-cuilder instructions for Ubuntu into savanna-extra
18:33:22 <aignatov3> mattf, yes
18:34:14 <aignatov3> we are working on fedora image instructions as well
18:34:37 <aignatov3> all instructions are targeted to workwith savanna 0.2)
18:35:24 <SergeyLukjanov> there are several action items from the previous meetings
18:35:43 <SergeyLukjanov> first of all - update sample conf
18:36:02 <SergeyLukjanov> I've updated the sample config and it's now correlates w/ savanna configuration
18:36:15 <SergeyLukjanov> the next action item - Erik to update bp
18:36:22 <SergeyLukjanov> it's still actuall
18:36:33 <SergeyLukjanov> #action Erik/Jon/John to update HDP plugin blueprint description and status
18:36:44 <SergeyLukjanov> #link https://blueprints.launchpad.net/savanna/+spec/apache-ambari-service-provider
18:37:03 <SergeyLukjanov> mm, I think that's all about action items
18:37:26 <SergeyLukjanov> I think there is no other updates
18:37:29 <SergeyLukjanov> #info General discussion
18:38:34 <SergeyLukjanov> are there any questions?
18:40:00 <aignatov3> yes
18:40:56 <aignatov3> can we rename Config property in instances.py from 'is_optional' to 'required'?
18:41:28 <SergeyLukjanov> could you please write some pros of it?
18:42:03 <aignatov3> yes'
18:43:38 <aignatov3> 1.Dasboard works with this name 'required'. So I woould have th unique naming
18:44:59 <aignatov3> 2. Intuitively I always think about name of this field as required)
18:45:37 <SergeyLukjanov> Nikita, how many changes we should do on UI side to update it?
18:45:57 <nkonovalov_> Not much
18:46:13 <nkonovalov_> just some field renaming
18:46:29 <SergeyLukjanov> ok, great
18:47:04 <aignatov3> If you want we can vote for renaming)
18:47:18 <SergeyLukjanov> Alex, could you, please, create separated CR for it and we can discuss it more in it
18:47:56 <SergeyLukjanov> are there any other questions?
18:47:57 <aignatov3> ok, thx. will do that
18:48:26 <SergeyLukjanov> If not, I think it's about time to end our meeting
18:48:48 <SergeyLukjanov> #info JFYI you can always use savanna-all@lists.launchpad.net mailing lists and #savanna irc channel to find us and ask your questions
18:48:54 <SergeyLukjanov> #endmeeting