18:07:10 <SergeyLukjanov> #startmeeting savanna
18:07:11 <openstack> Meeting started Thu Oct 10 18:07:10 2013 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:07:14 <openstack> The meeting name has been set to 'savanna'
18:07:28 <SergeyLukjanov> #topic Agenda
18:07:28 <SergeyLukjanov> #info Action items from the last meeting
18:07:28 <SergeyLukjanov> #info Code freeze
18:07:28 <SergeyLukjanov> #info News / updates
18:07:28 <SergeyLukjanov> #info Roadmap cleanup / update
18:07:29 <SergeyLukjanov> #info Design Track sessions
18:07:30 <SergeyLukjanov> #info General discussion
18:07:43 <SergeyLukjanov> #topic Action items from the last meeting
18:08:17 <SergeyLukjanov> #info ACTION: all to find and fix gaps in the docs for 0.3 release
18:08:27 <SergeyLukjanov> looks like it is in the WIP state
18:08:37 <SergeyLukjanov> #action all to find and fix gaps in the docs for 0.3 release
18:08:55 <SergeyLukjanov> #info ACTION: all to check their blueprints and update their descriptions and statuses
18:09:09 <SergeyLukjanov> #info https://blueprints.launchpad.net/savanna
18:09:17 <SergeyLukjanov> https://blueprints.launchpad.net/savanna/0.3
18:09:29 <SergeyLukjanov> not all bps are resolved...
18:09:49 <aignatov_> that's not good
18:10:03 <SergeyLukjanov> yeah, let's ckear them till tomorrow
18:10:06 <SergeyLukjanov> clear*
18:10:46 <SergeyLukjanov> #info [DONE] ACTION: ruhe to create root documentation blueprint and add work items to it
18:11:03 <SergeyLukjanov> #topic Code freeze
18:11:40 <SergeyLukjanov> due to the some open bugs and not resolved blueprint I'll push rc3 tag at this weekend and it'll be the code freeze barrier
18:12:11 <SergeyLukjanov> please, land all your CRs (not docs) till the Friday evening
18:12:12 <aignatov_> can docs creating task be postponed?
18:12:17 <aignatov_> ok
18:12:31 <SergeyLukjanov> yep, docs could be merged till the 0.3 tag
18:12:56 <SergeyLukjanov> #info rc3 tag at this weekend and it'll be the code freeze barrier
18:13:12 <aignatov_> tmckay, so we should work on the several bug in edp tommorow
18:13:14 <aignatov_> not docs
18:13:15 <SergeyLukjanov> any questions?
18:13:35 <SergeyLukjanov> ok, let's move on
18:13:39 <SergeyLukjanov> #topic News / updates
18:13:42 <SergeyLukjanov> folks, please
18:14:31 <crobertsrh> First pass at UI doc is up for review.  Please let me know if you want any tweaks or additional info.
18:14:48 <SergeyLukjanov> btw here is a checklist - https://launchpad.net/savanna/+milestone/0.3
18:14:51 <aignatov_> since  we have created bp on docs creating for 0.3, me, tmckay and crobertsrh have stqarted working on this
18:15:33 <SergeyLukjanov> rc2 tag is already in repo
18:15:46 <SergeyLukjanov> it consists of dashboard that uses savanna client
18:16:01 <SergeyLukjanov> and integration tests that do the same thing ;)
18:16:09 <SergeyLukjanov> btw release page - https://github.com/openstack/savanna/releases
18:16:12 <SergeyLukjanov> #info https://github.com/openstack/savanna/releases
18:17:11 <SergeyLukjanov> #info https://wiki.openstack.org/wiki/Savanna/0.3_Release_Schedule
18:17:19 <aignatov_> I see that we have some interesting thing on the review ;)
18:18:13 <SergeyLukjanov> any other updates?
18:18:17 <aignatov_> #link https://review.openstack.org/#/c/50720/
18:18:44 <aignatov_> this is plugin for IDH! Wow!
18:19:28 <SergeyLukjanov> let's move on
18:19:31 <SergeyLukjanov> #topic Roadmap cleanup / update
18:19:33 <jmaron> making progress on neutron private network/namespace support
18:19:40 <SergeyLukjanov> #info https://wiki.openstack.org/wiki/Savanna/Roadmap
18:19:55 <SergeyLukjanov> nothing to update in roadmap from my side
18:20:35 <SergeyLukjanov> looks like no updates here today
18:20:42 <ruhe_> moment please
18:20:48 <SergeyLukjanov> #topic Design track sessions
18:21:07 <SergeyLukjanov> all of you know that we have 4 slots at Design Summit this November
18:21:15 <SergeyLukjanov> Nov 8
18:21:22 <SergeyLukjanov> 4 x 40 mins
18:21:32 <SergeyLukjanov> there are some proposed themes to dicsuss
18:21:42 <SergeyLukjanov> #info http://summit.openstack.org
18:21:56 <SergeyLukjanov> anyone can propose additional themes to dicsuss
18:22:22 <ruhe_> in addition to roadmap topic
18:22:41 <ruhe_> i don't see anything related to ceilometer, devstack and tempest integration
18:22:51 <jmaron> neutron support
18:23:06 <SergeyLukjanov> any suggestion about things to discuss at design summit in addition to the http://summit.openstack.org ?
18:23:09 <jmaron> (provisioning over private nets)
18:23:37 <aignatov_> jmaron, neutron support you mean to add to design tracks or to roadmap?
18:23:46 <jmaron> design tracks
18:24:12 <SergeyLukjanov> jmaron, please add a proposal for it http://summit.openstack.org
18:24:20 <ruhe_> SergeyLukjanov, can i add those items to roadmap myself?
18:24:20 <aignatov_> could you please send a topic aand some description at summit.openstack.org?
18:24:25 <SergeyLukjanov> ruhe_, lgtm to add them to the roadmap
18:24:34 <ruhe_> ok, will do
18:24:52 <jmaron> also - architecture enhancements to deal with service dependencies  - certain services/components require others but there is no current mechanism for doing that
18:25:37 <jmaron> at least automatically (beyond validation which doesn't really kick in till cluster creation and requires backtracking)
18:25:43 <SergeyLukjanov> ruhe, I think that there is no need to vote for it due to the need to integrate with them to become integrated project :)
18:26:11 <SergeyLukjanov> jmaron, please, add a proposal for it too
18:26:28 <jmaron> I think I'll stop mentioning things now ;)
18:26:32 <ruhe_> i like performance topic suggested by mattf
18:26:37 <aignatov_> jmaron, that's great topci, coould you propose it as well?
18:26:42 <SergeyLukjanov> ruhe_,yeah, +1
18:26:45 <aignatov_> me too, ruhe
18:26:51 <SergeyLukjanov> http://summit.openstack.org/cfp/details/215
18:27:42 <ruhe_> so many topics...
18:27:52 <ruhe_> SergeyLukjanov will you choose 4 of them?
18:27:58 <ruhe_> or it should be a vote?
18:28:36 <SergeyLukjanov> no, I'll prioritize them and merge important proposals to 4 sessions
18:29:01 <SergeyLukjanov> #info https://wiki.openstack.org/wiki/Summit
18:29:17 <SergeyLukjanov> ^^ is a short description of how design summit works
18:30:22 <SergeyLukjanov> I'm planning to start doing in the middle of the next week
18:30:48 <mattf> SergeyLukjanov, we should send you our topic votes?
18:31:38 <SergeyLukjanov> for now I see following sessions (very high-level): architecture, edp, roadmap/goals and others
18:32:09 <SergeyLukjanov> mattf, no, you should send proposals
18:33:00 <mattf> ok
18:33:25 <SergeyLukjanov> here is an announcement of design summit in Hong Kong from ttx with some details
18:33:27 <SergeyLukjanov> #info http://lists.openstack.org/pipermail/openstack-dev/2013-September/014601.html
18:33:34 <ruhe_> i guess we can give our votes in the topic comments
18:34:07 <ruhe_> at least for SergeyLukjanov to consider
18:34:27 <SergeyLukjanov> yeah, good idea
18:34:55 <SergeyLukjanov> #info Savanna Design Summit schedule  1:30 - 2:10, 2:20 - 3:00,  3:10 - 3:50,  4:10 - 4:50
18:35:54 <mattf> could setup a multi-winner vote like our ptl vote
18:36:08 <mattf> output of vote is input to SergeyLukjanov. output is not a decision.
18:36:52 <SergeyLukjanov> let's do it couple of fix before the summit
18:37:00 <SergeyLukjanov> fix -> weeks :)
18:37:23 * SergeyLukjanov thinking about open bugs targeted to 0.3
18:38:23 <aignatov_> tmckay, I see to bugs related to edp: https://bugs.launchpad.net/savanna/+bug/1235229
18:38:23 <aignatov_> https://bugs.launchpad.net/savanna/+bug/1237434
18:38:47 <aignatov_> all of them are related to edp validation
18:38:48 <SergeyLukjanov> mattf, could you help to organize this voting?
18:39:11 <mattf> SergeyLukjanov, sure, i'll take the action
18:39:38 <mattf> i'll use savanna contributors as the electorate
18:40:04 <SergeyLukjanov> mattf, thx, I think that the right time to start it about the Oct 20 and end till the Oct 27
18:40:15 <mattf> ok
18:41:20 <SergeyLukjanov> or a week earlier, let's discuss it afterwards
18:41:33 <mattf> sure thing
18:42:07 <SergeyLukjanov> any questions or suggestions about design summit?
18:43:02 <ruhe_> i'd suggest to combine several topics into "production quality". for instance topic suggested by jmaron will qualify for that
18:44:02 <SergeyLukjanov> btw I think that we'll be able to include most of the proposed topics
18:44:26 <SergeyLukjanov> ok, let's move on
18:44:42 <SergeyLukjanov> #topic General discussion
18:46:59 <SergeyLukjanov> who are planning to attend OpenStack Summit in Hong Kong?
18:47:01 <SergeyLukjanov> o/
18:47:11 <aignatov_> o/
18:47:26 <jmaron> From HWX currently just John Speidel
18:47:34 <mattf> i'm doing the passport dance atm. turns out mine expires w/i a month after summit.
18:48:09 <aignatov_> Trevor or Chad?
18:48:23 <mattf> tbd
18:48:29 <crobertsrh> :)
18:49:00 * crobertsrh has a fully up to date passport :)
18:50:44 <ruhe_> we need Savanna Foundation to fund every ATC to travel to every OS summit :)
18:50:59 <SergeyLukjanov> :)
18:51:03 <aignatov_> lol
18:51:14 <SergeyLukjanov> we need a huge donations for doing it :)
18:51:33 <mattf> i heard they are re-running their pass script because it caught ATC before savanna was accepted. can anyone confirm?
18:52:47 <SergeyLukjanov> I heard that it's not possible due to the end of discount period for summit registration...
18:52:55 <SergeyLukjanov> (Oct 4)
18:54:32 <SergeyLukjanov> anything more to discuss?
18:57:38 <SergeyLukjanov> ok, let's end meeting
18:57:56 <SergeyLukjanov> thank you all
18:58:02 <SergeyLukjanov> #info JFYI you can always use openstack-dev@lists.openstack.org mailing lists and #savanna irc channel to find us and ask your questions
18:58:05 <SergeyLukjanov> #endmeeting